Jump to content

Alpha 26 Pre-release/Release Candidate Build Testing


Recommended Posts

4 hours ago, andy5995 said:

ActorEditor works when I use use the -editor argument or select scenario editor from the main menu.

@hyperionExcuse me, that's wrong. You're right, it's not accessible without decompressing the appimage. I don't know of any way to make it more accessible than by extracting the appimage (--appimage-extract), cd to '/squashfs-root/usr/bin' and run ./ActorEditor'.

Link to comment
Share on other sites

41 minutes ago, andy5995 said:

@hyperionExcuse me, that's wrong. You're right, it's not accessible without decompressing the appimage. I don't know of any way to make it more accessible than by extracting the appimage (--appimage-extract), cd to '/squashfs-root/usr/bin' and run ./ActorEditor'.

Right in-game scenario editor is Atlas (-atlas option). Well, appimages have exactly one payload application but that could also be a shell script passing args to pyrogenesis unless there is an option -editor in which case it would run ActorEditor or in case of -h, --help print the readme.txt in binaries/system.

  • Thanks 1
Link to comment
Share on other sites

18 hours ago, andy5995 said:

Thanks for the feedback. Can you extract the appimage and see what your fps is? You can use './Name_of_app_image --appimage-extract' and then cd to 'squashfs-root' and enter './AppRun' to execute pyrogenesis.

Still same. Seems to be performance regression of a26.

  • Thanks 1
Link to comment
Share on other sites

1 hour ago, Stan` said:

Can you upload your logs? Were you using prefer glsl?

 

0ad-logs.tar.gz I'm using OpenGL with GLSL. Something must have happened after I did the the shadow map logic fix. I remember having a very smooth 60-75 fps all maxed out but now it's only around 25.

Link to comment
Share on other sites

I would love to see the functionality of the bell changed. This is not an urgent feature to change. But I think it is possible to give more choice.

For the woman we can diversify the bell a bit. For example 2 buttons : 1 button for bell for food woman production and second bell for woman wood production. But the issue is what about idle woman???

Second option : 2 bell, 1 little and 1 big -> the first for the area of civic center and the second for a big area like the P1 zone of CC. for avoid woman run very far for house with the little bell

After for the troops we can imagine a new button directly on troop. Not in building.  "Training Time" -> units move towards production buildings + fort + cc. 30 second cooldown to avoid boring micro/teleport battles.

Do not create anything op. If a player chooses to defend themselves by taking a losing fight, that's the game. But it allows you to create a panic button to give a second wind to the defender.

 

:) 

Link to comment
Share on other sites

11 minutes ago, Karmo said:

Something must have happened after I did the the shadow map logic fix.

Which fix do you mean?

11 minutes ago, Karmo said:

I remember having a very smooth 60-75 fps all maxed out but now it's only around 25.

There might be multiple reasons (including driver updates). Could you run the game, get 25FPS and press Shift + F11? There will appear a profile.txt file in logs folder, could you attach it here.

Also do you have installed A25 to compare?

Link to comment
Share on other sites

9 minutes ago, vladislavbelov said:

Which fix do you mean?

There might be multiple reasons (including driver updates). Could you run the game, get 25FPS and press Shift + F11? There will appear a profile.txt file in logs folder, could you attach it here.

Also do you have installed A25 to compare?

This fix: https://code.wildfiregames.com/rP26983
I'm quite sure at this commit performance was equal between a25 and a26. Unfortunately I don't have a dev setup anymore but can create it again soon to investigate.

I have a25 installed and it runs about 2.5x faster with every settings than latest a26 (except with very high shadows at hi res that was buggy in a25). Didn't do any major driver or kernel updates meanwhile.profile.txt

Link to comment
Share on other sites

10 minutes ago, vladislavbelov said:

I see you have set Anisotropic filtering to x16 (which is x2 by default, like it was in A25). Could you switch it to x2 and compare the performance?

If I change from x16 to x2 I get 27 fps instead of 25.

Profiled a25 with high shadows due to shadow map issue there.
profile.txt

Link to comment
Share on other sites

33 minutes ago, Karmo said:

Profiled a25 with high shadows due to shadow map issue there.
profile.txt

A26 profile.txt is also with high shadows, right?

A25 profile.txt says that it has everything faster, not particularly graphics (and pretty stable magnitude for mostly everything).

1 hour ago, Karmo said:

This fix: https://code.wildfiregames.com/rP26983
I'm quite sure at this commit performance was equal between a25 and a26.

There were no graphics or engine related commit after that one. So it seems more related to AppImage itself (maybe some optimizations are missed in the build). Could you attach system_info/hwreport for A25 too?

Link to comment
Share on other sites

8 hours ago, Dakara said:

Second option : 2 bell, 1 little and 1 big -> the first for the area of civic center and the second for a big area like the P1 zone of CC. for avoid woman run very far for house with the little bell

This sounds nice. I think keeping the current bell functionality but making the area that the bell impacts would work (and then a second click that make it apply to a larger area). 

Edited by chrstgtr
  • Like 1
Link to comment
Share on other sites

After many single player matches I cannot identify anymore bugs. Wow, congratulations to all developers! Would there be a forth release candidate, I would test it as well, but I really hope for the real release to play tons of multiplayer matches.

  • Like 2
Link to comment
Share on other sites

Resolved: See the update at the end of this post for a description of how this problem was resolved.

There is still a bug where the mouse jumps to a different monitor when scrolling the map. This didn't happen with alpha 0.0.25.

Note that I've only tested the release candidates.

Steps to reproduce:

1. Ensure that two monitors are connected to your Linux computer, one is 1920x1080, the other is 1280x1024 max resolution.

2. Determine where to move the mouse in order to cause the cursor to appear at the second monitor. Let's call this area the "junction" between the monitors. It's probably the left or right edge of the primary monitor.

3. Move the mouse cursor to the secondary monitor, configure that monitor as the "primary" monitor with an xrandr command that toggles the primary monitor. See the attached shell script for that xrandr command.

3. Start 0ad alpha 26, ensure that it is configured to full screen instead of windowed, begin a game simulation, move the mouse to the edge of the screen, at the "junction" between the monitors, in order to scroll the camera frame, also known as scrolling the map. Stop scrolling, then resume scrolling. Continue alternating this, perhaps also varying the speed that you move the mouse.

Expected results: the camera frame scrolls.

Actual results: usually the camera frame scrolls. Sometimes the cursor jumps to the other monitor and the camera frame stops scrolling. It's necessary to move the cursor back to the monitor where 0ad is displayed in order to regain the ability to scroll the camera frame.

The problem is intermittent. I find that playing the game normally for about 10 minutes, scrolling at the junction occasionally, makes the problem evident.

It may be possible to reproduce the symptoms with simpler steps.

 

Update: The problem was caused by the SDL library version that I was using. It was fixed by changing the version of the SDL library that I had installed. Discussion here.

set-primary-monitor.sh

Edited by Norse_Harold
Added problem resolution
  • Thanks 1
Link to comment
Share on other sites

0ad-nopadbox.jpg.679a3fc38ed4d8fb5feac5be716570d6.jpg

Besides that I think there should be a line break before "Interval", and that it should be indented at least like "Trunk" if not a step further, I really think there should be some padding to the box border and it really, really never should be possible that the text even goes outside the box.

Link to comment
Share on other sites

9 hours ago, phosit said:

"It does not always capture the curser" is it that what you are saying?

No, it's not what I'm saying. That sounds like a different issue from what I'm observing.

What I'm saying is that the game captures the cursor every time I startup the game and/or toggle it to full screen mode. However, it doesn't always keep the cursor captured when the mouse is at the "junction" between two monitors.

I'm not using Wayland for X rendering.

Edited by Norse_Harold
Link to comment
Share on other sites

3 hours ago, Norse_Harold said:

What I'm saying is that the game captures the cursor every time I startup the game and/or toggle it to full screen mode. However, it doesn't always keep the cursor captured when the mouse is at the "junction" between two monitors.

I also tryed to describe this but wasn't that precise.

Link to comment
Share on other sites

  • maroder unpinned this topic
  • Stan` unfeatured this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...