Jump to content

Recommended Posts

Is anybody working on the lag problem?

Seems to me this is the #1 issue that should be addressed. Or, is this an issue that will NEVER be addressed?

Why have the capability of Very Large maps when you can't play a Very Large map with anywhere close to amount of stuff you would want to have going on.

I've made several maps that are awesome looking, but when you play them it just lags you to the point of quitting.

Link to post
Share on other sites
1 hour ago, nsg3 said:

Is anybody working on the lag problem?

Seems to me this is the #1 issue that should be addressed. Or, is this an issue that will NEVER be addressed?

Why have the capability of Very Large maps when you can't play a Very Large map with anywhere close to amount of stuff you would want to have going on.

I've made several maps that are awesome looking, but when you play them it just lags you to the point of quitting.

Guy that disrespectful way to comment something.

1: This issue is already being addressed in Alpha 24.

2: Everyone involved in 0ad is a volunteer so complex things like this take longer.

Edited by Lopess
  • Like 2
Link to post
Share on other sites
50 minutes ago, OptimusShepard said:

I think, these are the two most interesting patches. Feel free, to help testing and reviewing, to speed up the development progress.

https://code.wildfiregames.com/D14

https://code.wildfiregames.com/D2528

I likely want to help testing, so i've got D14, patch and recompile the game (svn-revision 23846). Unfortunately this causes errors: at first, with "Shadows Very High" the game throws the known error:

D14_error.png.84437e8c574867824a86baeaa62948ee.png

Reducing the shadow-quality to high, the game starts without errors. Starting 4-player game (only KI), map "fields_of_meroe", gigantic, population unlimited. The game run a few minutes, fps up to ~ 90, gpu ~65%, cpu ~15%. But after 4-5 minutes it crashes without an error-message, no crashlog.txt or crashlog.dmp.

In the "Windows event display" i found this:

error_1.thumb.png.62fbc0a19aef6bba8cf7227323de66c4.png

error_2.thumb.png.9a1c393fe2f5674cfab94dab31167549.png

error_3.thumb.png.5b860cc0b16080473c8e2e0d4183a1a4.png

error_4.thumb.png.cc81d2ccf78e8779b0a700c04892ca49.png

 

the 5 links in the picture above are broken, but the last link i could open:

Report.wer

Maybe this will help you. I'm not sure, whether or not the patch is for A24.

Next i'll try D2528

 

Link to post
Share on other sites
26 minutes ago, Stan` said:

Does the error occurs every time with that patch ? Does it always crash? Can you run the game with visual studio attached?

Meinst Du, das Spiel aus der IDE heraus zu starten?

 

Link to post
Share on other sites
12 hours ago, Angen said:

Wir brauchen visual Studio so wir können Stacktrace sehen.

He starts 0 A.D. allready in VS, as you can see in his video. But I guess, he don't know (same as me) how to get the stacktrace. So maybe you could explain him, how to do?

Edited by OptimusShepard
Link to post
Share on other sites
1 hour ago, Angen said:

Sie müssen 0ad mit Visual Studio starten und dann 0ad abgestürzt lassen.

Dann sollten Sie in Visual Studio die aufrufListe sehen. 

Hallo Angen,

ich bin "Du" nicht "Sie" :)

ich habe gerade ein neues Spiel gestartet und werde nach einem Absturz dir die Informationen senden.

Link to post
Share on other sites
1 hour ago, Angen said:

Sie müssen 0ad mit Visual Studio starten und dann 0ad abgestürzt lassen.

Dann sollten Sie in Visual Studio die aufrufListe sehen. 

Erstes Spiel heute morgen:

Das Spiel ging in den Fenstermodus und zeigte diesmal eine Fehlermeldung:

today_pyrogenesis_error.txt

Visual Studio Debug:

error_01.thumb.png.4d55bd3fb3e304f9d5e66f7982c10a08.png

 

Aufrufliste:

today_aufrufliste.txt

Debug Ausgabe:

today_output.txt

 

Link to post
Share on other sites
On 7/17/2020 at 8:13 PM, Mr.lie said:

But after 4-5 minutes it crashes without an error-message, no crashlog.txt or crashlog.dmp.

Ich habe eben nochmals den Patch mit der aktuellsten SVN getestet. Nach 14min ohne Crash hab ich das Spiel dann beendet. Vielleicht gab es da einfach kurzzeitig einen Fehler in der SVN der jetzt behoben wurde. Wenn du Lust hast kannst du das gerne nochmals testen. Schau vielleicht, dass du vorher noch einen Cleanup machst damit du sicher bist, dass der Crash nicht durch irgendwelche Codereste/Überbleibsel ausgelöst wird. Ansonsten, falls du das "large addresse" Flag (https://trac.wildfiregames.com/wiki/premake) bereits gesetzt hast, hab ich leider auch keine Idee mehr (nicht mein Metier). Dass das Spiel ohne Crashlog crasht hört sich für mich zumindest mal nach dem fehlenden Flag an.

 

I have tested the current svn with that patch without crashes. Maybe there was a problem, and it's gone now. Maybe you want to test it again? Else, did you set the "large addresse" flag?

Link to post
Share on other sites
2 hours ago, OptimusShepard said:

Ich habe eben nochmals den Patch mit der aktuellsten SVN getestet. Nach 14min ohne Crash hab ich das Spiel dann beendet. Vielleicht gab es da einfach kurzzeitig einen Fehler in der SVN der jetzt behoben wurde. Wenn du Lust hast kannst du das gerne nochmals testen. Schau vielleicht, dass du vorher noch einen Cleanup machst damit du sicher bist, dass der Crash nicht durch irgendwelche Codereste/Überbleibsel ausgelöst wird. Ansonsten, falls du das "large addresse" Flag (https://trac.wildfiregames.com/wiki/premake) bereits gesetzt hast, hab ich leider auch keine Idee mehr (nicht mein Metier). Dass das Spiel ohne Crashlog crasht hört sich für mich zumindest mal nach dem fehlenden Flag an.

 

I have tested the current svn with that patch without crashes. Maybe there was a problem, and it's gone now. Maybe you want to test it again? Else, did you set the "large addresse" flag?

Ich habe soeben nochmals D14 angewendet, das "large-address-aware"-flag explicit gesetzt und neu compiliert. Während das Spiele läuft, als erstes die gute Nachricht:

Das Spiel startet mit "Schattenqualität - Sehr hoch", also maximum ohne die obligatorische Warnmeldung". :):):) Das ist schon mal erste Sahne! Mal sehen, wie lange das Spiel läuft :unsure:

 

  • Like 1
Link to post
Share on other sites
13 hours ago, Mr.lie said:

Ich habe soeben nochmals D14 angewendet, das "large-address-aware"-flag explicit gesetzt und neu compiliert. Während das Spiele läuft, als erstes die gute Nachricht:

Dann lag es vermutlich tatsächlich am fehlenden Flag. Ohne dem geht dir schnell der Speicher aus. In der Release Version ist das Flag gesetzt, in der SVN Version nicht. Ohne Flag lassen sich wohl leichter Speicherfehler finden.

 

So I think, the issue was actually the missing flag. The release version includes this flag. The developers version not, for developing reasons. 

13 hours ago, Mr.lie said:

Das Spiel startet mit "Schattenqualität - Sehr hoch", also maximum ohne die obligatorische Warnmeldung". :):):) Das ist schon mal erste Sahne! Mal sehen, wie lange das Spiel läuft :unsure:

Der Patch sollte eigentlich nur die Performance erhöhen in dem die Wegberechnung der Einheiten auf verschiedene Kerne aufgeteilt wird. Ich drück dir aber die Daumen, dass der Framebuffer Fehler nicht wieder auftritt. Hab den Fehler leider selber auch. Denke aber nicht dass der so bald gefixt wird, den gibts schon etwas länger.

 

The patch should only speed up the game by threading the pathfinder. But I hope, you can go on playing your game without the framebuffer bug :)

Link to post
Share on other sites

Leider gibt's auch schlechte Nachrichten:

Heute nacht habe ich ein Spiel laufen lassen (Bottnischer Meerbusen, groß, 5 Spieler, Population unbeschränkt). Heute morgen war das Spiel abgestürzt (es hat etwa 1:04:00 Std. gelaufen). Ich habe zunächst nach den Log-Dateien gesucht:

Eine ellenlange "mainlog.html" mit folgenden letzten Einträgen:

grafik.thumb.png.d1844dbfc955fd8844b440fd2fce4fb8.png

D14_mainlog.html

Die Windows-Ereignisanzeige zeigte diesmal, im Gegensatz zum letzten Mal, nicht die VCRuntime Dll als fehlerhaftes Modul, sondern Pyrogenesis.exe selbst.

grafik.thumb.png.d192844e843d228c934ba4fc2ce87e3f.png

Als ich die Wiederholung gestartet hatte und sie beendet war, war die folgende Fehlermeldung am Ende der "mainlog.html" zu sehen:

grafik.thumb.png.aa3323a1ba3bfe4a316b22f1b6ee940b.png

D14_mainlog_replay.html

 

Dannn habe ich nochmal 3 Spiele mit den selben Konditionen laufen lassen, aber diesmal aus der Visual Studio IDE heraus.

Alle 3 Spiele sind ohne Fehler oder Abstürze durchgelaufen! Und alle haben jeweils mehr wie eine Stunde gelaufen!

Vielleicht muss ich beim erstellen ausser dem "large-address-aware"-flag" noch etwas anderes ändern :unsure: !?

Vielleicht helfen Dir diese Angabe ja etwas.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...