Jump to content

Recommended Posts

  • Replies 74
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Grass doesn't grow faster when you pull it.

Since a few days i noticed a flickering in game: 0 A.D. 2020-06-06 18-15-55.mp4   Any idea, why this happens? Thanks.

Agreed that it looks like z-fighting in the shadow map (this sounds more epic than it is btw :p ) Did this never happen before? Is that just on this one map? What happens if you lower the shadow

Posted Images

5 hours ago, vladislavbelov said:

Not yet :)

Steps:

  1. Zoom in the place where you continuously reproduce the flickering
  2. Open the developer panel (Alt + D) and enable the "Lock cull camera" checkbox
  3. Zoom out to see the whole shadow boxes
  4. Take a screenshot

 

I'll hope this time it's correct :unsure:

grafik.thumb.png.a79452c09d0583c020e6503d776bb9f6.png

 

grafik.thumb.png.f1b12eacc5dcf464c1058b0fe2821969.png

Link to post
Share on other sites
1 hour ago, vladislavbelov said:

Yeah, that's the correct picture. Now questions: a) do you see flickering from that distance? b) do the boxes flicker (their sizes are changing along the sun direction)?

I have to revert the changes i've made, so the "flickering" will appear again. Then i will record it. I'll do that as soon as possible. Thank you for your patience.

Link to post
Share on other sites

Sorry for the delay,

but YouTube Studio needs much time to convert the video;), so i will embed the Video only in SD.

What i've done to get the "flickering":

1. revert the game to rev. 23718

2. don't commented out the line <mesh>skeletal/celt_trader.dae</mesh> , because when it is commented out the flickering never occurs.

3. the result:

I'll hope i've it done correctly :unsure:

 

Edited by Mr.lie
  • Thanks 1
Link to post
Share on other sites
1 hour ago, Mr.lie said:

Sorry for the delay,

but YouTube Studio needs much time to convert the video;), so i will embed the Video only in SD.

What i've done to get the "flickering":

1. revert the game to rev. 23718

2. don't commented out the line <mesh>skeletal/celt_trader.dae</mesh> , because when it is commented out the flickering never occurs.

3. the result:

I'll hope i've it done correctly :unsure:

Thank you very much, you've done that perfectly!

Yeah, I was right, jumping bounding boxes appear on the video. It seems celt_trader commit has tweaked that behaviour.

  • Thanks 1
Link to post
Share on other sites

Can you try with that file and see if it happens again?

I went a bit overboard, and the trader mesh was actually 360m below the ground (180m in game units) now it's 5 (2.5 in game units) and should be a lot better? Just check that it doesn't flicker anymore, no need to record fancy stuff :)  If it works I'll commit it tomorrow.

celt_trader.dae

  • Thanks 1
Link to post
Share on other sites

Hello again,

i don't want to steal your precious time, but there is another small issue. Playing the game as in the videos above with my Tropical-Biome i noticed a ugly "flimmer" related to the entities and/or actors "banyan" and "teak" and maybe "palm_tropical". I've recorded a small video, but i have to upload it here, because after uploading it to YouTube and converting the issue is not so easy to see. Also there is a difference between open the video with VLC or Microsoft Filme & TV (the last shows it more excactly). The video is recorded in Atlas, but playing the game is just the same :

After replacing banyan and teak with other trees without changing anything else, there is no "flimmer" except the palm_tropical.

 

:

Maybe it's because the banyan and teak are more complex :unsure:?

 

Edited by Mr.lie
  • Thanks 1
Link to post
Share on other sites

What i've figured out:

i just activated "Delenda Est" and played the map "Hydaspes River" which also contains Banyan and Teak. There is no "flimmer". Starting again my Map the "flimmer" always occurs, but not that bad as without Delenda Est. Maybe it has something to do with my Enviroment-Settings in the biome-file :unsure:

Link to post
Share on other sites

Btw, i'm glad to inform you, that, while experimenting, i figured out, that the following Windows Display-Settings causes the "flimmern" posted in another topic:

grafik.thumb.png.85afbc914a8451b4250d2cfba21f7256.png

With this settings "150% (empfohlen)" there is absolut no "flimmern". Before i use "100%".

This does the trick.

NO MORE FLIMMER:

 

 

  • Thanks 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...