Jump to content

Increasing zoom?


Recommended Posts

Thank you! According to \binaries\data\config\default.cfg

[view] ; Camera control settings
zoom.min = 50.0
zoom.max = 200.0
zoom.default = 120.0

However, when I put zoom.max = 1000.0 into \0ad\config\local.cfg, I don't get closer than this:

grafik.png.14d7c2cce69a55b2081a37f043f42869.png

Is I also put gui.scale = 1.5 there and see its effect in the GUI scale, the file seems to be in the right place. But the max. zoom factor does not seem to have any effect. Shouldn't local.cfg override default.cfg?

 

Edit: When starting 0 A.D. (SVN) with this parameter, where is the local.cfg file stored?

 
-writableRoot store runtime game data in root data directory
(only use if you have write permissions on that directory)

 

Besides, see there about the GUI scale and there: https://code.wildfiregames.com/D3037

Edited by Ceres
Link to comment
Share on other sites

38 minutes ago, Ceres said:

When starting 0 A.D. (SVN) with this parameter, where is the local.cfg file stored?

I believe for linux, it is at:

~/.config/0ad/config/

For windows,

Appdata/local/0ad/config

or Appdata/roaming/0ad/config 

(Again, I haven't used windows in a long time so I don't know for sure, but if I remember correctly they were in appdata)

 

You need to create the file by yourself. It is not included by default.

Edited by Yekaterina
  • Thanks 1
Link to comment
Share on other sites

I created the file:

Quote

 

However, when I put zoom.max = 1000.0 into \0ad\config\local.cfg, I don't get closer than this:

grafik.png.14d7c2cce69a55b2081a37f043f42869.png

Is I also put gui.scale = 1.5 there and see its effect in the GUI scale, the file seems to be in the right place. But the max. zoom factor does not seem to have any effect. Shouldn't local.cfg override default.cfg?

 

The GUI scale change works, but the max. zoom change has no effect.

PS: When I enable the dev overlay (alt+d) and untick "Restrict camera", the zoom works ("endlessly").

Edited by Ceres
Link to comment
Share on other sites

When using the "-writableRoot" parameter on Debian, the file ~/.config/0ad/config/local.cfg does not have any effect, but it does without that parameter. However, only the GUI scale (switch between 1.0 and e.g. 1.2) shows an effect. The max. zoom settings does not show any effect when zooming. Here is my local.cfg:

gui.scale = 1.2
zoom.max = 500.0

Any further ideas? Thank you! :)

Link to comment
Share on other sites

Just now, Ceres said:

When using the "-writableRoot" parameter on Debian, the file ~/.config/0ad/config/local.cfg does not have any effect, but it does without that parameter. However, only the GUI scale (switch between 1.0 and e.g. 1.2) shows an effect. The max. zoom settings does not show any effect when zooming. Here is my local.cfg:

gui.scale = 1.2
zoom.max = 500.0

Any further ideas? Thank you! :)

I think you need the semi-colon sign at the end of each line. 

If it still doesn't work, maybe insert the local.cfg at where you found default.cfg  (0ad/binaries/config)

  • Thanks 1
Link to comment
Share on other sites

@Stan` When zooming in, it's keeping the screen centre in focus. However, if one is interested to zoom in to a unit or just an area not in the centre, after zooming in, one has to move there (or vice versa). Would it make sense to have a toggleable zoom function, so a selected unit or area is kept in the centre of the screen, even if not originally in the screen centre? (e.g. Alt + scroll wheel)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...