Jump to content

how to 4K screen setup video mode


Recommended Posts

Hi,

You need to create file in this location:

On Linux, create:                                          *
; *   $XDG_CONFIG_HOME/0ad/config/local.cfg                    *
; *   (Note: $XDG_CONFIG_HOME defaults to ~/.config)           *
; *                                                            *
; * On OS X, create:                                           *
; *   ~/Library/Application\ Support/0ad/config/local.cfg      *
; *                                                            *
; * On Windows, create:                                        *
; *   %appdata%\0ad\config\local.cfg      

for windows 10 it is: C:\Users\Username\AppData\Roaming\0ad\config

file local.cfg with:

gui.scale = "1.2" 

and experiment with value a bit

Edited by Angen
  • Like 2
Link to post
Share on other sites

Yes, 0 A.D.'s GUI is designed to be 1024×768. I also have a 3840×2160 screen and I'm using

gui.scale = 1.875

because I prefer to be able to play the game at half a screen; if you want the GUI to be exactly 3840 pixels wide, set it to 3.75; you'd probably want a lower value, though.

The location of your configuration file depends on your operation system (see https://trac.wildfiregames.com/wiki/GameDataPaths ); on mine (Fedora 28) it's `~/.config/0ad/config/user.cfg`

 

This is not the first time someone asked. Perhaps a FAQ page should be made. Or add the ability to set the `gui.scale` in game under options.

  • Like 3
Link to post
Share on other sites
1 hour ago, Nescio said:

This is not the first time someone asked. Perhaps a FAQ page should be made. Or add the ability to set the `gui.scale` in game under options.

Yeah this was planned. I also made a bot with generic answers for question asked on IRC but my attempt to host it on my raspberry failed. And I haven't seen progress on the FAQ in a while. Maybe it could be integrated in the new website design @implodedok

The GUI scale option sounds like a good idea. Using hwdetect would work too.

  • Like 1
Link to post
Share on other sites

Many thanks to you Angen, Nescio and Stanislas69 who replied so quickly.

I did as indicated and it did the trick!

For my personal taste I used factor 2 for the gui.scale.

Would be great indeed having these features somewhere. I was expecting to find it under settings.options.graphics in main menu window, but I am just a casual gamer and other place might fit better.

In the meantime, having this information under FAQ would certainly help.

Thanks again.

Gonna play and test it further now.

Cheers,

Roberto

PS FYI forgot to mention that I use Ubuntu as operating system.

  • Like 3
Link to post
Share on other sites
  • 2 years later...

Hi@all,

I want to play 0.A.D. under Ubuntu 20.04 on my laptop with HiDPI display (3840x2160) But the font in the game is not visible and much too small.

I have tried the solution mentioned here and the file:

~/.config/0ad/config/local.cfg

with the content:

gui.scale = 1.8

I tried different values and also renamed the file to user.cfg. But nothing changes in the game. What am I doing wrong?

 

with best

pixel24

Link to post
Share on other sites

ok, I found the problem. If you install 0.A.D in the Ubuntu Software Center it will be installed as SNAP. Thereby ~/.config/0ad is not created. Creating it afterwards has no effect.
Remove 0.A.D. in the Software Center and install 0ad with apt install. After that .config/0ad/config/user.cfg exists and you can set the value gui.scale.

Now I can explore the game :-)

Link to post
Share on other sites
  • 2 months later...
On 02/09/2018 at 4:48 PM, Stan` said:

Yeah this was planned. I also made a bot with generic answers for question asked on IRC but my attempt to host it on my raspberry failed. And I haven't seen progress on the FAQ in a while. Maybe it could be integrated in the new website design @implodedok

The GUI scale option sounds like a good idea. Using hwdetect would work too.

hello thank you for the help but i dont see gui. scale in the readme file do i just need to type it in there i ask becouse you say change it ?

Link to post
Share on other sites

Force a particular resolution. (If these are 0, the default is
; to keep the current desktop resolution in fullscreen mode or to
; use 1024x768 in windowed mode.)
xres = 0
yres = 0

 

 im trying to get higher resolution it is blocky 

saw some  4k footage on youtube and it looks better 

was just wondering if it was posible 

 

 

 

Link to post
Share on other sites
2 minutes ago, Stan` said:

I'm not sure I understand. It uses your screen resolution by default

Not completely right. If you are using Windows and you have scaled your Windows, the game doesn't use the correct resolution. Than the game resolution is:

resolution = Windows_resolution / Windows_scale

You can solve this by changing the properties of pyrogenesis.exe  properties -> Compatibility-> High-DPI settings -> enable "overwrite high DPI scaling" 

Link to post
Share on other sites
7 minutes ago, maximusbullet said:

Force a particular resolution. (If these are 0, the default is
; to keep the current desktop resolution in fullscreen mode or to
; use 1024x768 in windowed mode.)
xres = 0
yres = 0

 

 im trying to get higher resolution it is blocky 

saw some  4k footage on youtube and it looks better 

was just wondering if it was posible 

 

 

 

That doesn't work in FullScreen mode anymore sadly, it's only for windowed.

Link to post
Share on other sites
8 minutes ago, maximusbullet said:

im trying to get higher resolution it is blocky 

saw some  4k footage on youtube and it looks better 

was just wondering if it was posible 

Your graphics driver may have the feature "virtual super resolution". If you enable this, you can change the resolution for your Windows, and so the game resolution too.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...