Jump to content
Sign in to follow this  
alchemy

[Resolved] Access violation reading 0x8801FF40

Recommended Posts

hi

on windows10 with standard installation, i have this incident :

after running the game, and choosing "solo", "match", "begin", and after reach the 100% preparing game.

i run the game with admin rights and i try to run it with other compatibilities

thank you.

-------------------------------------------------------------------------------------------------------------------------------

Much to our regret we must report the program has encountered an error.

Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Access violation reading 0x88007740)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)
errno = 0 (No error reported here)
OS error = 0 (no error code was set)

-----------------------------------------------------------------------------------------------------------------------------------

when i break it , i have this message

-----------------------------------------------------------------------------------------------------------------------------------

Details: unhandled exception (Breakpoint)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)
errno = 13 (Insufficient access rights to open file)
OS error = 0 (no error code was set)
 

 

 

 

crashlog.dmp crashlog.txt

Edited by alchemy
resolved

Share this post


Link to post
Share on other sites
21 minutes ago, Imarok said:

Try disable GLSL and postprocessing in the options.

>	ig8icd32.dll!724fcaa1()	Unknown	Non-user code. No matching binary found.
 	[Frames below may be incorrect and/or missing, no symbols loaded for ig8icd32.dll]	Unknown	No symbols loaded.
 	pyrogenesis.exe!CShaderProgramGLSL::Link() Line 380	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderProgramGLSL::Reload() Line 465	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderManager::NewProgram(const char * name=0x003af1a0, const CShaderDefines & baseDefines={...}, std::shared_ptr<CShaderProgram> & program={...}) Line 271	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderManager::LoadProgram(const char * name=0x003af1a0, const CShaderDefines & defines={...}) Line 68	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderManager::NewEffect(const char * name=0x001ad0d8, const CShaderDefines & baseDefines={...}, std::shared_ptr<CShaderTechnique> & tech={...}) Line 545	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderManager::LoadEffect(CStrIntern name={...}, const CShaderDefines & defines1={...}, const CShaderDefines & defines2={...}) Line 369	C++	Symbols loaded.
 	pyrogenesis.exe!CShaderManager::LoadEffect(CStrIntern name={...}) Line 351	C++	Symbols loaded.
 	pyrogenesis.exe!SkyManager::RenderSky() Line 262	C++	Symbols loaded.
 	pyrogenesis.exe!CRenderer::RenderSubmissions(const CBoundingBoxAligned & waterScissor={...}) Line 1538	C++	Symbols loaded.
 	pyrogenesis.exe!CRenderer::RenderScene(Scene & scene) Line 1897	C++	Symbols loaded.
 	pyrogenesis.exe!CGameView::Render() Line 489	C++	Symbols loaded.
 	pyrogenesis.exe!Render() Line 223	C++	Symbols loaded.
 	pyrogenesis.exe!CGame::ReallyStartGame() Line 319	C++	Symbols loaded.
 	pyrogenesis.exe!ProgressiveLoad() Line 279	C++	Symbols loaded.
 	pyrogenesis.exe!Frame() Line 364	C++	Symbols loaded.
 	pyrogenesis.exe!RunGameOrAtlas(int argc=1, const char * * argv=0x00620008) Line 634	C++	Symbols loaded.
 	pyrogenesis.exe!SDL_main(int argc=1, char * * argv=0x00620008) Line 680	C++	Symbols loaded.
 	pyrogenesis.exe!main_utf8(int argc=1, char * * argv=0x00620008) Line 126	C	Symbols loaded.
 	pyrogenesis.exe!wmain(int argc=1, unsigned short * * wargv=0x0019c310, unsigned short * wenvp=0x001a39c8) Line 151	C	Symbols loaded.
 	pyrogenesis.exe!__tmainCRTStartup() Line 623	C	Non-user code. Symbols loaded.
 	pyrogenesis.exe!CallStartupWithinTryBlock() Line 364	C++	Symbols loaded.
 	kernel32.dll!76f60419()	Unknown	Non-user code. Cannot find or open the PDB file.
 	ntdll.dll!7795662d()	Unknown	Non-user code. Cannot find or open the PDB file.
 	ntdll.dll!779565fd()	Unknown	Non-user code. Cannot find or open the PDB file.

Indeed that will fix the crash for you :)

  • Like 1

Share this post


Link to post
Share on other sites

Thank you !!

one : for so quickly answering (with good solution !)

two : for all the community for this good game !

thanks again

  • Like 1

Share this post


Link to post
Share on other sites

Weird @alchemy said he was using Windows 10 but the crashlog says: 

OS             : WinXP SP 3 (5.1.2600)
CPU            : x86,       Intel Pentium  N3700  @ 1.60GHz (1x4x1), 1.60 GHz
Memory         : 8192 MiB; 4615 MiB free
Graphics Card  : Intel Intel(R) HD Graphics
OpenGL Drivers : 4.4.0 - Build 20.19.15.4835; nvoglv32.dll (10.18.13.5923)
Video Mode     : 1600x900:32
Sound Card     : OpenAL Soft on Haut-parleurs (Realtek High Definition Audio); 
Sound Drivers  : 1.1 ALSOFT 1.17.1

 

Share this post


Link to post
Share on other sites
On 4/28/2019 at 9:03 AM, alchemy said:

i run the game with admin rights and i try to run it with other compatibilities

Maybe that could be the answer?

 

btw: Why does it say '1post' for @alchemywhen he has two posts in this thread already?

Share this post


Link to post
Share on other sites
27 minutes ago, Gurken Khan said:

btw: Why does it say '1post' for @alchemywhen he has two posts in this thread already?

Maybe @feneur would know. It would seem he joined the community after his first post. I think you can post as guest on the forum.

 

Share this post


Link to post
Share on other sites
4 hours ago, stanislas69 said:

Weird @alchemy said he was using Windows 10 but the crashlog says: 


OS             : WinXP SP 3 (5.1.2600)
CPU            : x86,       Intel Pentium  N3700  @ 1.60GHz (1x4x1), 1.60 GHz
Memory         : 8192 MiB; 4615 MiB free
Graphics Card  : Intel Intel(R) HD Graphics
OpenGL Drivers : 4.4.0 - Build 20.19.15.4835; nvoglv32.dll (10.18.13.5923)
Video Mode     : 1600x900:32
Sound Card     : OpenAL Soft on Haut-parleurs (Realtek High Definition Audio); 
Sound Drivers  : 1.1 ALSOFT 1.17.1

 

I'm not sure that's in the case. But we have wrong Windows version detection. We can't detect Windows 10 correctly.

Share this post


Link to post
Share on other sites
1 minute ago, vladislavbelov said:

I'm not sure that's in the case. But we have wrong Windows version detection. We can't detect Windows 10 correctly.

True, but in this case it would put Windows 8.1 like this (My current computer runs w10)

OS             : Win8.1  (6.3.9200)
CPU            : x86, Intel Core i7-6820HQ @ 2.70GHz (1x4x2), 2.71 GHz
Memory         : 32768 MiB; 17838 MiB free
Graphics Card  : NVIDIA Quadro M620/PCIe/SSE2
OpenGL Drivers : 4.6.0 NVIDIA 411.63; nvoglv32.dll (24.21.14.1163)
Video Mode     : 1024x768:32
Sound Card     : OpenAL Soft on Speakers / Headphones (Realtek Audio); 
Sound Drivers  : 1.1 ALSOFT 1.17.1

 

Share this post


Link to post
Share on other sites
41 minutes ago, Gurken Khan said:

Maybe that could be the answer?

You are right. Same config with XP SP2 Config. Worth noting than 95/98 appear as Windows 8.1

OS             : WinXP SP 2 (5.1.2600) / XP SP2 Compat
OS             : Win8  (6.2.9200) / Windows 8 Compat
OS             : Vista  (6.0.6000) / Vista no sp
OS             : Win7  (6.1.7600) / 7 compat
CPU            : x86, Intel Core i7-6820HQ @ 2.70GHz (1x4x2), 2.71 GHz
Memory         : 32768 MiB; 19902 MiB free
Graphics Card  : NVIDIA Quadro M620/PCIe/SSE2
OpenGL Drivers : 4.6.0 NVIDIA 411.63; nvoglv32.dll (24.21.14.1163)
Video Mode     : 1024x768:32
Sound Card     : OpenAL Soft on Speakers / Headphones (Realtek Audio); 
Sound Drivers  : 1.1 ALSOFT 1.17.1

 

Share this post


Link to post
Share on other sites
3 minutes ago, stanislas69 said:

You are right. Same config with XP SP2 Config

Also can it be the compatibility mode in Windows (where you can run an application with Windows XP compatibility)?

Share this post


Link to post
Share on other sites
1 minute ago, vladislavbelov said:

Also can it be the compatibility mode in Windows (where you can run an application with Windows XP compatibility)?

That's what I meant. He was on windows 10 he just tried XP compatibility

Share this post


Link to post
Share on other sites
4 minutes ago, stanislas69 said:

Maybe @feneur would know. It would seem he joined the community after his first post. I think you can post as guest on the forum.

 

No idea why, and unless it's been mistakenly enabled/done by someone else I don't think guests should be able to post anywhere in the forums. I made the forum software recount his posts so now it's correct though.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 4/30/2019 at 3:34 PM, feneur said:

I made the forum software recount his posts so now it's correct though.

I see that bug quite frequently (obviously only with very new users), and even at the risk of sounding rude I dare say I don't trust the counter at all! ;)

Maybe worth looking into?

Spoiler

0AD-forumop3.thumb.jpg.a53a191a4de260af699d0f2f4034d2f4.jpg

 

Share this post


Link to post
Share on other sites
16 minutes ago, (-_-) said:

Apparently, you can post as guests now. That might explain it.

Yeah I noticed that as well @feneur @implodedok maybe an update's side effect ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...