Jump to content
Sign in to follow this  
wowgetoffyourcellphone

Ugh, okay, help

Recommended Posts

2 hours ago, wowgetoffyourcellphone said:

@mimoAfter latest AI phase changes, which actually work nicely for the Chinese and Imperial Romans, I get this for the Kushites:

 

WARNING: PlayerID 3 | Petra: requirement PyramidSmall for phase 2 not taken into account

:)   this message has been removed from the latest version. Are you sure that you have not kept the old phaseRequirements.js in your petra directory? this file should be removed (its content is now more generic, and has been reincluded in the other petra files).

From my tests, Kushites and Chinese work well, and Imperial Romans is a question of chance (the AI does not know yet how to interpret obstructions with Left/Right and believes it has no obstruction, so it may or may not succeed to position it depending on the terrain, will be fixed in a future commit).

PS Looking at your github, why do you have a shared.js in the ai directory? your serialization could be broken if you do not update it.

  • Like 1

Share this post


Link to post
Share on other sites

I have old files from testing various patches and trying new ideas and whatnot. Never said my repository was stable. ;)

 

Thanks for the reply. I deleted the AI directory in DE and still got that message though.

 

EDIT:

Quote

Are you sure that you have not kept the old phaseRequirements.js in your petra directory? 

A wild phaseRequirements.js appeared! Find it in the public mod. Was there after I applied and tested your first patch. Forgot to clean it out. :)

Edited by wowgetoffyourcellphone

Share this post


Link to post
Share on other sites
11 hours ago, mimo said:

Would we more useful if you would copy-paste here some of these warnings (in fact the first warnings you got).

This is the main warning I have encountered.

ERROR: JavaScript error: simulation/ai/petra/_petrabot.js line 106 TypeError: this.gameState is undefined m.PetraBot.prototype.OnUpdate@simulation/ai/petra/_petrabot.js:106:2 m.BaseAI.prototype.HandleMessage@simulation/ai/common-api/baseAI.js:64:2

Edited by Zeta1127

Share this post


Link to post
Share on other sites
49 minutes ago, Zeta1127 said:

This is the main warning I have encountered.

ERROR: JavaScript error: simulation/ai/petra/_petrabot.js line 106 TypeError: this.gameState is undefined m.PetraBot.prototype.OnUpdate@simulation/ai/petra/_petrabot.js:106:2 m.BaseAI.prototype.HandleMessage@simulation/ai/common-api/baseAI.js:64:2

That can't be the first error encountered? it is not the main one which is important, but the first one. Usually all followings warnings are just consequences and not useful to understand what could have happen.

  • Like 2

Share this post


Link to post
Share on other sites

Okay, lets try that again.

ERROR: JavaScript error: simulation/ai/common-api/entity.js line 29
TypeError: value is null
  m.Template<.get@simulation/ai/common-api/entity.js:29:1
  m.Template<.resourceSupplyType@simulation/ai/common-api/entity.js:348:8
  m.SharedScript.prototype.createResourceMaps@simulation/ai/common-api/terrain-analysis.js:400:35
  m.SharedScript.prototype.init@simulation/ai/common-api/shared.js:211:2
  InitGame@simulation/helpers/InitGame.js:78:2

 

Share this post


Link to post
Share on other sites
On 22/08/2017 at 1:53 AM, Darthvoider said:

in the map Fortress, the starter buildings and wall are athenian for all modded civs. also i don't know why the kushite pyramids look different for me than in the images

It seems there is some fallback to athen in maps/random/rmgen/wall_builder.js

You might look at adding your civ to the abobe block in the previous file.

var wallScaleByType = {
    "athen": 1.5,
    "brit": 1.5,
    "cart": 1.8,
    "gaul": 1.5,
    "iber": 1.5,
    "mace": 1.5,
    "maur": 1.5,
    "pers": 1.5,
    "ptol": 1.5,
    "rome": 1.5,
    "sele": 1.5,
    "spart": 1.5,
    "rome_siege": 1.5
};

 

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, fatherbushido said:

It seems there is some fallback to athen in maps/random/rmgen/wall_builder.js

You might look at adding your civ to the abobe block in the previous file.


var wallScaleByType = {
    "athen": 1.5,
    "brit": 1.5,
    "cart": 1.8,
    "gaul": 1.5,
    "iber": 1.5,
    "mace": 1.5,
    "maur": 1.5,
    "pers": 1.5,
    "ptol": 1.5,
    "rome": 1.5,
    "sele": 1.5,
    "spart": 1.5,
    "rome_siege": 1.5
};

 

var wallScaleByType = {
	"athen": 1.5,
	"brit": 1.5,
	"cart": 1.8,
	"chin": 1.5,
	"epir": 1.5,
	"gaul": 1.5,
	"iber": 1.5,
	"imp": 1.5,
	"kush": 1.5,
	"mace": 1.5,
	"maur": 1.5,
	"pers": 1.5,
	"ptol": 1.5,
	"rome": 1.5,
	"sele": 1.5,
	"spart": 1.5,
	"theb": 1.5,
	"rome_siege": 1.5
};

 

  • Like 1

Share this post


Link to post
Share on other sites

Getting this the past couple days. I don't think I've touched anything with the animations. Only happens in DE, not public.

 

ERROR: art/animation/quadraped/Croc_death.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_death.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_death.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_run.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_run.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_run.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_walk.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_walk.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_walk.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_attack.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_attack.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_attack.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_idle1.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_idle1.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_idle1.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_idle2.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_idle2.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_idle2.dae): Failed loading, marked file as bad

ERROR: art/animation/quadraped/Croc_idle3.dae: Assertion not satisfied (line 86): failed requirement "animation end frame must come after start frame"

ERROR: Could not load animation 'art/animation/quadraped/Croc_idle3.dae'

ERROR: CSkeletonAnimManager::GetAnimation(art/animation/quadraped/Croc_idle3.dae): Failed loading, marked file as bad

Share this post


Link to post
Share on other sites

I can't say I fully understand why, but it appears to be a conflict/problem with the file "art/skeletons/Trebuchet.xml" added to Delenda Est in commit id d34479ebc748 "Lots of Kushite stuff." This commit/file also causes errors when trying to load `fauna_shark`.

In addition, the `fauna_walrus` and `fauna_elephant_asian_infant` also give errors in DE and not in vanilla, but these appear to be issues with their templates.

  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, s0600204 said:

I can't say I fully understand why, but it appears to be a conflict/problem with the file "art/skeletons/Trebuchet.xml" added to Delenda Est in commit id d34479ebc748 "Lots of Kushite stuff." This commit/file also causes errors when trying to load `fauna_shark`.

In addition, the `fauna_walrus` and `fauna_elephant_asian_infant` also give errors in DE and not in vanilla, but these appear to be issues with their templates.

Okay, thanks. That is super weird. Why would the trebuchet skeleton have an impact on a different skeleton? I wonder.

Share this post


Link to post
Share on other sites

Actually there is a ticket for wall placement not being generic and a pain for mods. https://trac.wildfiregames.com/ticket/2944

Maybe @FeXoR will have some time to finish it & put it on Phabricator.

EDIT : Also https://trac.wildfiregames.com/ticket/2631

They look similar though.

Edited by stanislas69

Share this post


Link to post
Share on other sites

Two issues I'm having. I'm sure  I have some deprecated file somewhere.

 

  1. Glory is not being looted anymore. I once had this working, but now I'm not sure why it doesn't work anymore. All units have a little Glory as loot when they die. Not working.
  2. Wonder of the Ages aura does not work to increase the pop cap anymore. When you build or capture a Wonder, it's supposed to raise your pop cap by 10%.

Share this post


Link to post
Share on other sites
On 9/11/2017 at 6:19 AM, wowgetoffyourcellphone said:

Two issues I'm having. I'm sure  I have some deprecated file somewhere.

 

  1. Glory is not being looted anymore. I once had this working, but now I'm not sure why it doesn't work anymore. All units have a little Glory as loot when they die. Not working.
  2. Wonder of the Ages aura does not work to increase the pop cap anymore. When you build or capture a Wonder, it's supposed to raise your pop cap by 10%.

Anyone with the mod confirm?

Share this post


Link to post
Share on other sites
On 9/11/2017 at 6:19 AM, wowgetoffyourcellphone said:

Two issues I'm having. I'm sure  I have some deprecated file somewhere.

 

  1. Glory is not being looted anymore. I once had this working, but now I'm not sure why it doesn't work anymore. All units have a little Glory as loot when they die. Not working.
  2. Wonder of the Ages aura does not work to increase the pop cap anymore. When you build or capture a Wonder, it's supposed to raise your pop cap by 10%.

 

12 hours ago, Lion.Kanzen said:

works fine

2- Wonder of the Age

i cant confirm right now.

 

11 hours ago, wowgetoffyourcellphone said:

Yep, I tested the glory loot again and it works.

Wonder of the Ages doesn't work though.

 

 

I think I figured it out. At one point, the line 
    "type": "global",

Was changed to
    "type": "player",

In the Public mod. Or maybe it was always that way. I'm not sure. Any rate, "type": "global" worked at one point for the aura, but now does not. so, I changed DE's aura to player from global and it works. Now I'm wondering if I have other auras with type global that do not work and I haven't noticed.

Edited by wowgetoffyourcellphone

Share this post


Link to post
Share on other sites
1 minute ago, fatherbushido said:

Yes, already have that bookmarked. At one point, global worked for the aura. Now it does not. Or maybe I changed it to global accidentally. Don't know. All I know is that the aura used to work, stopped working, I changed it to player and now it works again. :)

Share this post


Link to post
Share on other sites

nevermind.

Michael left this in the repo.

Quote

his repository exists only as an archive for the now-defunct development of Delenda Est, a mod for 0 A.D. Empires Ascendant. I did not delete this archive so that other modders may have access to the files contained within.

 

Share this post


Link to post
Share on other sites

I'd rather have someone else fork this project than have someone else (other than the original team members) take over. But I'm not sure about the licensing issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...