Jump to content

Game increases speed and FPS freezes


Recommended Posts

Hello guys,

since 2-3 days the game randomly increases the gamespeed, then, when this happens, the fps freezes, and the screen doesn't refresh after screenshot-messages or other messages (see picture). Normally after making a screenshot the message disappears after few seconds. Also the workload of the GPU slows down, in my case down to 53% (normally it's up to 100%). Also, i'm not sure, but i mean, after this happens, my whole WINDOWS runs faster (open word, explorer, firefox etc.). After quitting the game and reload, all is fine.

Also since 2-3 days, the game randomly crashes and quits without any message. This never happens before. 

I use 0 A.D. SVN-Revision 23700, i update every day.

I'm sorry about my bad english, i try my best ;-) - please excuse me ...

Greeting from Germany, and pay attention to your health in this bad times!

Keep on your fantastic work , and ignore stupid opinions from people who mean, they know everything better than you experts ;-)

 

 

Screenshot_6.thumb.png.50a1f789373fdcd74ee0933b51625b58.png

 

  • Like 2
Link to post
Share on other sites

Yes.

AMD Ryzen 7 3700X 8-Core Processor

ASUS NVIDIA Geforce RTX 2070 Super

16 GB Memory

But, as i said, i have never problems before ... Just for interesting i have installed the "Ryzen-patch", but then the game crashes.

Link to post
Share on other sites

with this settings it's a absolute "hammer" graphics, and the game runs every day without errors. You have a fantastic game-engine and you all are eminently good artists ...:hi:

Edited by Mr.lie
Link to post
Share on other sites

The slowdown/speedup bug has nothing to do with graphics :)

If that doesn't annoy you sure you can continue playing that way :)

I'm curious what is the left panel in the last screenshot from :)

 

  • Thanks 1
Link to post
Share on other sites

For the "slowdown/speedup bug" i came to the conclusion, it happens mostly on more complex maps. Since 3 days i played the map "Islands" and the "slowdown/speedup bug" didn't even occur anymore. What do you think about that? :scratch_one-s_head:

Link to post
Share on other sites

@Mr.lie could you maybe use the Ryzen patch anyway? Every feedback to fix the problem is welcome ;)

https://code.wildfiregames.com/D2726

If you are interested in sharpening filter, you maybe want also to test this patch.

https://code.wildfiregames.com/D2642

Btw, you said, you don't like fxaa. Did you test fxaa + sharpening filter? Only using fxaa without sharpening is for me to blurry too.

Link to post
Share on other sites
1 hour ago, Mr.lie said:

For the "slowdown/speedup bug" i came to the conclusion, it happens mostly on more complex maps. Since 3 days i played the map "Islands" and the "slowdown/speedup bug" didn't even occur anymore. What do you think about that? :scratch_one-s_head:

Could you record a video on when that happen? (for AMD tech support)

Link to post
Share on other sites
5 hours ago, OptimusShepard said:

@Mr.lie could you maybe use the Ryzen patch anyway? Every feedback to fix the problem is welcome ;)

https://code.wildfiregames.com/D2726

If you are interested in sharpening filter, you maybe want also to test this patch.

https://code.wildfiregames.com/D2642

Btw, you said, you don't like fxaa. Did you test fxaa + sharpening filter? Only using fxaa without sharpening is for me to blurry too.

I do so soon ...

thanks

Link to post
Share on other sites
6 hours ago, OptimusShepard said:

@Mr.lie could you maybe use the Ryzen patch anyway? Every feedback to fix the problem is welcome ;)

https://code.wildfiregames.com/D2726

If you are interested in sharpening filter, you maybe want also to test this patch.

https://code.wildfiregames.com/D2642

Btw, you said, you don't like fxaa. Did you test fxaa + sharpening filter? Only using fxaa without sharpening is for me to blurry too.

Hi,

after apply patch D2642 the Option-Windows is changed as expected:

Screenshot_16.thumb.png.2820b9cba9d3c9b617da4e4e801b742f.png

 

But if i try using the slider "Sharpness factor" the following error occurs:

Pyrogenesis Log.html

after using the Dropdown "Sharpening"the following error occurs:

ERROR: JavaScript error: gui/options/options.js line 253 TypeError: Engine[option.function] is not a function displayOptions/control[optionType.guiSetter]@gui/options/options.js:253:5

ERROR: JavaScript error: Errors executing script event "SelectionChange"

Edited by Mr.lie
Link to post
Share on other sites
6 minutes ago, Stan` said:

Both patches need you to recompile the game, did you?

No, i didn't :self_hammer:

But, i think, this is an problem:

i have several times tried to recompile following https://trac.wildfiregames.com/wiki/BuildInstructions, because i'm very interested in programming (i'm a semi-professional programmer mainly in VB). Therefore i use Visual Studio Community 2017 and failed every time, because at that time 0ad only uses VC 2015. Then i installed Visual Studio 2015, but the build-process also failed (perhaps because i had VS2017 installed first).

6 minutes ago, Stan` said:

Both patches need you to recompile the game, did you?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...