Jump to content

Crash on map selection and hotkey problem


Recommended Posts

First I want to thank whoever makes this game. I enjoy it so much!

I have two bugs to report.

The OS of my laptop is Ubuntu 20.04, and the game version is as the following screenshot.


The first bug is the game crashes when I'm selecting the game map. Steps:

  1. Launch 0ad.
  2. Select Single-player > Matches
  3. Select "Random" in map type
  4. Select "Default" in map filter
  5. Select "Unknown" in select map
  6. Select "Scenario" in map type

Then, the game window is killed, but the audio is still played in background. Below is a part of the output of my terminal (full output is in attachment crash.txt):



The second bug is that the game window does not capture my left Ctrl key press. For example, I want to send my infantry to attack (not capture) an enemy's building, I should press Ctrl and right-click the building. However, the cursor changes to the attack icon only when I press right Ctrl. Another example is in the hotkeys settings. I want to change "session.attack" key mapping. I click on the current mapping, and it tells me to "Enter new key. Hold to register". When I press left Ctrl, it does not capture my key press, but it does if I press right Ctrl instead. By the way, when I press left Ctrl+Shift, it capture both key press correctly (display "Ctrl+Shift, hold to register").


Thank you so much!


Edited by chiffoncake
removing empty lines at the end of the post
Link to comment
Share on other sites

Thanks for your fast responding!

I think if left ctrl and right ctrl are different keys, the UI should tells whether the current settings is left or right. Showing simply "Ctrl" implies both left and right ctrl in my opinion.

Also, if it is intended, then I don't know how to make the key mapping use left ctrl. It would be very inconvenient if the only available ctrl key is right ctrl.

The attachment left.png and right.png is captured when I press left ctrl and right ctrl, respectively. I expect the game window should capture my left ctrl key press in left.png.





Edited by chiffoncake
Link to comment
Share on other sites

10:57 -!- Freagarach_work [Freagarach_work!webchat@cloak-y62wiuqh.fixed.kpn.net] has joined #0ad-dev
10:57 < Freagarach_work> Stan: Both Ctrl behave the same for me. As do Alt.
10:58 < Freagarach_work> Same as with my window manager.
10:58 -!- Freagarach_work [Freagarach_work!webchat@cloak-y62wiuqh.fixed.kpn.net] has left #0ad-dev (Work.)

Apparently it worked fine for them on Lubuntu, could this be a specificity of your desktop manager ?

Link to comment
Share on other sites

Maybe I might be a little late to the party and should have reported it earlier. I used to be on Linux mint 19 and now I am on Linux mint 20, famously based on Ubuntu.


On both systems I also experienced a similar bug. When I go to set up a game and try to select a map by clicking on the "browse maps" and go to the random maps. Then when I move the mouse over some maps, the game crashes.

Link to comment
Share on other sites

1 hour ago, Angen said:

@LetswaveaBook can you upload crashlog files?

I don't know if I found the correct crash files. To clean my logs, I renamed the directory



I ran 0ad in the teminal with the command

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=0ad com.play0ad.zeroad

Then 0ad started and I clicked on single player and on matches. There I selected "random" as the map type and clicked on "browse maps". I scrolled around for a little while and then the game seemed to close. After that I terminated the proces with ctrl+C. The music kept playing for a minute. The result in the terminal is:

TIMER| InitVfs: 1.90684 ms
Writing the mainlog at /home/stefan/.var/app/com.play0ad.zeroad/config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 3.27961 ms
Sound: AlcInit success, using OpenAL Soft
TIMER| shutdown ConfigDB: 0.847 us
TIMER| resource modules: 5.88766 ms
TIMER TOTALS (9 clients)
  tc_pool_alloc: 0 c (0x)
  tc_png_decode: 0 c (0x)
  tc_dds_transform: 0 c (0x)
  tc_transform: 0 c (0x)
  tc_plain_transform: 0 c (0x)
  tc_ShaderGLSLLink: 0 c (0x)
  tc_ShaderGLSLCompile: 0 c (0x)
  tc_ShaderValidation: 0 c (0x)
  xml_validation: 0 c (0x)
TIMER| shutdown misc: 328.32 us
TIMER| InitVfs: 174.436 ms
Writing the mainlog at /home/stefan/.var/app/com.play0ad.zeroad/config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 3.26081 ms
Sound: AlcInit success, using OpenAL Soft
UserReport written to /home/stefan/.var/app/com.play0ad.zeroad/config/0ad/logs/userreport_hwdetect.txt
TIMER| RunHardwareDetection: 11.316 ms
TIMER| write_sys_info: 16.3904 ms
TIMER| InitRenderer: 38.3028 ms
TIMER| ps_console: 7.03005 ms
TIMER| ps_lang_hotkeys: 4.01364 ms
TIMER| common/modern/setup.xml: 299.301 us
TIMER| common/modern/styles.xml: 132.678 us
TIMER| common/modern/sprites.xml: 1.49723 ms
TIMER| common/setup.xml: 272.034 us
TIMER| common/sprites.xml: 577.78 us
TIMER| common/styles.xml: 61.118 us
TIMER| pregame/backgrounds/: 261.419 us
TIMER| pregame/sprites.xml: 151.385 us
TIMER| pregame/styles.xml: 21.294 us
TIMER| pregame/mainmenu.xml: 46.4355 ms
TIMER| common/global.xml: 6.1839 ms
TIMER| common/modern/setup.xml: 193.296 us
TIMER| common/modern/styles.xml: 154.253 us
TIMER| common/modern/sprites.xml: 1.88632 ms
TIMER| common/sprites.xml: 666.61 us
TIMER| splashscreen/setup.xml: 41.302 us
TIMER| splashscreen/splashscreen.xml: 26.2146 ms
TIMER| common/global.xml: 1.23888 ms
TIMER| common/modern/setup.xml: 164.865 us
TIMER| common/modern/styles.xml: 128.654 us
TIMER| common/modern/sprites.xml: 1.47501 ms
TIMER| common/setup.xml: 254.602 us
TIMER| common/sprites.xml: 514.137 us
TIMER| common/styles.xml: 57.462 us
TIMER| gamesetup/setup.xml: 229.43 us
TIMER| gamesetup/styles.xml: 21.087 us
TIMER| gamesetup/gamesetup.xml: 103.394 ms
TIMER| common/global.xml: 1.50326 ms
tex_dds.cpp(562): Function call failed: return value was -120102 (Invalid/unsupported texture format)
Function call failed: return value was -120102 (Invalid/unsupported texture format)
Location: tex_dds.cpp:562 (decode_sd)

Call stack:

(0x55c7f7aecdf5) /app/bin/pyrogenesis(+0x5e0df5) [0x55c7f7aecdf5]
(0x55c7f7a9e7b1) /app/bin/pyrogenesis(+0x5927b1) [0x55c7f7a9e7b1]
(0x55c7f7aa0047) /app/bin/pyrogenesis(+0x594047) [0x55c7f7aa0047]
(0x55c7f7aa03e3) /app/bin/pyrogenesis(+0x5943e3) [0x55c7f7aa03e3]
(0x55c7f7b0d3c0) /app/bin/pyrogenesis(+0x6013c0) [0x55c7f7b0d3c0]
(0x55c7f7b0baeb) /app/bin/pyrogenesis(+0x5ffaeb) [0x55c7f7b0baeb]
(0x55c7f7ae1a64) /app/bin/pyrogenesis(+0x5d5a64) [0x55c7f7ae1a64]
(0x55c7f7ae3df2) /app/bin/pyrogenesis(+0x5d7df2) [0x55c7f7ae3df2]
(0x55c7f78ef02c) /app/bin/pyrogenesis(+0x3e302c) [0x55c7f78ef02c]
(0x55c7f78ef8a6) /app/bin/pyrogenesis(+0x3e38a6) [0x55c7f78ef8a6]
(0x55c7f78e9c60) /app/bin/pyrogenesis(+0x3ddc60) [0x55c7f78e9c60]
(0x55c7f78cc143) /app/bin/pyrogenesis(+0x3c0143) [0x55c7f78cc143]
(0x55c7f7a8aed9) /app/bin/pyrogenesis(+0x57eed9) [0x55c7f7a8aed9]
(0x55c7f7a1b450) /app/bin/pyrogenesis(+0x50f450) [0x55c7f7a1b450]
(0x55c7f7a1443b) /app/bin/pyrogenesis(+0x50843b) [0x55c7f7a1443b]
(0x55c7f7a6d882) /app/bin/pyrogenesis(+0x561882) [0x55c7f7a6d882]

errno = 0 (Try again later)
OS error = ?

^C(C)ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?


So I pressed D and got

Sleeping until debugger attaches.
Please wait.
Debugger launch failed: No such file or directory
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
pyrogenesis: ../../src/xcb_io.c:260: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
/app/bin/0ad: line 9:     5 Aborted                 (core dumped) "$pyrogenesis" "$@"

This did not help the issue. After this finished, I uploaded all the files in /home/stefan/.var/app/com.play0ad.zeroad/config/0ad/logs

However it would be nice to note that I used both the autociv mod and the ballanced maps mod. Disabling the ballanced map mod solved the issue.

Edit: I want to add that I occasionally experienced a similar crash if I looked at the summary of a compled game and switched to the miscellaneous tab, disabling the mods solves the problem again...  So @chiffoncake could you state if you used any mods?


crashlog.txt interestinglog.html mainlog.html system_info.txt userreport_hwdetect.txt

Edited by LetswaveaBook
Link to comment
Share on other sites

1 hour ago, LetswaveaBook said:

tex_dds.cpp(562): Function call failed: return value was -120102 (Invalid/unsupported texture format)
Function call failed: return value was -120102 (Invalid/unsupported texture format)
Location: tex_dds.cpp:562 (decode_sd)

I had this when I ran out of disk space. Cache files get corrupted.

I deleted files in ~/.cache/0ad and the game started.

Edited by nwtour
Link to comment
Share on other sites

Sorry for the late reply. The forum shows "You have reached the maximum number of posts you can make per day."

The left ctrl problem seems to be a result of the "show cursor" functionality of gnome-tweak. I turn off the option and the game window just capture my left ctrl correctly. Also, I use a browser to test if it captures left ctrl key press. It turns out that neither does my browser capture left ctrl if "show cursor" is enabled. Therefore, this is not a bug of 0ad. Maybe add this strange behavior in FAQ or elsewhere to help others deal with this problem.

@LetswaveaBook the attachment is the screenshot of my mods. I downloaded and enabled a mod to provide zh_TW translation. However, I still use the default language (English). I think the crash on map selection isn't related to mods in my case ...


  • Like 1
Link to comment
Share on other sites

18 hours ago, nwtour said:

I had this when I ran out of disk space. Cache files get corrupted.

I deleted files in ~/.cache/0ad and the game started.

That did not solve the issue for me. I don't really bother to much about it, but I think there are people that do not like to play a broken wheel.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...