Jump to content
Sign in to follow this  
feneur

Batch training females using hotkeys doesn't work

Recommended Posts

As far as I remember it has been possible to queue batch training using Shift + Z, but now it doesn't seem to work. At first I thought it was all, but after some more testing I've realized that it only affects batch training females (I assume it affects all units trained using the Z key, but I've only tested it in an early game and thus am only sure it affects females).

I have tested Alpha 18 and it worked there, so it's got to be something that's changed since that which affects it.

I'll gladly post a ticket, just want to have it tested by someone else first to be sure it's not just something I do/that only affects me :P

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem here. The hotkey is broken too in the barracks.

The reason it is broken is a duplicate definition of the shift+Z combination. At least CTRL+shift+Z is used for some camera zooming and when I remove this hotkey from "default.cfg" the Z batches are working again. I am speaking about romoving line 200 in "default.cfg":

zoom.speed.increase = "Ctrl+Shift+Z"          ; Increase zoom speed

We can solve this problem by changing this hotkey too.

Share this post


Link to post
Share on other sites

That could have been the issue, in case that had changed since Alpha 18, but it's a lot older than that. The current theory is that it's got something to do with SDL2, which handles keyboard layouts differently.

  • Like 1

Share this post


Link to post
Share on other sites

I am just saying that when I remove this single line the batch training with shift+Z is working again. With that line the hotkey is not working here too.

Share this post


Link to post
Share on other sites

I am just saying that when I remove this single line the batch training with shift+Z is working again. With that line the hotkey is not working here too.

Yeah, and your information was useful. Just apparently doesn't seem to be the root cause of the issue :)

Share this post


Link to post
Share on other sites

Similar issue on Shift+S. If I am hold Shift down (for whatever reason) I can move camera with WAD but not S (for backward camera move). Look like in default.cfg there is this which conflict:

scroll.speed.increase = "Ctrl+Shift+S" ; Increase scroll speed

I think think like scroll speed should be put in options menu, noit with hotkey that add conflicts. :)

But root cause seem to be that the engine does not look for complete key press sequence, only partial? Very odd. It seems to be wanting me to press Ctrl too. "Please press Ctrl to complete hotkey sequence!" the game is begging me, "No you can't move camera back until you do as I ask." ;)

Edited by wowgetoffyourcellphone
  • Like 1

Share this post


Link to post
Share on other sites

Keyboard entry is handled by the SDL2 library as fenur mentioned could be a bug in the library as the old SDL lib was kinda wonky handling modifier keys of any kind.

Enjoy the Choice :)

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...