Jump to content

Recommended Posts

Hi, Is there a way to customize controls? or to change some of the hot-keys, mouse control?

I am having a couple issues:/

- Panning with the middle mouse button. It doesn't seem to do anything really. It would be good if I could pan around in an x/y/z spectrum, instead of just, zoom in, zoom out, left and right. you know?

- this keys : "[ ]" for rotating buildings do not work on German Keyboards, It would be good if we could cusomize or assign them to other keys so that we are able to rotate the buildings.

 

just that really, other than that, the game is honestly magnificent.

Link to post
Share on other sites

I don't know what you mean by "spectrum panning" but you can rotate the view with ctrl-a ctrl-d ctrl-w and ctrl-s.  (You can see all camera hotkeys in the default.cfg file mentioned in the settings manual I linked).  The middle mouse button works (or should work) like this:  click and hold with the middle mouse button, and move the mouse around.  The view should pan as you move the mouse.

By the way, you can also control the default camera speed and angle.  I find the default speed is too slow.  I also prefer an overhead view because it helps me to judge distance, although perhaps it's not as aesthetically pleasing.  I use these camera settings in my local.cfg:

[view] ; Camera control settings
scroll.speed = 300.0
zoom.default=200.0
fov = 45.0
rotate.x.default = 60.0
rotate.y.speed = 5.0

The way I use the camera, I hardly ever rotate the view if I'm not spectating.  I just use wasd to move it around, or I click on the minimap for long-distance camera changes, or I press f to focus on a selected unit.  I don't use middle button scrolling either.

Edited by causative
Link to post
Share on other sites
  • 2 years later...

Greetings all!

I apologize if resurrecting's an old thread of inappropriate, but I have a similar issue.  I recently installed 0 AD on my Windows 10 20H2 machine, and noticed a camera issue. 

I'll set the scene.  I launch 0 AD in full screen mode, start a game, and see my village.  If I move my mouse to the left, the camera/view moves accordingly, sliding to the left.  I do not know if this is to truck or track the camera.  But if I move my mouse to the right the view moves a tiny amount to the right and stops.  I then repeat the movement to the right and the camera/view moves a tiny amount more.  How can I fix this?  I would like the view to move freely as it does on my Ubuntu 20.04 workstation.

In case it matters, I have two displays and screen two is to the right.  The game is full screen, so I don't think that should matter.

Any advice is appreciated.

Link to post
Share on other sites

Thanks for responding Stan`!  I disconnected my second display and the issue continues, even after a reboot of the OS.  Moving the mouse to the right, diagonal right & down, or just down, the view only moves a tiny amount of distance.  Moving the mouse in the other arc of direction, it moves fine.  Could this simply be an old config file / registry issue?  I played 0 AD a few years ago on the same PC and it worked great.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...