Jump to content

Minimum requirements out of date?


Recommended Posts

Hi All,

I am a fan of AOE and came across this game, I do not have a modern computer, but it runs Win10 well, so I check with the minimum system requirements for the game, and my laptop Compaq CQ61 with Mobile Intel 4 series Express Family chipset passes the minimum requirments with Open GL version 2.1 (min req version 1.3).

But I receive the OpenGL shader warnings when loading the game, also 2 error pages, GL_ARB_multitexture extension n/a and GL_ARB_texture_env_crossbar n/a.

The welcome screen appears but when I start a tutorial, or a game it crashes with this message:

 

Much to our regret we must report the program has encountered an error.

Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Access violation reading 0x00000000)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)
errno = 0 (No error reported here)
OS error = 0 (no error code was set)
 

It would appear the minimum requirments need updating with the newer Open GL version requirments, I can then obtain a laptop that is capable of running it.

Many thanks for what appears to be a great looking game.

 

 

Link to post
Share on other sites
STACK_TEXT:  
004ff28c 00d6ee1a     00860da8 0de7d348 0bc1b14b pyrogenesis!CShaderProgram::Uniform+0x11
004ff360 00d2b3b4     0754d9cc 0bc1b1eb 0754d980 pyrogenesis!OverlayRenderer::RenderForegroundOverlays+0x3ca
004ff3c0 00d2a6e3     00000000 0bc1b49b 00000000 pyrogenesis!CRenderer::RenderSubmissions+0x694
004ff6b0 00d1dd5a     073b8a28 0dc3c7f8 00cd1730 pyrogenesis!CRenderer::RenderScene+0x7c3
004ff6bc 00cd1730     0bc1b5bb 00000000 00000001 pyrogenesis!CGameView::Render+0x3a
004ff790 00bc6ed7     0bc1b5e7 00000000 35ff0381 pyrogenesis!Render+0x150
004ff7cc 00bc96c8     0bc1b9ff 00000000 00000001 pyrogenesis!Frame+0x2e7
004ffbd4 00bcb403     00000001 00b70008 004ffbf4 pyrogenesis!RunGameOrAtlas+0x14c8
004ffbe4 00bc1035     00000001 00b70008 004ffc10 pyrogenesis!SDL_main+0x13
004ffbf4 00bc10c4     00000001 00b70008 00b70008 pyrogenesis!main_utf8+0x15
004ffc10 00e7ab61     00000001 00838190 0085e320 pyrogenesis!wmain+0x84
004ffc50 00e2e02f     0bc1beaf 00e2e750 00e2e750 pyrogenesis!__tmainCRTStartup+0xfd
004ffc84 75f9fa29     0024e000 75f9fa10 004ffcf0 pyrogenesis!CallStartupWithinTryBlock+0x3f
004ffc94 775a75f4     0024e000 7c5fea3a 00000000 kernel32!BaseThreadInitThunk+0x19
004ffcf0 775a75c4     ffffffff 775c7332 00000000 ntdll!__RtlUserThreadStart+0x2f
004ffd00 00000000     00e2e750 0024e000 00000000 ntdll!_RtlUserThreadStart+0x1b

@vladislavbelov

Link to post
Share on other sites

Thanks for that suggestion Stan, but the outcome is the same, there is a message at top of screen when game loads welcome page "warning falling back to fixed" or similar words to that effect.

I don't understand why it will not run with shaders, when the chipset should be capable of Opengl version 2.1.

 

Link to post
Share on other sites

@Stan, yes I have downloaded and tried the only version available on the Intel website, that was presented to me was WinXP64bit, that would only provide resolution of 800x600 and made no difference to the game so used WIn10 update to get me back to where I was.

If Win10 drivers are not up to it, and Intel are only showing drivers for XP, do you have any idea where I would get some suitable drivers?

Link to post
Share on other sites

Thanks for your help Stan.

Having done much research, I have now established that the GPU does support OpenGL 2.1, the Win10 driver WDDM 1.1 does not, MS removed it from the original intel driver and made a stripped down version, so I found a custom driver thanks to Nightmayor who can be found at tenforums.

Thanks to all the developers for bringing us this great game I am learning!

Link to post
Share on other sites
  • 1 month later...

@Stan` Also it would good idea to mention there the driver from previous discussion in this threat. Maybe i do not know if on macos side there should be mentioned that they need to disable so that they could play multiplayer or if the problems from previous threats about glsl and turning of postprocessing were resolved. 

Edited by asterix
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...