Jump to content

Alpha feedback


Recommended Posts








------------------------------------------------------------------ Original post:

Initially I just want to say the Alpha is great, congrats to the entire team behind it.

I installed the Alpha on my 32bit XP SP3 machine, and this is what I'd created an hour later:


Full size

A few houses after that screenshot was taken 0 A.D. became completely unresponsive and I had to force quit. Overall though I was very impressed by user interfaces, the buildings, the units, the animations, the water, the trees, and lots more. On to constructive criticism:

1) On default settings the shadows looked choppy

2) Only the selection circle is selectable when using the selection box.

3) The obstruction radius prevented walls and towers being connected to one another

4) Can't build on chickens (y) - Animals prevent placement of buildings

Those are my initial thoughts - hope they are helpful!

Edited by Pureon
Link to comment
Share on other sites

  • Replies 307
  • Created
  • Last Reply

Top Posters In This Topic

I can not do these things so nice because I can not catch when I'm out in full screen and it is very difficult to build walls. Should implement a system of construction as other games like imperium that you are clicking and placing towers where you do it.

I'm pretty sure something like that is on the ''to do'' list. (y)

Link to comment
Share on other sites

Looks like it's drawing shadows for transparent textures as if they were fully opaque. I've no idea why, and don't have any suggestions other than updating graphics drivers.

@Ykkrosh: I remember your name from all the great work you did for the AOE community many years ago. Huge thanks to you mate! Anyway, I updated DirectX and NVIDIA Display drivers and that fixed it (whatever it was).

No more choppy shadows:


Full size

Edit: Spoke too soon, now the editor hangs on startup - no blank map loads in the display window, and it's completely unresponsive. A single player scenario starts without any problems. A reinstall of 0AD didn't fix it either.

Edit2: Still haven't worked out why the atlas editor has stopped working since I updated my display drivers, the logs don't show anything worrying apart from maybe these 2 lines:

Cannot find config file "config/local.cfg" - ignoring

Cannot find config file "config/profiles/default/settings/user.cfg" - ignoring

But I assume there is no log specifically for the editor?

Edited by Pureon
Link to comment
Share on other sites

Those .cfg files are optional (and not present by default) and won't hurt. The editor runs as part of the game engine, so it uses the same log files. I don't have any ideas as to why it'd stop working (y). Maybe it'd be useful to run the game in a debugger to see what's going on, but unless you've got Visual Studio installed that's a pain - I guess we should figure out some instructions on how to use WinDbg to help with this kind of thing.

Link to comment
Share on other sites

I do have Microsoft Visual C++ 2005 Express Edition installed, but it' not registered (as in I didn't go through the registration process). That probably doesn't help.

During the 0AD uninstall process, do all files related to 0AD get deleted? The reinstall didn't fix the Atlas Editor, so doesn't that suggest it's my system and not 0AD?

Edited by Pureon
Link to comment
Share on other sites

Hmm, I think 2005 is probably too old to read the debug information files. I'll see if I can look into this debugging thing some time tomorrow (if not for this case then for future debugging).

The uninstall should delete everything except local .cfg files and screenshots, so it sounds like a system thing. Did Atlas stop working immediately when you updated the drivers? What exactly does it display on the screen when you start it?

Link to comment
Share on other sites

It looks like this.

The menu has gone white because I clicked on the move button - same happens whenever any buttons are pressed after Atlas starts. Some parts of the screen go white, or all of it (edit:like this), and it doesn't respond to anything.

Yes Atlas stopped working after I updated DirectX and then NVIDIA Display drivers (both to latest versions).

Perhaps I can follow this tomorrow evening:

Edited by Pureon
Link to comment
Share on other sites

  • 2 weeks later...

Very nice looking screenie. Thanks, Pureon!

I was playing with the atlas a few weeks ago to see what buildings, units, and textures were available. I made some screenies of a simple Celtic Iron Age hill fort here.

It's very nice being able to alter the ambient lighting with this nice GUI within the editor. Users of Age of Empires 3 can get similar effects, but only through trigger scripts, so you can't see the effects until you playtest the game. With my current graphics setup, shadows, ambient lighting, and translucent textures all work very nicely. (2x ATI Radeon 5870 1Gb GDDR5, driver version 10.7 for 64 bit Win7).

Changing water tint, reflectivity, clarity, and wave intensity is also very nice. This is important in setting the mood of a scene - a dark stormy night on a grey leaden sea, or a sunny tropical paradise with calm, crystalline waters. I do miss being able to have two separate bodies of water at different heights, but for most skirmishes and multiplayer settings, a single water table should be enough.

Is there a way to change viewfinder camera pitch and zoom within the editor? I wanted to take a lower pitch view of the fort, but had to exit editor and playtest the map to get the camera maneuverability.

Other things I could not find but perhaps need help with: Resizing map, point elevation picker/painter, rotating buildings in z-axis.

As for units on walls, if a point elevation tool were available, you could raise a discrete ridge of terrain and then place wall segments along its sides. This is how you do the trick in AOE3. Since it appears units can walk through wall segments I don't think it's possible to have units walk on top of them.

Link to comment
Share on other sites

You need to use ctrl + middle-mouse-drag (or right-mouse-plus-middle-mouse-drag) to rotate the camera in Atlas - see documentation. See the next section there for rotating buildings, or click-and-drag when first placing the building.

Resizing maps currently isn't possible, except by opening binaries/data/mods/public/maps/scenarios/_default.xml in a text editor and changing the patches="12" value. There isn't any elevation picking tool yet (though it probably wouldn't be hard to add). You can elevate a point by just changing the brush size to be very small, but I'm not sure if that's what you mean.

Units shouldn't be able to walk through walls - I think their collision shapes are just set wrong. I believe you can get a unit to stand on a spike of terrain inside a wall, but the pathfinder will probably get quite confused if it tries walking anywhere.

Link to comment
Share on other sites

  • 3 weeks later...
Your instructions were spot on, thanks. Here's the output

Sorry, I forgot to get back to this :victory:. I don't see any obvious problems, but it looks suspicious that it says

WARNING: Break-in timed out, suspending.
This is usually caused by another thread holding the loader lock

and threads 3 and 4 seem to be blocking while requesting that lock.

Thread 4 looks a bit weird, running "ScanSoft\OmniPageSE4\OpHookSE4.dll" - that sounds like some background process/service is injecting itself into other applications. That probably ought to be safe, but are you able to disable that process and see if anything is different?

An alternative thing to try: can you open the folder "%appdata%\0ad\config" and create a file local.cfg containing

noframebufferobject = true

and see if that makes any difference? (If it does, it'd still be nice to know why that breaks it, but it sounds like it might just be a graphics driver bug or something.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...