Jump to content
Sign in to follow this  
Itms

Re-release of 0 A.D. Alpha 23 Ken Wood

Recommended Posts

On 12/29/2018 at 12:04 AM, camelator said:

the last release of 0ad was uploaded today (28 Dec 18) , but as expected, it does not work with the Long Term Support version of Ubuntu.

This is not expected at all: the game builds and runs on Ubuntu LTS. You can follow sarcoma's guide above. However, the PPA maintainer indeed has an issue building the game on the Launchpad containers, we don't know why yet. There should be an update for 0 A.D. on Ubuntu LTS as soon as possible, but it will be quicker for you to build the game.

  • Like 1

Share this post


Link to post
Share on other sites
On 12/30/2018 at 11:43 AM, Itms said:

This is not expected at all: the game builds and runs on Ubuntu LTS. You can follow sarcoma's guide above. However, the PPA maintainer indeed has an issue building the game on the Launchpad containers, we don't know why yet. There should be an update for 0 A.D. on Ubuntu LTS as soon as possible, but it will be quicker for you to build the game.

HI,

many thanks for your feedback, I compiled the last version it works.

Related to the issue on the package, may I suggest you to have a look on what I wrote: I think there are unresolved dependencies (I think 4) inside the file "control" inside the package.

For exemple  this dependency : "libgloox17" is not available for the currentLTS version of  Ubuntu  (but it will be available for the next versions of Ubuntu)

https://packages.ubuntu.com/search?suite=default&section=all&arch=any&keywords=libgloox17&searchon=names

Here are the dependencies found in the file "control" in the last 0ad version:

Depends: 0ad-data (>= 0.0.23b), 0ad-data (<= 0.0.23b-0ubuntu1~18.04~wfg0), 0ad-data-common (>= 0.0.23b), 0ad-data-common (<= 0.0.23b-0ubuntu1~18.04~wfg0), libboost-filesystem1.65.1, libboost-system1.65.1, libc6 (>= 2.27), libcurl3-gnutls (>= 7.16.2), libenet7, libgcc1 (>= 1:3.4), libgl1, libgloox17, libicu60 (>= 60.1-1~), libminiupnpc10 (>= 1.9.20140610), libnspr4 (>= 2:4.9.2), libnvtt2, libopenal1 (>= 1.14), libpng16-16 (>= 1.6.2-1), libsdl2-2.0-0 (>= 2.0.8), libsodium23 (>= 1.0.14), libstdc++6 (>= 5.2), libvorbisfile3 (>= 1.1.2), libwxbase3.0-0v5 (>= 3.0.4+dfsg), libwxgtk3.0-0v5 (>= 3.0.4+dfsg), libx11-6, libxcursor1 (>> 1.1.2), libxml2 (>= 2.9.0), zlib1g (>= 1:1.2.0)

ps: I can see there is a downgrade on version of libboost-system1 since my previous message, may I suggest to downgrade version of libgloox ?

 

Edited by camelator

Share this post


Link to post
Share on other sites

Goody ! Happy New Year all ! :D I will be looking forward to playing this update,and ty for keeping up with this beautiful game !

  • Like 3

Share this post


Link to post
Share on other sites
On 12/31/2018 at 12:38 PM, camelator said:

I think there are unresolved dependencies (I think 4) inside the file "control" inside the package.

The PPA will also contain the correct or compatible versions of dependencies if the ones in the official tree are not adequate. You don't have to worry about this as a user. The downside of compiling yourself is actually having to also compile dependencies when they are outdated in the package manager (typically, libsodium).

The gloox minimal required version really cannot be reduced, because we had to make upstream include fixes, and we will need other fixes on their side, so we really need to use the latest version and will continue needing that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...