Jump to content
Sign in to follow this  
FeXoR

[FIXED] Atlas crashes at first start

Recommended Posts

This is just a null pointer (and the logs don't tell where it comes from). Is there any way to reproduce this reliably?

Also, are both of you using windows? I might be a Windows specific issue.

Share this post


Link to post
Share on other sites

@Stan: not for Niek.

Third question, can you bisect SVN to see which commit caused it the first time?

No, for me the first time it happened was already long ago and it's only the first time start. Pressing exit at the error log and restarting fixes the error.

Share this post


Link to post
Share on other sites

There are still multiple ways null pointers can get into our code. The problem with yours can be related to something we don't initialise, a file that's being read too slow, or something else. And it can be totally unrelated to the other issue.

Share this post


Link to post
Share on other sites

well mine won't even start ;) ''not or available of failed to load'' (on a mac)

That's because it's compiled without Atlas. Did you compile it yourself, or where did you get it?

Share this post


Link to post
Share on other sites

I tried this:

Reboot, directly start Atlas:

Error:

Much to our regret we must report the program has encountered an error.
Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Access violation reading 0x00000000)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)

errno = 0 (No error reported here)
OS error = 0 (no error code was set)

Click break:

Error:

Much to our regret we must report the program has encountered an error.
Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Breakpoint)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)
errno = 13 (Insufficient access rights to open file)
OS error = 0 (no error code was set)

After this Atlas stops reacting (Windows "waiting for program" window) and I have to kill it.

crashlog.txt

crashlog.dmp

mainlog.html

But that's not the same error. I'm trying to reproduce it...

Edited by FeXoR

Share this post


Link to post
Share on other sites

FexoR, you're working on terrains, right? The log you posted now complains about a missing terrains.xml. Something you modified there?

That warning has been around for a long time, since myconid modified the terrain loading I think.

Share this post


Link to post
Share on other sites

FexoR, you're working on terrains, right? The log you posted now complains about a missing terrains.xml. Something you modified there?

No. I erased the cache before rebooting and renamed the mod folder of mine. So no modifications at all.

Share this post


Link to post
Share on other sites

That's because it's compiled without Atlas. Did you compile it yourself, or where did you get it?

You mean the game? well always had it tried it again and it doesn't work. tried to reinstall the game but it still doesn't work. I don't think i changed anything...

Share this post


Link to post
Share on other sites

greenlaser: He meant what version of the game you are using e.g. "Alpha 15 (Osiris)" or "SVN Revision: 14797(autobuild)" or "SVN Revision: 14797(selfbuild without wxwidgets)" or "SVN Revision: 14797(selfbuild with wxwidgets)"

Share this post


Link to post
Share on other sites

oh ok well, Alpha XV (Osiris),

and it says it can't open a file: ''Applications/0ad. app/Contents/Framework/libAtlasUI.dylib''

In Alpha 15, Atlas won't work on OS X, that's a known problem and different than what is reported here.
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...