Jump to content

gui456wSERTDYF

Community Members
  • Posts

    30
  • Joined

  • Last visited

Posts posted by gui456wSERTDYF

  1. In previous versions of 0AD there was a button (with an engine icon if I recall correctly) that would send units back to work. It was super useful. I cannot find it now.

    I am also wondering whether the "delete button" is useful to have it there at all. After all, a delete operation is so intuitive that even my grandpa could figure out that the "delete" key is the shortcut for this.

  2. My humble suggestion: The game is already awesome, you can still make it better of course but what 0AD is missing most of all is not new civs, new units, new features but a larger community of players. So to me it looks wise to prioritize marketing rather than development at this stage. I get to know many people that is still playing Age of Empires 2 and don't even know about 0AD, and the reason they play it is due to the community, because of course 0AD is nowadays much superior. But it lacks that community.

    Also: Things like the community mod go against enlarging the community actually. The reason: Now I enter the lobby and find two kinds of games which are not compatible with each other, for me this is a pain but handle it because I already know. But for a newcomer this is just splitting the community.

  3. A26 has come with many new interesting features. My problem is that many of them I cannot find how to use. The one I am more interested in is to bring things to the front of the production line, how is this done? Another one: Now armies move in batalions, which is nice but if I want to select only few units to do something else, how can this be done?

  4. Yeah, I can. It will take some time though. Do you have suggested bibliography? I will start in Wikipedia.

    Another issue I experience quite frequently which is probably related is that I host a game, people can connect without issues (up to 8 players) and it works absolutely fine for about 30-60 minutes. Then, suddenly, one by one players loose connection and cannot come back. This process takes between 5 and 15 minutes per player, and does not affect all players but some.

    BTW, yesterday I knew about other player that was experiencing the port connection issues with all games except mine, don't ask me why. Of course he did not come to the forum to report this.

  5. 4 hours ago, hyperion said:

    Teaching people on how to setup forwarding is not the goal but to let them know they are using a problematic setup. If stun is the only thing they get working, so be it. The main problem I see is they don't even know that there is an issue, which is always the biggest hurdle to address.

    I am an example of such people. I don't know anything at all about those network details. I am getting to know at this very moment that "stun" (whatever that is) is the quick'n dirty solution, if I am getting the point properly.

    Does this forwarding port thing affect all online games/apps? If so, how do other games avoid this to be an issue? I don't play others so honestly I don't know, but all other apps that use internet connection work fine...

  6. I am still facing this problem and it is frustrating. It seems to be completely random, some days I can play (join or host) any game I want, several games per day. Other days I cannot join any game at all and people cannot join my games, but they can play among themselves (not always anyway). Other days some games I can join, some others I can't. Today I played a game some hours ago, no problems; now I wanted to play again and just keep getting this. So I didn't play.

    What can I try to debug this problem? Things already done (because sometimes they work):

    • Restart 0AD.
    • Restart computer.
    • Connect via a VPN.

    I don't have a router. I always connect via the hotspot of my phone with 4G.

  7. I would suggest as a top priority to fix the issues when joining a multiplayer game in the lobby, see attached. I have no idea what is the reason for this, but I know a lot of people experience this, even though very few of us post about it in the forum (1 2 3). This is probably a barrier for newcomers (1 2 3, these links are just the tip of the iceberg, most people never come to the forum) when they get this error a few times they just abandon 0AD. I have been dealing with this since I started playing 0AD back in 2018-2019 (different 0AD versions, different computers, different countries and continents, different internet connections). A solution for this is needed, either automatic (i.e. this does not happen anymore) or non automatic (like Android when it requests permissions for apps, or a link to an easy, complete and up to date troubleshooting guide).

    I know this is not a cool game play idea, but I would give this top priority.

    Screenshot_2022-08-03_18-08-38.png

    Screenshot_2022-08-03_18-11-48.png

    • You cannot just demolish your buildings by pressing "delete" for free, to demolish a building should be some time/resource consuming process. It is hateful when you are stealing your enemy's city or CC and he just destroys it in your face. It also does not make sense. A nice implementation would be that when you demolish a building, something similar to what happens when you upgrade a wood tower to a stone tower happens, but instead the health of the building gradually decreases. You may also need to pay some resources, or even garrison some workers. The cost and time would be a function of the building. Even more, the more resources you pay the faster the building is demolished, so you can decide this depending on if you are in times of war and in need of speed or in times of peace and you don't care to spend some time and save resources.
    • Some unit/technology that can be garrisoned into stone walls to burn rams (like throwing fire down the wall). This would make stone walls much more attractive (or at least attractive).
    • New building complementary to walls: "trenches with water and crocodiles" that block the passage of siege and make the movement of soldiers slower (well, the water and crocodiles are not necessary haha). This would be nice because you can place them in front of the wall to avoid rams destroying it (like it was done in real life).
    • Soldiers cannot attack buildings, except some "arrow with fire" or so. It just makes no sense that a bunch of soldiers with arrows and swords can destroy a building, and it is annoying when your enemy does this...
    • Elephants cannot attack buildings, instead they are very strong against soldiers. It just does not make much sense that a bunch of elephants destroys a fortress...
    • Rams that cannot move unless you garrison soldiers, and increase movement speed/power as soldiers are garrisoned. Make rams very cheap to build, but add this feature to use. Also, rams belong to gaia when no soldier is garrisoned (of course they cannot move or attack in this case), so then if I bring my rams to your city and left them unattended, you can just garrison your soldiers into them and they are yours.
    • Randomize the attack of units. In this way it is not obvious that 100 soldiers will defeat 99. The distribution gives more freedom to tune units, consider for example the attached `damage_distribution.png` for some unit before and after it is trained (increased rank or whatever).
    • Ranged units that switch to sword when very close to enemy (at least optional this). In the movies this is always the case. They are weaker than sword soldiers but anyway.

    damage_distribution.png

    • Thanks 2
  8. I also have very often problems to connect to games. In my case, however, it has a random nature, about 70 % of the games work fine and 30 % have problems. It also happens that I join a game without any problem and just in the second the host clicks "start game" I am disconnected and then I cannot join again. As I said, with about 70 % of the games it works fine, but there is roughly a 30 % of the games which I cannot join, even if the host is the same person always with the same computer and configuration.

    These are the 3 errors I usually receive:

    photo_2021-07-04_17-51-56.jpg

    When I get the next one, it just stays there forever and I have to close the game:

    photo_2021-07-04_17-56-16.jpg

    photo_2021-07-04_17-56-44.jpg

  9. On 11/11/2020 at 7:59 AM, gui456wSERTDYF said:

    I usually connect through my phone using the hotspot Wi-Fi. I discovered that if this problem happens, restarting the phone is a solution. Restarting the computer does not solve the problem for me.

    I guess that, in analogy with my solution, restarting your modem or whatever device you use to connect can provide a solution.

    Just want to let the world know that this is not working anymore since 0AD 24. I don't know if something changed or is it just random.

  10. Today I played a match without any problem (in fact I won). After this I joined a new one and just when it was about to start (seconds before the host hit "start") I was disconnected and could not join again, nor any other game. Now I keep receiving this message:

    image.png.05f6681181ea3bd60484af0cd2d45e31.png

    It is not the first time this happens to me. Now I know will have to wait for some days until I can play again, which is really bad. In the past some times this was solved by resetting the internet connection/computer, but today (and some other days) none of these things worked.

    How can I avoid this problem?

    My setup: 0AD A24 build Mar 17, 2021 (24937-release) on Ubuntu 20.04.

×
×
  • Create New...