Jump to content

[AppImage] can't cd to /tmp/.mount_0


Recommended Posts

Update 4: Now, there is sound when I start it with a bash script. That's very weird. If you know the reason please let me know.

Update 3: I have no sound when I start the game with a bash script. Do you know how to fix this?

Update 2: I placed a bash script on my desktop to run the game. I do not know why a symbolic link did not work, but with a bash script it works. :rolleyes:

Update: If I do not use a shortcut it works. Do you know how I can add a working shortcut to the .AppImage file?
 

Hi,

I'd like to use the AppImage of the game, but unfortunately, it crashes with this error log:

 

```

/tmp/.mount_0 A.D.yLVJfl/usr/bin//0ad: 2: cd: can't cd to /tmp/.mount_0
CreateDirectories: failed to mkdir ././/share/games (mode 448)
file_system.cpp(158): Function call failed: return value was -1 (Function failed (no details available))
Function call failed: return value was -1 (Function failed (no details available))
Location: file_system.cpp:158 (CreateDirectories)

Call stack:

(0x55eefdeba0de) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5ec0de) [0x55eefdeba0de]
(0x55eefde60919) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x592919) [0x55eefde60919]
(0x55eefde624ab) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5944ab) [0x55eefde624ab]
(0x55eefde72282) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5a4282) [0x55eefde72282]
(0x55eefde71f29) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5a3f29) [0x55eefde71f29]
(0x55eefde71f29) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5a3f29) [0x55eefde71f29]
(0x55eefde71e8b) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5a3e8b) [0x55eefde71e8b]
(0x55eefde7e193) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x5b0193) [0x55eefde7e193]
(0x55eefdb2d64b) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x25f64b) [0x55eefdb2d64b]
(0x55eefd932886) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x64886) [0x55eefd932886]
(0x55eefd922527) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x54527) [0x55eefd922527]
(0x7fd4c340d0b3) /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fd4c340d0b3]
(0x55eefd9306cb) /tmp/.mount_0 A.D.yLVJfl/usr/bin//pyrogenesis(+0x626cb) [0x55eefd9306cb]

errno = 0 (?)
OS error = ?

```

I'm new to Linux so I have no clue how to fix this. When I try to run it with sudo I get this error:

```

/tmp/.mount_0 A.D.FTbAYa/usr/bin//0ad: 2: cd: can't cd to /tmp/.mount_0
********************************************************
WARNING: Attempted to run the game with root permission!
This is not allowed because it can alter home directory
permissions and opens your system to vulnerabilities.   
(You received this message because you were either      
  logged in as root or used e.g. the 'sudo' command.)    
********************************************************

```

 

Could you please help me to fix this?

Thanks & regards,
Mark

Edited by MarkCS
Link to post
Share on other sites
  • MarkCS changed the title to [AppImage] can't cd to /tmp/.mount_0

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...