Jump to content

[Solved] ftbs: fmt/printf.h: No such file or directory


Recommended Posts

I got a compile failure today after fetching the latest SVN (r24351).

I ran clean-workspaces.sh and ./update-workspaces.sh --with-system-nvtt, then make in the gcc folder.

System:

  • Linux Mint based on Ubuntu Focal (20.04).
  • gcc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0

 

==== Building network (release) ====
Creating obj/network_Release
precompiled.h
In file included from ../../../source/lib/precompiled.h:111,
                 from ../../../source/pch/network/precompiled.h:19:
../../../source/ps/CLogger.h:28:10: fatal error: fmt/printf.h: No such file or directory
   28 | #include <fmt/printf.h>
      |          ^~~~~~~~~~~~~~
compilation terminated.

 

Edited by GunChleoc
  • Like 2
Link to post
Share on other sites

Thanks that fixed it!

BTW the dependencies list python-is-python2, should that be python-is-python3 now since the SpiderMonkey upgrade is done? Also, the rust dependencies would install python-is-python2 if I installed them from the Ubuntu package manager. I got them from https://www.rust-lang.org/tools/install instead as recommended in the Spidermonkey thread to be on Python 3. Shall we update the build instructions accordingly?

Since my system nvtt is too old, I updated the workspaces without the switch.

Link to post
Share on other sites
  • GunChleoc changed the title to [Solved] ftbs: fmt/printf.h: No such file or directory

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...