Jump to content

Why I cant Minimize the game?


Recommended Posts

thats a(probably) hard-to-work-around library thing… the underlying lib grabs the whole keyboard, so you can’t use eg. the volume keys too.

idk, how to solve that. Savage 2 had an option to turn capture on/off in the options menu…

but I somehow like the capturing… you can use so much more keyboard shortcuts then, like <Ctrl>+<F1-12>, which would otherwise interfere with the window manager.

if you really want the keyboard unlock, i have a workaround for you(only works with KDE):

(I retranslate the options back to english, setting LC_ALL=C doesn’t help this case)

  1. create a local.cfg with windowed=true -> http://trac.wildfire...Manual_Settings
  2. right click on the window title, select 'Advanced' -> 'Special settings for this programm'
  3. accept the infobox dialog with ok
  4. go to tab 'Size&Position'
  5. activate 'Fullscreen' -> in the dropdown to the right select 'Force' or maybe better 'Apply on Initialization'(second entry) -> set radio button to 'yes'
  6. maybe restart the game

then the game uses KWin’s fullscreen mode(windowed fullscreen); you have fullscreen with an ungrabbed keyboard(and mouse!) .

so hitting screen edges might toggle compositing effects, if you enabled such actions(I think there is one enabled by default for the upper left corner…)

so you might need to enable other options too, (eg. block compositing)

Edited by luziferius
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...