Jump to content
Sign in to follow this  
marioxcc

“disconnected” after hosting or joining a game.

Recommended Posts

Hello.

I get the message “disconnected” in red in the chat if I host for more than like 1 min and then get back to the lobby. I also get this message after I have played a game from the lobby either as host or client so I have to get back to the main menu and rejoin the lobby. I have checked for packet loss several times when it happens and it's below 1‰ and this happens even when there are no lag problems while playing (Most of the time). My score won't get updated after I play a 1 vs 1 rated as host. My games (When I'm hosting) gets unlisted in the lobby after some time, so I have to constantly cancel and re-create my games, plus, players aren't able to rejoin my games if they get disconnected. I have noticed than this don't happens to all players, and it don't seems to happen to most of them. What should I do regarding this problem?.

Regards.

Share this post


Link to post
Share on other sites

Bugs to be expected in such an early alpha state. considering they only happen rarely is quite an achievement.

You could try re-installing your game, that'd be a start.

Windows: Go to your add/remove programs in your control centre and delete it fully.

Linux; get synaptic package manager and search for '0ad', all the 0ad packages have 0ad in their name, and fully uninstall them all, then re-install them.

Share this post


Link to post
Share on other sites

good job, Auron2401, for replying the topic that the rest of us all missed :).

If I remember correctly, being able to rejoin totally depends on how the game feels (tough luck). You also get disconnected from the lobby if the ping times out (ie, a bad internet connection).

Share this post


Link to post
Share on other sites

Hello.

I get the message “disconnected” in red in the chat if I host for more than like 1 min and then get back to the lobby. I also get this message after I have played a game from the lobby either as host or client so I have to get back to the main menu and rejoin the lobby. I have checked for packet loss several times when it happens and it's below 1‰ and this happens even when there are no lag problems while playing (Most of the time). My score won't get updated after I play a 1 vs 1 rated as host. My games (When I'm hosting) gets unlisted in the lobby after some time, so I have to constantly cancel and re-create my games, plus, players aren't able to rejoin my games if they get disconnected. I have noticed than this don't happens to all players, and it don't seems to happen to most of them. What should I do regarding this problem?.

Regards.

Iv'e noticed a couple of times when I have been playing against you while you have hosted, you disconnect during the game. I not sure if its a bug or not but it always happens when I'm winning the game. Also its strange that your ranked 9th seems your games don't get rated. Maybe there's a bug with the game that won't let you lose when hosting!

  • Like 1

Share this post


Link to post
Share on other sites

If you're using UPnP instead of forwarding a port, I'd guess your router just has a weird UPnP implementation. In addition, our current UPnP usage is more of an experiment than anything. It probably does have some weird issues, sorry. :(

You could try forwarding UDP port 20595. That was the game won't have to use UPnP and thus can avoid any oddities with 0 A.D. and/or your router.

Iv'e noticed a couple of times when I have been playing against you while you have hosted, you disconnect during the game. I not sure if its a bug or not but it always happens when I'm winning the game. Also its strange that your ranked 9th seems your games don't get rated. Maybe there's a bug with the game that won't let you lose when hosting!

He did this against me too (left after some raging), and I assumed it was just a bad internet connection except that he came back on, raged a bit more, and then left again. (I was hosting.) I hate to assume marioxcc is abusing the leave-game-without-resigning thing, but it's beginning to sound a bit like he might.
  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...