Jump to content
Sign in to follow this  
fabio

Broken GUI on Persian Sandbox

Recommended Posts

The Persian Sandbox demo map has a partially missing and broken GUI when hover the mouse cursor over it.

EDIT: added screenshot.

post-8891-0-16342400-1349451691_thumb.pn

Edited by fabio

Share this post


Link to post
Share on other sites

A screenshot would be useful yeah. Can't confirm it either (using the 12726 revision, custom built, on Windows 7).

Share this post


Link to post
Share on other sites

I get it too, but only when the Gardens are in view, so probably something to do with the high amount of polys/entities.

Share this post


Link to post
Share on other sites

Screenshot added in the first post. As zoot said I also only get it when the wonder is on the screen.

There's some unfinished/untested code being used in that wonder that could easily be the cause of this. Does this happen on an empty map with just the wonder, and if yes, which prop is causing the problem?

Share this post


Link to post
Share on other sites

There's some unfinished/untested code being used in that wonder that could easily be the cause of this. Does this happen on an empty map with just the wonder, and if yes, which prop is causing the problem?

Yes, I created a map with just the gardens and it happens whenever I hover the mouse on it. What do you mean with the "which prop is causing the problem"?

Share this post


Link to post
Share on other sites

The whole structure is made of different parts, one per different texture used. I think Myconid is talking about those parts:

In atlas' object menu, select "Actors (all)" in the dropbox instead of "Entities" and use "gardens" as filter. The search will display all .xml separate actors of the gardens.

Try an empty map just with the waterfalls and water to see if those are causing the problem.

Share this post


Link to post
Share on other sites

The whole structure is made of different parts, one per different texture used. I think Myconid is talking about those parts:

In atlas' object menu, select "Actors (all)" in the dropbox instead of "Entities" and use "gardens" as filter. The search will display all .xml separate actors of the gardens.

Try an empty map just with the waterfalls and water to see if those are causing the problem.

OK I tried, but I cannot reproduce the problem with just waterfall and/or water.

Note that the problem only happens when the mouse is over the gardens and the selection box appears (even if I don't click on it).

When using the lonely water or waterfall the selection box doesn't appear over them, so this is probably why the problem cannot be reproduced with just these.

Share this post


Link to post
Share on other sites

OK I tried, but I cannot reproduce the problem with just waterfall and/or water.

Note that the problem only happens when the mouse is over the gardens and the selection box appears (even if I don't click on it).

When using the lonely water or waterfall the selection box doesn't appear over them, so this is probably why the problem cannot be reproduced with just these.

Have you tried with the other parts of the gardens? :)

Share this post


Link to post
Share on other sites

Have you tried with the other parts of the gardens? :)

No, but is there a way to enable the selection box on single parts? This is probably the key that trigger the problem.

Share this post


Link to post
Share on other sites

No, but is there a way to enable the selection box on single parts? This is probably the key that trigger the problem.

Note that this is only relevant in Atlas: Alt-click (or drag to select multiple parts, not relevant in this case I guess, but I just want to take the opportunity to spread knowledge ;) ) to select and thereby also display the selection, though it's not the exact same as for the full building in-game so I can't say whether it would be accurate or not, still, could be worth a try :P If you turn on the "Simulation test" in Atlas but still have the select and move tool selected you should be able to test it, but again, it's not doing the exact same thing so if it is the selection display I'm not sure how relevant it will be.

Share this post


Link to post
Share on other sites

OK, I was looking at this again on current SVN, the original problem is no longer reproducible, however this is probably due to the fact that now all waters effects are missing in the wonder. Does this happens to others, also?

Share this post


Link to post
Share on other sites

That probably explains this whole issue :P I'm assuming you're not using GLSL but rather the ARB shaders? Leper found out the other day that there are no ARB shaders for those water effects, which was causing crashes when loading maps with the wonder and using ARB shaders, so until those shaders are written he's now made those water effects not render at all for the time being. So in case you are using ARB rather than GLSL shaders what you are seeing right now is intended, and hopefully explains the original issue as well :)

Share this post


Link to post
Share on other sites

That probably explains this whole issue :P I'm assuming you're not using GLSL but rather the ARB shaders? Leper found out the other day that there are no ARB shaders for those water effects, which was causing crashes when loading maps with the wonder and using ARB shaders, so until those shaders are written he's now made those water effects not render at all for the time being. So in case you are using ARB rather than GLSL shaders what you are seeing right now is intended, and hopefully explains the original issue as well :)

Yes, I am using arb indeed, which anyway is the default.

Share this post


Link to post
Share on other sites

Hmm, that's bad, IMO there should be no GLSL shaders loaded unless the user enables that option. If we haven't confirmed that yet, we should go through all the current effects and make sure.

Share this post


Link to post
Share on other sites

Hmm, that's bad, IMO there should be no GLSL shaders loaded unless the user enables that option. If we haven't confirmed that yet, we should go through all the current effects and make sure.

What do you mean? There are no shaders loaded by default now, it seems.

Share this post


Link to post
Share on other sites

Hmm, that's bad, IMO there should be no GLSL shaders loaded unless the user enables that option. If we haven't confirmed that yet, we should go through all the current effects and make sure.

All the fancywater is rendered using GLSL. That includes both the water-on-models and the global water planes.

I think there are two bugs at play here. One is with ShaderTechnique, as it bugs out when the only option is a GLSL shader but preferGLSL isn't set. The other is somewhere in the GUI, which seems to make assumptions about the caller's state that happen to be invalidated by the water effects.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...