Jump to content

SpiderMonkey Build Failed


Recommended Posts

After successfully installing the required dependencies, I received this error after running the following command when attempting to compile the source code per the instructions at http://trac.wildfiregames.com/wiki/BuildInstructions.

$ ./update-workspaces.sh -j3Updating bundled third-party dependencies...Building SpiderMonkey...Package nspr was not found in the pkg-config search path.Perhaps you should add the directory containing `nspr.pc'to the PKG_CONFIG_PATH environment variableNo package 'nspr' foundERROR: SpiderMonkey build failed
Edited by NimbleKnight18
Link to comment
Share on other sites

Why is this dependency not included in the command to install the other dependencies?

su -c 'yum -y install gcc-c++ python subversion zip cmake boost-devel       \    libcurl-devel enet-devel libjpeg-devel libpng-devel libvorbis-devel     \    libxml2-devel openal-soft-devel pkgconfig SDL2-devel wxGTK-devel         \    gloox-devel libicu-devel miniupnpc-devel'

libnspr4-dev is not listed in this command, yet is a required dependency. I tried running "yum install libnspr4-dev" and it said the package is not found. I found a suitable RPM package for my OS (Ozon OS based on Fedora 21) and attempted to install it, but it did not work. Also, I don't know where to find the PKG_CONFIG_PATH.

Link to comment
Share on other sites

I tried running "yum install libnspr4-dev" and it said the package is not found.

well, apt would have asked: Did you mean libnspr4-devel ?

"yum install libnspr4-devel yielded the same results: nothing found.

Probably an oversight, I think previously it was assumed system SM (libmozjs) would be used by default with those commands but the situation changed since the upgrade to SM 31. Still, libnspr4 is listed as a dependency for all distros.

"yum install nspr" says that nspr-4.10.8-1.fc21.x86_64 is already installed and is the latest version. I tried compiling again, but it gives me the same error. So how exactly do I install libnspr4? https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSPR gives instructions for Windows, Mac, Ubuntu, Debian, and openSUSE, but not for Fedora. http://rpmfind.net/linux/rpm2html/search.php?query=libnspr4.so has a Netscape Portable Runtime package for Fedora 21 which I attempted to download and install but without success. I assume it's the development package version that I need, however. These two places are the closest I've come to finding a solution. I can't find any other meaningful information about NSPR. So how do I install this dependency?

Link to comment
Share on other sites

I don't use Fedora, and different distros use different naming conventions, but it's listed as a package here: https://apps.fedoraproject.org/packages/nspr-devel

Also on CentOS, which also has yum, I typically use "yum search <<keyword>>" when I want to find a package. "yum search nspr" might find it for you.

That was the solution right there. Thank you! The game compiles and runs successfully.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...