Jump to content

Fancy water issues


Recommended Posts

I was playing a game on the 1st, and I got this lovely rendering on the map Phonecian Levant:

http://i.imgur.com/90cOG.jpg

It's consistently reproducible, and turning on Water - Use Actual Depth fixes it.

Without Use Actual Depth: http://i.imgur.com/tdWNC.jpg

With Use Actual Depth: http://i.imgur.com/52GiO.png

The following water-related settings are enabled:

  • Water - HQ Waviness
  • Water - Enable Reflections
  • Water - Enable Refractions

These are the default settings for my computer. All other water-related settings are disabled.

Attached is the output from dxdiag.exe

DxDiag.txt

Edited by alpha123
Link to post
Share on other sites

Card name: IntelĀ® G45/G43 Express Chipset

Manufacturer: Intel Corporation

Chip type: IntelĀ® 4 Series Express Chipset Family

Display Memory: 1695 MB

Dedicated Memory: 64 MB

Shared Memory: 1631 MB

Driver Name: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32

Driver File Version: 8.15.0010.2555 (English)

Driver Version: 8.15.10.2555

Driver Date/Size: 10/13/2011 11:05:50, 6549504 bytes

Hmm, that's a fairly low-end GPU and Intel generally has awful drivers, so we might be pushing it to the limits. But it looks like there's a newer driver available, perhaps you could try that?

Link to post
Share on other sites

Hmm, that's a fairly low-end GPU and Intel generally has awful drivers, so we might be pushing it to the limits. But it looks like there's a newer driver available, perhaps you could try that?

Gee, it runs the game quite well usually (of course not on full settings). I'll install the newer driver sometime. So does this mean it's a driver bug?

Link to post
Share on other sites

The water shader code has gotten a little bit too artsy to debug easily, so I can't readily point to where the problem might be. Maybe wraitii has an idea...

alpha123 and serveurix, does it make any difference when you turn on/off reflections, refractions and so on?

Link to post
Share on other sites

alpha123 and serveurix, does it make any difference when you turn on/off reflections, refractions and so on?

Sorry to answer so late. It doesn't make any difference when I turn on/off reflections and refractions, I mean, reflections and refractions are displayed, but the shape of the water keeps looking like this. And I've noticed that the more I zoom in, the thinner thoses stripes are, until they disappear. With full zoom in the water is properly displayed.

Edited by serveurix
Link to post
Share on other sites

Just a thought, and something that's probably not related at all, but it should be quick to try: Could you try turning on and off shadows to see if that changes anything?

Tooked a few pics while toying with the options.

All graphical settings enabled, zoomed out to max :

1357990395.png

All graphical settings enabled, normal zoom :

1357990573.png

All graphical settings enabled, maximum zoom in (in fact, stripes are still visible on the shores) :

1357990665.png

Refractions, reflections, foam, waves and surface shadows disabled (and zoomed out a little, because without reflections/refractions you almost don't see the stripes on the shores) :

1357990948.png

Disabled the rest (shadows, shadow filtering, HQ waviness), actual depth is still enabled, stripes are still there :

1357991186.png

Edited by serveurix
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...