Jump to content

Mac OS X FCollada build failed with something error on CFBundle.h


Recommended Posts

I followed the Mac OS X build instruction but I still found error with building FCollada.

Updating bundled third-party dependencies...

bash -c 'mkdir -p output/{debug,release,test}/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}'

FCollada/FCollada.cpp

In file included from FCollada/FCollada.h:49,

from FCollada/StdAfx.h:13,

from FCollada/FCollada.cpp:9:

FCollada/FUtils/FUtils.h:91:25: error: libxml\tree.h: No such file or directory

In file included from /System/Library/Frameworks/CoreFoundation.framework/Headers/CoreFoundation.h:43,

from /System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/CarbonCore.h:20,

from /System/Library/Frameworks/CoreServices.framework/Frameworks/AE.framework/Headers/AE.h:20,

from /System/Library/Frameworks/CoreServices.framework/Headers/CoreServices.h:21,

from FCollada/FUtils/FUCriticalSection.h:18,

from FCollada/FUtils/FUError.h:21,

from FCollada/FUtils/FUtils.h:129,

from FCollada/FCollada.h:49,

from FCollada/StdAfx.h:13,

from FCollada/FCollada.cpp:9:

/System/Library/Frameworks/CoreFoundation.framework/Headers/CFBundle.h:147: error: format string argument not a string type

make: *** [output/debug/FCollada/FCollada.o] Error 1

ERROR: FCollada build failed

I also use google to search some topics of this issue in our forum, and tried to use /libraries/fcollada/src/FCollada/FCollada.xcodeproj to build FCollada, but I found error "no file existing of /libxml/tree.h". I already follow the Mac OS X build intruction and get libxml2 installed.

When I search topics in forum, it said I need to us macports to install libxml-dev or libxml2-dev. But when I tried sudo port install libxml-dev or libxml2-dev, I get below error messages:

Error: Port libxml-dev not found

Error: Port libxml2-dev not found

Would you please help about this issue?

Link to post
Share on other sites

After I run pkg-config libxml-2.0 --cflags

it shows:

-I/opt/local/include/libxml2

I can get the tree.h file under /opt/local/include/libxml2/libxml/

Do I need to modify xcodeproj file with some changes?

And it is also very weird to found CFBundle error. ;)

Thanks for your quick reply.

Link to post
Share on other sites

Hmm, if pkg-config says that and if the files exist there, then I can't see why gcc wouldn't find it...

The .xcodeproj file won't work - you need to build FCollada either by running update-workspaces.sh, or by running "make" inside libraries/fcollada/src.

From some searching on the web, it sounds like the CFBundle.h:147 error is an issue in the Snow Leopard header files and it requires you to use Apple's version of GCC. Could you check "which g++" and "g++ -v" to see what version it's using? (If you have a MacPorts version of GCC selected by default then perhaps that's the problem.)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...