Jump to content
Sign in to follow this  
Alembic

[RESOLVED] 0ad: error while loading shared libraries: libboost_filesystem.so

Recommended Posts

Hi,

I reinstalled my system (Ubuntu GNOME 14.10) and then 0AD, but I can't start the game :

0ad: error while loading shared libraries: libboost_filesystem.so.1.54.0: cannot open shared object file: No such file or directory

I installed libboost-all-dev package but it still doesn't works.

I don't know if it's useful for you but here are my libboost_filesystem libraries :

morgan@alembic:~$ sudo find / -name libboost_filesystem.so*/usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.55.0/usr/lib/x86_64-linux-gnu/libboost_filesystem.so

So the good version isn't present on my system.

I tried :

morgan@alembic:~$ sudo apt-get install libboost1.54-all-devLecture des listes de paquets... FaitConstruction de l'arbre des dépendances       Lecture des informations d'état... FaitCertains paquets ne peuvent être installés. Ceci peut signifierque vous avez demandé l'impossible, ou bien, si vous utilisezla distribution unstable, que certains paquets n'ont pas encoreété créés ou ne sont pas sortis d'Incoming.L'information suivante devrait vous aider à résoudre la situation : Les paquets suivants contiennent des dépendances non satisfaites : libboost1.54-all-dev : Dépend: libboost1.54-dev mais ne sera pas installé                        Dépend: libboost1.54-tools-dev                        Dépend: libboost-atomic1.54-dev mais ne sera pas installé                        Dépend: libboost-chrono1.54-dev mais ne sera pas installé                        Dépend: libboost-context1.54-dev mais ne sera pas installé                        Dépend: libboost-coroutine1.54-dev mais ne sera pas installé                        Dépend: libboost-date-time1.54-dev mais ne sera pas installé                        Dépend: libboost-exception1.54-dev mais ne sera pas installé                        Dépend: libboost-filesystem1.54-dev mais ne sera pas installé                        Dépend: libboost-graph1.54-dev mais ne sera pas installé                        Dépend: libboost-graph-parallel1.54-dev mais ne sera pas installé                        Dépend: libboost-iostreams1.54-dev mais ne sera pas installé                        Dépend: libboost-locale1.54-dev mais ne sera pas installé                        Dépend: libboost-log1.54-dev mais ne sera pas installé                        Dépend: libboost-math1.54-dev mais ne sera pas installé                        Dépend: libboost-mpi1.54-dev mais ne sera pas installé                        Dépend: libboost-mpi-python1.54-dev mais ne sera pas installé                        Dépend: libboost-program-options1.54-dev mais ne sera pas installé                        Dépend: libboost-python1.54-dev mais ne sera pas installé                        Dépend: libboost-random1.54-dev mais ne sera pas installé                        Dépend: libboost-regex1.54-dev mais ne sera pas installé                        Dépend: libboost-serialization1.54-dev mais ne sera pas installé                        Dépend: libboost-signals1.54-dev mais ne sera pas installé                        Dépend: libboost-system1.54-dev mais ne sera pas installé                        Dépend: libboost-test1.54-dev mais ne sera pas installé                        Dépend: libboost-thread1.54-dev mais ne sera pas installé                        Dépend: libboost-timer1.54-dev mais ne sera pas installé                        Dépend: libboost-wave1.54-dev mais ne sera pas installéE: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Share this post


Link to post
Share on other sites

I uninstalled libboost*-dev packages, whitout installing anyting else after that, and the game works perfectly (standard distribution, not from the SVN repo).

I can't understand why the game works now, but I'm so happy, the game was crashing all the time (ubuntu repos, PPAs, source and regardless the driver, video card or configuration I was using, after long debates on this forum the problem wasn't solved until now, after a complete reinstallation and mainly a better support of Optimus in Ubuntu 14.10 [precedently, a complete reinstall of 14.04 changed nothing]...).

Edited by Alembic

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...