Sign in to follow this  
Followers 0
billt79

multicore support? and water problem.

3 posts in this topic

Just noticed before that the game only runs on one core, just thinking it would be significantly quicker if it made use of all of them. Also i'm having problems with water, or at least i think its the water, it causes the game to lag a lot even with no shadows and water reflections. My card is an ATi Mobility Radeon HD4250 on catalyst 12.3 drivers, have tried open source drivers, doesn't make a difference to performance really. water can cause it to drop 20 frames, and on maps with very little water my laptop will happily pull 30+ frames. I would just thinks its just my gfx being slow, but on my cousins desktop (amd sempron, old ati graphics - i think a radeon 9600, 2gb ram) doesn't have a problem, nut on all land maps my laptop is quicker by a few frames when a lot is going on ingame and when the games just started. my setup is an acer aspire 5551, 4gb ram amd athlon p320, ati mobility radeon hd 4250, wd scorpio black and debian sid with kde. desktop effects are disabled while im in game. my cousins computer uses windows xp and is an older version of opengl.

Share this post


Link to post
Share on other sites

The game only uses one core for now (partly because of historical reasons: when the development started multicore computers weren't as common as today, if at all, and partly because keeping things on one core makes things like profiling easier), but there are ideas to at least try to put things like AIs in different cores. (For more indepth explanation you'll have to wait for one of the programmers to explain ;) )

In the water games you've played, have you played against AIs? AIs don't yet support water maps, so in addition to the water effects that might be part of what makes things slow.

Have you tried disabling water reflections? (In the in-game settings dialog to quickly toggle it on/off for testing, or by disabling fancywater as per http://trac.wildfiregames.com/wiki/Manual_Settings )

Share this post


Link to post
Share on other sites

fancy water and shadows are disabled, i noticed the AI's didnt like water but even at the very start, the game doesn't run very well. This problem occurs with or without AI got profiles of both, profile1 is with AI (qbot). The map is generated from corsica vs sardina and on normal size.

profile.txt

profile1.txt

Edited by billt79

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0