Jump to content
Sign in to follow this  
collimarco

Alpha 8 not launching in Mac OS Lion

Recommended Posts

Here's a screenshot and some system info:

post-2104-0-26602400-1324974926_thumb.pn

Based on your screenshot, I would say it's some weirdness with the camera position or input, because the UI and minimap are there, but there's no orange camera box in the minimap. It's probably offworld, which is why you see nothing, I've had a problem like this before on Windows. Try clicking on the minimap or scrolling, see if your camera comes back, and check that your mouse is not accidentally scrolling the map before the game loads. Either way I think this can be considered a bug.

Share this post


Link to post
Share on other sites

I made sure the application wasn't selected (and thus not receiving input from the mouse) while it loaded and tried clicking on the map. I think you're right, it probably is a camera issue but I don't see any way of fixing it. Perhaps when I get through these build errors this issue will go away. My build could have been faulty somehow.

Juicyfruit, I have boost version 1.48.0. I couldn't find any boost folder in /usr/local/include and I'm not sure if that's a problem.

Share this post


Link to post
Share on other sites

you need to download daily snapshots of the source. sometimes projects like sdl dont have latest snapshots. hence i am against it and other reasons like some patches which are not in the main tree of original libraries might be needed, etc. I vote -1 for that proposal of having separate script to download sources and compile them

Share this post


Link to post
Share on other sites

Juicyfruit, I have boost version 1.48.0. I couldn't find any boost folder in /usr/local/include and I'm not sure if that's a problem.

My bad, mac ports boost is in /opt/local/include/boost/ then if you have not changed the path.

Ill try to help you this evening on IRC. Im in the western europe timezone. Not sure if that suits you ?

I talked some with OS X maintainers from other projects and they seem to prefer static linking for release executables.

I am trying to build a set of minimally configured ( as small as possible) static libs and the corresponding headers and modify the build to use those instead.

My goal is to provide a package that allows the user to do a "just works" compile without having to install macports and a lot of libs.

Share this post


Link to post
Share on other sites

Hi,

I have uploaded a new set of binaries for Mac OS X (on the first page) if anyone is interested. These are SDL 1.2 based (thanks for the link to the patch) and have scenario editor (wxwidgets 2.9).

Best regards

Aleksandar

Share this post


Link to post
Share on other sites

Hi,

I have uploaded a new set of binaries for Mac OS X (on the first page) if anyone is interested. These are SDL 1.2 based (thanks for the link to the patch) and have scenario editor (wxwidgets 2.9).

Best regards

Aleksandar

Thanks for the binaries, Aleksandar! I still get this black screen error with his binaries, so I'm starting to think it has something to do with my computer. Any way to troubleshoot it?

Share this post


Link to post
Share on other sites

Hi,

I have uploaded a new set of binaries for Mac OS X (on the first page) if anyone is interested. These are SDL 1.2 based (thanks for the link to the patch) and have scenario editor (wxwidgets 2.9).

Best regards

Aleksandar

The game starts (strangely yellow cursor) but crashes with the following log message (collapsed for readability's sake):

Process: pyrogenesis [52235]

Path: /Users/USER/Downloads/*/pyrogenesis.app/Contents/MacOS/pyrogenesis

Identifier: com.wildfiregames.app.pyrogenesis

Version: r10803 (r10803)

Code Type: X86-64 (Native)

Parent Process: launchd [308]

Date/Time: 2011-12-28 16:09:09.442 +0100

OS Version: Mac OS X 10.7.2 (11C74)

Report Version: 9

Interval Since Last Report: 3280441 sec

Crashes Since Last Report: 171

Per-App Interval Since Last Report: 65 sec

Per-App Crashes Since Last Report: 8

Anonymous UUID: 332C68E7-7876-4225-8568-A844CA5D45FD

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGTRAP)

Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:

objc[52235]: garbage collection is OFF

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0 libsystem_kernel.dylib 0x00007fff8985782a __kill + 10

1 com.wildfiregames.app.pyrogenesis 0x0000000104a98198 debug_break() + 40

2 com.wildfiregames.app.pyrogenesis 0x0000000104a6b59b unifont_linespacing(long long) + 75

3 com.wildfiregames.app.pyrogenesis 0x00000001048b2a3b CFont::GetLineSpacing() + 31

4 com.wildfiregames.app.pyrogenesis 0x00000001048e9a23 _ZL6InitPsbRK5CStrW10CScriptVal + 195

5 com.wildfiregames.app.pyrogenesis 0x00000001048ebc02 InitGraphics(CmdLineArgs const&, int) + 2178

6 com.wildfiregames.app.pyrogenesis 0x00000001047d3f73 SDL_main + 1571

7 com.wildfiregames.app.pyrogenesis 0x0000000104aa2750 -[sDLMain applicationDidFinishLaunching:] + 48

8 com.apple.Foundation 0x00007fff90215de2 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 47

9 com.apple.CoreFoundation 0x00007fff884e3e0a _CFXNotificationPost + 2634

10 com.apple.Foundation 0x00007fff90202097 -[NSNotificationCenter postNotificationName:object:userInfo:] + 65

11 com.apple.AppKit 0x00007fff8a57faa7 -[NSApplication _postDidFinishNotification] + 212

12 com.apple.AppKit 0x00007fff8a57f80d -[NSApplication _sendFinishLaunchingNotification] + 78

13 com.apple.AppKit 0x00007fff8a57e4d2 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 242

14 com.apple.AppKit 0x00007fff8a57e233 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 330

15 com.apple.CoreFoundation 0x00007fff8852d851 -[NSObject performSelector:withObject:withObject:] + 65

16 com.apple.Foundation 0x00007fff9023889b __-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke_1 + 101

17 com.apple.Foundation 0x00007fff90237822 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 283

18 com.apple.Foundation 0x00007fff902376b0 _NSAppleEventManagerGenericHandler + 105

19 com.apple.AE 0x00007fff8eb85c25 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 200

20 com.apple.AE 0x00007fff8eb85b03 _ZL25dispatchEventAndSendReplyPK6AEDescPS_ + 38

21 com.apple.AE 0x00007fff8eb859f7 aeProcessAppleEvent + 250

22 com.apple.HIToolbox 0x00007fff8baf8b6d AEProcessAppleEvent + 102

23 com.apple.AppKit 0x00007fff8a57b63d _DPSNextEvent + 1247

24 com.apple.AppKit 0x00007fff8a57acf5 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

25 com.apple.AppKit 0x00007fff8a57762d -[NSApplication run] + 470

26 com.wildfiregames.app.pyrogenesis 0x0000000104aa2564 main + 1444

27 com.wildfiregames.app.pyrogenesis 0x00000001047d3624 start + 52

If I try to run the game from the command line, the following output appears:

Cache: 500 (total: 2048) MiB

TIMER| InitVfs: 701 us

TIMER| InitScripting: 8.467 ms

TIMER| CONFIG_Init: 1.248 ms

ERROR: CVFSFile: file hwdetect/hwdetect.js couldn't be opened (vfs_load: -110100)

ERROR: Failed to load hardware detection script

TIMER| RunHardwareDetection: 236 us

APIC: not unique

TIMER| write_sys_info: 18.091 ms

ERROR: CVFSFile: file shaders/program.rng couldn't be opened (vfs_load: -110100)

ERROR: Failed to read grammar shaders/program.rng

TIMER| InitRenderer: 2.895 ms

ERROR: Failed to find font 'mono-10'

unifont.cpp(230): Function call failed: return value was -110100 (VFS directory not found)

Function call failed: return value was -110100 (VFS directory not found)

Location: unifont.cpp:230 (unifont_linespacing)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (No error reported here)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

unifont.cpp(244): Function call failed: return value was -110100 (VFS directory not found)

Function call failed: return value was -110100 (VFS directory not found)

Location: unifont.cpp:244 (unifont_character_width)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (No error reported here)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

unifont.cpp(206): Function call failed: return value was -110100 (VFS directory not found)

Function call failed: return value was -110100 (VFS directory not found)

Location: unifont.cpp:206 (unifont_unload)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (No error reported here)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

TIMER| ps_console: 70.5216 s

TIMER| ps_lang_hotkeys: 672 us

ERROR: Failed to find file: "gui/page_pregame.xml"

ERROR: Failed to find file: "shaders/model_common.xml"

ERROR: Failed to load shader 'model_common'

ERROR: Failed to find file: "shaders/solid_tex.xml"

ERROR: Failed to load shader 'solid_tex'

ERROR: Failed to find file: "shaders/solid.xml"

ERROR: Failed to load shader 'solid'

ERROR: Failed to find file: "shaders/solid_instancing.xml"

ERROR: Failed to load shader 'solid_instancing'

ERROR: Failed to find file: "shaders/solid_player.xml"

ERROR: Failed to load shader 'solid_player'

ERROR: Failed to find file: "shaders/solid_player_instancing.xml"

ERROR: Failed to load shader 'solid_player_instancing'

ERROR: Failed to find file: "shaders/solid_tex.xml"

ERROR: Failed to load shader 'solid_tex'

ERROR: Failed to find file: "shaders/model_common.xml"

ERROR: Failed to load shader 'model_common'

ERROR: Failed to find file: "shaders/model_common_instancing.xml"

ERROR: Failed to load shader 'model_common_instancing'

ERROR: Failed to find file: "shaders/model_common.xml"

ERROR: Failed to load shader 'model_common'

ERROR: Failed to find file: "shaders/model_common_instancing.xml"

ERROR: Failed to load shader 'model_common_instancing'

ERROR: Failed to find font 'mono-stroke-10'

unifont.cpp(230): Function call failed: return value was -110100 (VFS directory not found)

Function call failed: return value was -110100 (VFS directory not found)

Location: unifont.cpp:230 (unifont_linespacing)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (Error during IO)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

unifont.cpp(219): Function call failed: return value was -110100 (VFS directory not found)

Function call failed: return value was -110100 (VFS directory not found)

Location: unifont.cpp:219 (unifont_bind)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (No error reported here)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

unifont.cpp(273): Assertion failed: "BoundGlyphs != NULL"

Assertion failed: "BoundGlyphs != NULL"

Location: unifont.cpp:273 (glvwprintf)

Call stack:

(error while dumping stack: Function not supported)

errno = 0 (No error reported here)

OS error = ?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

©ontinue, (S)uppress, (B)reak, Launch (D)ebugger, or (E)xit?

c

Segmentation fault: 11

With the following error log:

Process: pyrogenesis [52378]

Path: /Users/USER/Downloads/*/pyrogenesis.app/Contents/MacOS/./pyrogenesis

Identifier: com.wildfiregames.app.pyrogenesis

Version: r10803 (r10803)

Code Type: X86-64 (Native)

Parent Process: bash [52340]

Date/Time: 2011-12-28 16:20:13.400 +0100

OS Version: Mac OS X 10.7.2 (11C74)

Report Version: 9

Interval Since Last Report: 3281100 sec

Crashes Since Last Report: 180

Per-App Interval Since Last Report: 198 sec

Per-App Crashes Since Last Report: 17

Anonymous UUID: 332C68E7-7876-4225-8568-A844CA5D45FD

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010

VM Regions Near 0x10:

-->

__TEXT 0000000102d41000-000000010318d000 [ 4400K] r-x/rwx SM=COW /Users/USER/Downloads/*/pyrogenesis.app/Contents/MacOS/pyrogenesis

Application Specific Information:

objc[52378]: garbage collection is OFF

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0 com.wildfiregames.app.pyrogenesis 0x0000000102fda967 glvwprintf(wchar_t const*, __va_list_tag*) + 263

1 com.wildfiregames.app.pyrogenesis 0x0000000102fdabe4 glwprintf(wchar_t const*, ...) + 148

2 com.wildfiregames.app.pyrogenesis 0x0000000102e0a786 CLogger::Render() + 482

3 com.wildfiregames.app.pyrogenesis 0x0000000102e5cef1 Render() + 1025

4 com.wildfiregames.app.pyrogenesis 0x0000000102d43974 SDL_main + 4132

5 com.wildfiregames.app.pyrogenesis 0x0000000103011750 -[sDLMain applicationDidFinishLaunching:] + 48

6 com.apple.Foundation 0x00007fff90215de2 __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 47

7 com.apple.CoreFoundation 0x00007fff884e3e0a _CFXNotificationPost + 2634

8 com.apple.Foundation 0x00007fff90202097 -[NSNotificationCenter postNotificationName:object:userInfo:] + 65

9 com.apple.AppKit 0x00007fff8a57faa7 -[NSApplication _postDidFinishNotification] + 212

10 com.apple.AppKit 0x00007fff8a57f80d -[NSApplication _sendFinishLaunchingNotification] + 78

11 com.apple.AppKit 0x00007fff8a57e4d2 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 242

12 com.apple.AppKit 0x00007fff8a57e233 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 330

13 com.apple.CoreFoundation 0x00007fff8852d851 -[NSObject performSelector:withObject:withObject:] + 65

14 com.apple.Foundation 0x00007fff9023889b __-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke_1 + 101

15 com.apple.Foundation 0x00007fff90237822 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 283

16 com.apple.Foundation 0x00007fff902376b0 _NSAppleEventManagerGenericHandler + 105

17 com.apple.AE 0x00007fff8eb85c25 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 200

18 com.apple.AE 0x00007fff8eb85b03 _ZL25dispatchEventAndSendReplyPK6AEDescPS_ + 38

19 com.apple.AE 0x00007fff8eb859f7 aeProcessAppleEvent + 250

20 com.apple.HIToolbox 0x00007fff8baf8b6d AEProcessAppleEvent + 102

21 com.apple.AppKit 0x00007fff8a57b63d _DPSNextEvent + 1247

22 com.apple.AppKit 0x00007fff8a57acf5 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

23 com.apple.AppKit 0x00007fff8a57762d -[NSApplication run] + 470

24 com.wildfiregames.app.pyrogenesis 0x0000000103011564 main + 1444

25 com.wildfiregames.app.pyrogenesis 0x0000000102d42624 start + 52

Share this post


Link to post
Share on other sites

The game starts (strangely yellow cursor) but crashes with the following log message (collapsed for readability's sake):

Hi,

Have downloaded the data file and unpacked it? These are only binaries since the data package is c/a 300mb. In the future I can make a self contained app (that has everything needed inside)

ATM you have to have the data in ../data (sorry for that I will make a new version that looks for the data in the same directory in which the app resides).

Best regards

Aleksandar

P.S.

You should have a folder in which the game will reside eg. 0ad

Image

And data files in the data folder

Image

An the binaries in the folder

Image

Edited by atopuzov

Share this post


Link to post
Share on other sites

Thanks for the binaries, Aleksandar! I still get this black screen error with his binaries, so I'm starting to think it has something to do with my computer. Any way to troubleshoot it?

Hi,

What Mac OS version do you have? I have compiled this on 10.7 so for now it's the safest bet to try it on 10.7.

I'll set up a build environment to target earlier versions of Mac OS X in the next few days.

Best regards

Aleksandar

Share this post


Link to post
Share on other sites

Hi,

Have downloaded the data file and unpacked it? These are only binaries since the data package is c/a 300mb. In the future I can make a self contained app (that has everything needed inside)

ATM you have to have the data in ../data (sorry for that I will make a new version that looks for the data in the same directory in which the app resides).

Best regards

Aleksandar

The data archive has the folder data put below binaries, which got me confused. Thanks for the hint. It has to look like this:

o 0AD folder

`-o binaries or system or whatever you like

| `-o pyrogenesis.app

`-o data

`-o config

`-o mods

`-o tools

However graphics look very strange on my external monitor.

Anyway, great to be able to run the game.

- David

Edited by xy77

Share this post


Link to post
Share on other sites

The data archive has the folder data put below binaries, which got me confused. Thanks for the hint. It has to look like this:

o 0AD folder

`-o binaries

| `-o pyrogenesis.app

`-o data

`-o config

`-o mods

`-o tools

Hi,

Yup that's right. I'll fix that soon so it looks for the data right in directory as same as the app (slow upload speeds ;().

Best regards

Aleksandar

Edited by atopuzov

Share this post


Link to post
Share on other sites

Hi,

What Mac OS version do you have? I have compiled this on 10.7 so for now it's the safest bet to try it on 10.7.

I'll set up a build environment to target earlier versions of Mac OS X in the next few days.

Best regards

Aleksandar

10.7.2

Share this post


Link to post
Share on other sites

10.7.2

Hi,

Can you confirm that your directory structure looks like the one in the previous posts?

Can you remove your .config/0ad (first backup your copy) and then start?

Can you check .config/0ad/log for any errors.

Best regards

Aleksandar

Share this post


Link to post
Share on other sites

Hi,

Can you confirm that your directory structure looks like the one in the previous posts?

Can you remove your .config/0ad (first backup your copy) and then start?

Can you check .config/0ad/log for any errors.

Best regards

Aleksandar

I have your binaries (pyrogenesis.app and ActorEditor.app) in my system folder. Everything else is the latest data from the private SVN repo. I don't think the error I'm getting is related to your binaries because I have the same problem with the ones I built on my system. I'm still having trouble diagnosing the problem, but I know it has something to do with the camera. One time I was able to see the map in Atlas but I couldn't edit anything in it. I'm not sure why it worked that one time.

Share this post


Link to post
Share on other sites

How many of you guys can be on IRC during our regularly scheduled meeting this Saturday (1/31) at 16:30 GMT? That would be a good time for all of us to get together and discuss the best packaging solution for Mac.

Share this post


Link to post
Share on other sites

How many of you guys can be on IRC during our regularly scheduled meeting this Saturday (1/31) at 16:30 GMT?

I think I can be there... even though it's New Year's Eve.

Share this post


Link to post
Share on other sites

How many of you guys can be on IRC during our regularly scheduled meeting this Saturday (1/31) at 16:30 GMT? That would be a good time for all of us to get together and discuss the best packaging solution for Mac.

You mean 12/31 :) I probably won't be there.

Share this post


Link to post
Share on other sites

Hi,

There is a 0.7 version from your main site http://releases.wildfiregames.com/thirdparty/0ad-r10288-alpha-mac.dmg and the 0.8 are only source & data no binaries.

Best regards

Aleksandar

Aha, I just wondered whether they might have gotten things to work on their own or something =) But alas no :) I hope you all will be able to get things working together though (y)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...