Jump to content

Eragon0605

Community Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Eragon0605

  • Rank
    Tiro
  1. OK, thanks! Compiled without any errors, and a billion 'comparison between signed and unsigned integer' warnings ! Alright, just one more question: How do you change the settings in the game? The in-game button is all grayed out, so I presume there is some sort of configuration file somewhere. EDIT: Nevermind, I found it.
  2. Alright, the svn is updated. I looks like prebuild is already compiled, so I didn't do anything there, so the first thing I ran was ./update-workspaces.sh --with-spidermonkey-tip Then I cd to the gcc folder and ran make. Now, the first few things compile fine, but when I get to scriptinterface, this is the output: ==== Building scriptinterface ==== ScriptInterface.cpp ../../../source/scriptinterface/ScriptInterface.cpp: In constructor ‘ScriptInterface_impl::ScriptInterface_impl(const char*, JSContext*)’: ../../../source/scriptinterface/ScriptInterface.cpp:134: error: ‘JS_BeginRequest’ was no
  3. Alrighty! I extracted a fresh archive from the 7z again, and ran 'svn up' from there. It's doing its thing right now...
  4. Well, I read a readme file, and it says I have to put spidermonkey in my /usr/include/js/ folder. I downloaded it, followed the instructions, and now I get a different error message: ==== Building network ==== Network.cpp In file included from /usr/include/js/jsdbgapi.h:46, from ../../../source/scripting/SpiderMonkey.h:49, from ../../../source/scripting/ScriptingHost.h:42, from ../../../source/scripting/JSConversions.h:23, from ../../../source/scripting/JSSerialization.h:23, from ../../../source/network/NetMessages.h:31, from ../../../source/network/NetMessage.h:
  5. Yup, it's there, and is owned by my normal user. Good suggestion, I won't use sudo anymore. Well, I've tried it now, and nothing changes. I did a total clean of my files - I deleted the folder I had previously attempted to compile in and re-extracted the files from the 7z archive. I then ran premake and ./update-workspaces.sh --with-spidermonkey-tip. I get the exact same error message as before.
  6. Sorry if I'm posting in the wrong section. I didn't see any forum or any link to anywhere this would more appropriate... Anyway, I cannot compile 0 A.D. I am running Ubuntu 9.10. I installed all the necessary dependencies, did all the premake stuff, and then went to trunk/build/workspaces/gcc and typed 'sudo make'. This is the output I get: ==== Building network ==== Network.cpp In file included from ../../../source/scripting/ScriptingHost.h:42, from ../../../source/scripting/JSConversions.h:23, from ../../../source/scripting/JSSerialization.h:23, from ../../../source/network/N
  7. OS:XP Pro/Ubuntu Intrepid dual boot. XP Is my main system. CPU: 2.2GHz Intel Pentium Dual-Core Video Card: Nvidia Geforce 9500 512MB Memory: 2 GB Dual-Channel 667MHz DDR2 Kingston
×
×
  • Create New...