Jump to content
Sign in to follow this  

wxWidgets conversion to current Visual C++ format fails

Recommended Posts

When I follow the instructions in the 0ad svn for building wxWidgets (libraries\wxwidgets\README.txt) it comes to the point 'Agree to convert all projects'.

I checked 'Do this for all similar cases during this conversion session.' and agreed to 'Convert and open this project?'.

Microsoft Visual C++ 2010 Express then asks me:

"The project file 'C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxregex.dsp' cannot be loaded. Do you want to remove the unloadable project from the solution?"

That occurs for all projects it seams. I always disagreed.

Here's the output:

C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxregex.dsp : error  : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxzlib.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxpng.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxjpeg.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxtiff.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_wxexpat.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_base.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_net.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_core.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_adv.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_media.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_odbc.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_dbgrid.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_html.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_qa.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_xml.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_xrc.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_aui.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_richtext.dsp : error : Project upgrade failed.
C:\Users\fexor\dat\wintools\wxWidgets\wxMSW-2.8.12\build\msw\wx_gl.dsp : error : Project upgrade failed.

What did I do wrong?

Additional information:

- Windows Vista Home Premium (6.0, Build 6002) Longhorn 64Bit

- Microsoft Visual C++ 2005, 2008 and 2010 Express (Can't use any other then 2010 to compile or don't know how)

-- About says:

-- Microsoft Visual C++ 01013-532-2002287-70468

-- Hotfix for Microsoft Visual C++ Express - ENU (KB2542054)

-- Microsoft Visual C++ 2010 Express - ENU Service Pack 1 (KB983509)

- C:\Users\fexor\dat is the mount point of an NTFS partition, so it's not really 'C:'

Edited by FeXoR

Share this post

Link to post
Share on other sites

Oh, ok, thx. I just read the 'libraries\wxwidgets\README.txt' and there I found

* Download the wxMSW zip from http://wxwidgets.org/downloads/ 
(avoid version 2.9; 2.8.12 is known to work)

Same problem with wxWidgets-2.9.3 (Tryed ZIP and exe)

Trying VC++ 2008...

Edited by FeXoR

Share this post

Link to post
Share on other sites

I think the README is outdated, though technically 2.8 is the stable and 2.9 the development release, we've corrected all the build errors that used to occur with 2.9 and it works quite well (in fact you don't have a choice when building Atlas on OS X).

You got the same error when opening the 2.9 project in VC++ 2010? It seems to work for someone on the wxWiki, are you using SP1?

Share this post

Link to post
Share on other sites
You got the same error when opening the 2.9 project in VC++ 2010?

I hadn't but installed now. Still the same even after reboot.

Tryed the exe and build in 'C:\wxWidgets-2.9.3', still the same.

I updated the system information in the OP.

Perhaps I always try to compile for 64 bit but when trying to install VC++ 10 SP1 it sais: 'Microsoft Visual C++ Compilers 2010 Standard x86 - 10.0.40219'

And in /docs/msw.install.txt it reads: 'Visual C++ Express Edition does not include 64-bit compilers.'

And I found this: 'If you didn't use the installer, it is highly recommended that you do so by hand. You will need to setup WXWIN to the full location where you installed wxWidgets to (e.g. C:\wx\wx288).'

Trying to reinstall wxWidgets-2.9.3 and compile in the installation dir... Still the same.

I found a page descrybing the same problem but no solution was found: forums.wxwidgets.org

Found 'In the 2010 edition, converting vanilla wxWidgets projects from .dsw to .vcxproj format is an operation that fails.'. Trying the solution found at coderomp ...

Should I used SHARED = 0 or 1???

Edited by FeXoR

Share this post

Link to post
Share on other sites

OK. It worked in the command line:

cd C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC
set WXWIN="C:\Users\fexor\dat\libs\wxWidgets\wxWidgets-2.9.3"
cd C:\Users\fexor\dat\libs\wxWidgets\wxWidgets-2.9.3\build\msw
nmake -f makefile.vc UNICODE=1 BUILD="debug"
nmake -f makefile.vc UNICODE=1 BUILD="release"

Atlas now runs (build in the gui).

Still this problem is strange since not many ppl seam to have it.

Plz let me know if any other solution is found.

Maybe someone more into this should look this through and update the README.txt for the use of wxWidgets-2.9.3.

Edited by FeXoR

Share this post

Link to post
Share on other sites

I found this thread when trying to build wxwidgets with VS2010.

It worked this way, but I had to add an additional option:

nmake -f makefile.vc UNICODE=1 USE_OPENGL=1 BUILD="release"

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...