Jump to content

0ad compiles with a lot of warnings and after does not run!


Recommended Posts

Hi to everyone:

I have one big problem: I'm trying to compile and run 0ad in my computer, but 0ad compiles with a lot of warnings and after does not run! ;)

The compilation process shows these messages in the console: (see the attached compile.txt file). :)

The running process shows these messages in the console: (see the attached run0ad.txt file). ;)

What can I do? :)

compile.txt

run0ad.txt

Link to post
Share on other sites

What version of the game is this?

Can you run it in a debugger? ("gdb /usr/bin/pyrogenesis", "r", wait for crash, "bt full")

This is the latest version: r07970 in Arch Linux system.

This is the outcome from gdb:


[user@archerpc ~]$ gdb /opt/0ad/system/pyrogenesis
GNU gdb (GDB) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/0ad/system/pyrogenesis...done.
(gdb) r
Starting program: /opt/0ad/system/pyrogenesis
[Thread debugging using libthread_db enabled]
ERROR: Error initializing FAM; hotloading will be disabled
TIMER| InitVfs: 5.36425 ms
[New Thread 0x7ffff7ff8710 (LWP 3095)]
[New Thread 0x7fffec43f710 (LWP 3096)]
TIMER| InitScripting: 725.74 us
TIMER| CONFIG_Init: 2.32214 ms
TIMER| write_sys_info: 1.93597 ms
Performance warning: your graphics card does not support compressed textures. The game will try to continue anyway, but may be slower than expected. Please try updating your graphics drivers; if that doesn't help, please try upgrading your hardware.
TIMER| InitRenderer: 328.497 ms
TIMER| ps_console: 1.6314 ms
TIMER| ps_lang_hotkeys: 1.4252 ms
TIMER| common/setup.xml: 893.04 us
TIMER| common/styles.xml: 275.587 us
TIMER| common/sprite1.xml: 1.94887 ms
TIMER| common/init.xml: 1.66723 ms
TIMER| pregame/sprites.xml: 646.652 us
TIMER| pregame/styles.xml: 113.394 us
TIMER| pregame/mainmenu.xml: 8.23929 ms
TIMER| common/global.xml: 504.343 us
TIMER| common/setup.xml: 484.363 us
TIMER| common/styles.xml: 222.712 us
TIMER| common/sprite1.xml: 1.89339 ms
TIMER| msgbox/msgbox.xml: 863.22 us
[Thread 0x7ffff7ff8710 (LWP 3095) exited]
[New Thread 0x7ffff7ff8710 (LWP 3097)]
[Thread 0x7ffff7ff8710 (LWP 3097) exited]
[New Thread 0x7ffff7ff8710 (LWP 3098)]
TIMER| common/setup.xml: 519.035 us
TIMER| common/styles.xml: 219.764 us
TIMER| common/sprite1.xml: 1.82453 ms
TIMER| gamesetup/setup.xml: 372.066 us
TIMER| gamesetup/sprites.xml: 115.712 us
TIMER| gamesetup/styles.xml: 136.3 us
TIMER| gamesetup/gamesetup_mp.xml: 4.57322 ms
[Thread 0x7ffff7ff8710 (LWP 3098) exited]
[New Thread 0x7ffff7ff8710 (LWP 3099)]
TIMER| common/setup.xml: 553.983 us
TIMER| common/styles.xml: 296.036 us
TIMER| common/sprite1.xml: 1.99145 ms
TIMER| gamesetup/setup.xml: 82.559 us
TIMER| gamesetup/sprites.xml: 51.449 us
TIMER| gamesetup/styles.xml: 66.613 us
TIMER| gamesetup/gamesetup.xml: 4.43206 ms
[Thread 0x7ffff7ff8710 (LWP 3099) exited]
[New Thread 0x7ffff7ff8710 (LWP 3100)]
[Thread 0x7ffff7ff8710 (LWP 3100) exited]
[New Thread 0x7ffff7ff8710 (LWP 3101)]
TIMER| common/setup.xml: 569.491 us
TIMER| common/styles.xml: 286.61 us
TIMER| common/sprite1.xml: 1.93573 ms
TIMER| common/init.xml: 1.66176 ms
TIMER| loading/loading.xml: 963.624 us
TIMER| common/global.xml: 327.529 us
TIMER| common/setup.xml: 577.34 us
TIMER| common/styles.xml: 299.012 us
TIMER| common/sprite1.xml: 1.89901 ms
TIMER| common/icon_sprites.xml: 5.62878 ms
TIMER| session_new/sprites.xml: 995.378 us
TIMER| session_new/styles.xml: 224.682 us
TIMER| session_new/session.xml: 37.7509 ms
TIMER| common/global.xml: 1.16057 ms
[New Thread 0x7fffe64b3710 (LWP 3102)]
SND| alc_init: success, using ALSA Software
GAME STARTED, ALL INIT COMPLETE
[Thread 0x7ffff7ff8710 (LWP 3101) exited]
[New Thread 0x7ffff7ff8710 (LWP 3103)]

Program received signal SIGSEGV, Segmentation fault.
0x00007fffeb648296 in ?? () from /usr/lib/xorg/modules/dri/r600_dri.so
(gdb) bt full
#0 0x00007fffeb648296 in ?? () from /usr/lib/xorg/modules/dri/r600_dri.so
No symbol table info available.
Cannot access memory at address 0x7fffffffda78
(gdb)

Link to post
Share on other sites

/usr/lib/xorg/modules/dri/r600_dri.so is the graphics driver, so it sounds like the bug is there. Several people have reported problems with the drivers for ATI hardware - I think they were fixed in later versions, so upgrading things like Mesa (maybe to a git snapshot, I don't know if it's in a stable release) might help. Otherwise you should probably report it as a driver bug.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...