Sign in to follow this  
Followers 0
ROMMEL_HSQ

Can't install on Fedora 16

6 posts in this topic

I hope this is the right place. I have just found about this game and wanted to give it a try. I tried to follow the instructions. I will post here what i did and what was the output of the terminal.

when i use the command: curl http://download.open...a_15/games.repo >/etc/yum.repos.d/obs-games.repo

I get the following:

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 220 100 220 0 0 1320 0 --:--:-- --:--:-- --:--:-- 3728

after that, with "yum install 0ad" I get the following:

Loaded plugins: langpacks, presto, refresh-packagekit

games | 1.7 kB 00:00

games/primary | 6.3 kB 00:00

games 26/26

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package 0ad.x86_64 0:r10803-3.2 will be installed

--> Processing Dependency: 0ad-data for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libenet.so.1()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_signals-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_system-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libwx_gtk2u_gl-2.8.so.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Running transaction check

---> Package 0ad.x86_64 0:r10803-3.2 will be installed

--> Processing Dependency: libboost_signals-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_system-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

---> Package 0ad-data.noarch 0:r10803-1.1 will be installed

---> Package libenet1.x86_64 0:1.3.3-3.1 will be installed

---> Package wxGTK-gl.x86_64 0:2.8.12-1.fc16 will be installed

--> Finished Dependency Resolution

Error: Package: 0ad-r10803-3.2.x86_64 (games)

Requires: libboost_signals-mt.so.1.46.0()(64bit)

Error: Package: 0ad-r10803-3.2.x86_64 (games)

Requires: libboost_system-mt.so.1.46.0()(64bit)

You could try using --skip-broken to work around the problem

** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:

1:kmod-nvidia-2.6.35.10-74.fc14.x86_64-260.19.36-1.fc14.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.10', '74.fc14.x86_64')

1:kmod-nvidia-2.6.35.12-90.fc14.x86_64-260.19.36-1.fc14.3.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.12', '90.fc14.x86_64')

1:kmod-nvidia-2.6.35.14-106.fc14.x86_64-280.13-2.fc14.6.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '106.fc14.x86_64')

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libhunspell-1.2.so.0()(64bit)

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libnotify.so.1()(64bit)

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libvpx.so.0()(64bit)

When I try the other fedora14 version: url http://download.opensuse.org/repositories/games/Fedora_14/games.repo >/etc/yum.repos.d/obs-games.repo

i get:

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 1046 0 1046 0 0 10676 0 --:--:-- --:--:-- --:--:-- 21346

and when I used the "yum install 0ad" I get the following:

Loaded plugins: langpacks, presto, refresh-packagekit

File contains no section headers.

file: file://///etc/yum.repos.d/obs-games.repo, line: 1

'<?xml version="1.0" encoding="ISO-8859-1"?>\n'

Share this post


Link to post
Share on other sites

I don't have experience with this, but if you're on Fedora 16, shouldn't the first command be:


curl http://download.opensuse.org/repositories/games/Fedora_16/games.repo >/etc/yum.repos.d/obs-games.repo

Maybe the instructions just haven't been updated for Fedora 16.

Share this post


Link to post
Share on other sites

I don't have experience with this, but if you're on Fedora 16, shouldn't the first command be:


curl http://download.opensuse.org/repositories/games/Fedora_16/games.repo >/etc/yum.repos.d/obs-games.repo

Maybe the instructions just haven't been updated for Fedora 16.

I tried, i get this:

yum install 0ad

Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit

games | 1.7 kB 00:00

Not using downloaded repomd.xml because it is older than what we have:

Current : Mon Feb 20 04:45:55 2012

Downloaded: Thu Feb 9 22:13:12 2012

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package 0ad.x86_64 0:r10803-3.2 will be installed

--> Processing Dependency: 0ad-data for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libwx_gtk2u_gl-2.8.so.0(WXU_2.8)(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libenet.so.1()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_signals-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_system-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libwx_gtk2u_gl-2.8.so.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Running transaction check

---> Package 0ad.x86_64 0:r10803-3.2 will be installed

--> Processing Dependency: libboost_signals-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

--> Processing Dependency: libboost_system-mt.so.1.46.0()(64bit) for package: 0ad-r10803-3.2.x86_64

---> Package 0ad-data.noarch 0:r10803-1.1 will be installed

---> Package libenet1.x86_64 0:1.3.3-3.1 will be installed

---> Package wxGTK-gl.x86_64 0:2.8.12-1.fc16 will be installed

--> Finished Dependency Resolution

Error: Package: 0ad-r10803-3.2.x86_64 (games)

Requires: libboost_signals-mt.so.1.46.0()(64bit)

Error: Package: 0ad-r10803-3.2.x86_64 (games)

Requires: libboost_system-mt.so.1.46.0()(64bit)

You could try using --skip-broken to work around the problem

** Found 6 pre-existing rpmdb problem(s), 'yum check' output follows:

1:kmod-nvidia-2.6.35.10-74.fc14.x86_64-260.19.36-1.fc14.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.10', '74.fc14.x86_64')

1:kmod-nvidia-2.6.35.12-90.fc14.x86_64-260.19.36-1.fc14.3.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.12', '90.fc14.x86_64')

1:kmod-nvidia-2.6.35.14-106.fc14.x86_64-280.13-2.fc14.6.x86_64 has missing requires of kernel-uname-r = ('0', '2.6.35.14', '106.fc14.x86_64')

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libhunspell-1.2.so.0()(64bit)

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libnotify.so.1()(64bit)

xulrunner2-2.0.1-1.fc14.x86_64 has missing requires of libvpx.so.0()(64bit)

Share this post


Link to post
Share on other sites

OK, I talked with the maintainer of those Fedora packages, it just happens to be our very own Philip (Ykkrosh) :) The Fedora 16 build of 0 A.D. was disabled on the OpenSuse Build Service, but it appears to be working now: https://build.opensuse.org/package/show?package=0ad&project=games

Can you try now with my last suggestion? You may need to clean up the other failed attempts. If it works, we'll add that to our Fedora instructions

Share this post


Link to post
Share on other sites

OK, I talked with the maintainer of those Fedora packages, it just happens to be our very own Philip (Ykkrosh) :) The Fedora 16 build of 0 A.D. was disabled on the OpenSuse Build Service, but it appears to be working now: https://build.opensu...d&project=games

Can you try now with my last suggestion? You may need to clean up the other failed attempts. If it works, we'll add that to our Fedora instructions

Downloaded and installed. Thanks alot, it is working :)

P.S for reference, a couple of the mirrors were out it seems, but a third was available:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0