Jump to content
Sign in to follow this  
vito

Game Error

Recommended Posts

Hi guys i hope this is the right forum section where i can write my problem with 0AD, first of all I would like to congratulate all who working on the implementation of this game. My problem is that when i stat the game i have this error :

Much to our regret we must report the program has encountered an error.

Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Access violation reading 0x00000000)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)

errno = 0 (No error reported here)

OS error = 2 (Impossibile trovare il file specificato.)

Please help me solve this problem, thanks to all by Vito ( Age of Empires the Conquerors old player )

Share this post


Link to post
Share on other sites

OK, in that case can you try using DebugView to view the debug output of the game when it loads and paste the output here?

00000001 0.00000000 [3548] HRT: activating HPET failed: Unknown error (-100032, 0xFFFFFFFFFFFE7940)

00000002 0.00006034 [3548] HRT: using name=TSC freq=2079000000.000000

00000003 0.00011454 [3548] HRT: counter=TSC freq=2.079e+009 res=4.81e-010 bits=64

00000004 0.00381808 [3548] Cache: 200 (total: 768) MiB

00000005 0.00741239 [3548] TIMER| InitVfs: 4.90517 ms

00000006 0.03815792 [3548] TIMER| InitScripting: 2.53689 ms

00000007 0.29820409 [3548] TIMER| CONFIG_Init: 259.693 ms

00000008 19.21024513 [3548] unknown(0): Much to our regret we must report the program has encountered an error.

00000009 19.21024513 [3548]

00000010 19.21024513 [3548] Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

00000011 19.21024513 [3548]

00000012 19.21024513 [3548] Details: unhandled exception (Access violation reading 0x00000000)

00000013 19.21024513 [3548]

thanks for the help wink.gif

Share this post


Link to post
Share on other sites

00000001 0.00000000 [3548] HRT: activating HPET failed: Unknown error (-100032, 0xFFFFFFFFFFFE7940)

I think this problem could probably be solved by Revision 10858.

Could you please get an updated version of the game and test with this one?

How to do this:

Acquiring the code

The game's code, data and build environment are stored on a Subversion server. The recommended way to get an up-to-date copy is with TortoiseSVN:

* Download and install TortoiseSVN. (Make sure you reboot when it asks you to.)

* Use TortoiseSVN to check out http://svn.wildfiregames.com/public/ps/trunk/. This may take a while, and will use around 1.2GB of disk space. If there are errors during the checkout, use TortoiseSVN's "update" to resume downloading.

There's a prebuilt version for windows, so you can just execute pyrogenesis.exe in 0ad\binaries\system once you have downloaded it and don't need to build the game from source.

Btw. here are the full Build Instructions, but you just need the part I quoted.

Share this post


Link to post
Share on other sites
00000001 0.00000000 [3548] HRT: activating HPET failed: Unknown error (-100032, 0xFFFFFFFFFFFE7940)

I think this problem could probably be solved by Revision 10858.

That "Unknown error" is not a problem - it's perfectly normal for the game to fail to load the HPET timer and fall back to the TSC timer. r10858 should stop that message but shouldn't affect the behaviour of the game, so I don't think there's any need to try a recent SVN version.

There really ought to be some crashlog files in %appdata%\0ad\logs\ and I don't know why they might fail to be there :(. Without them, probably the best way to debug the problem is with these instructions to hopefully see where it's failing.

Share this post


Link to post
Share on other sites

To expand a bit more on Philip's entirely correct reply:

The message just means the platform/BIOS does not provide a HPET, so activating it understandably fails :)

r10858 will indeed stop this from appearing, because we would no longer even check for the HPET (unless the user takes additional action by invoking aken_install.bat).

I am not sure why the error code isn't resolved into an error string - that's worrisome and will be investigated tomorrow.

Share this post


Link to post
Share on other sites

I am not sure why the error code isn't resolved into an error string - that's worrisome and will be investigated tomorrow.

Would it be possible to display a different error message if the crash dumps weren't generated for whatever reason, and give the path to them otherwise since surely that will be known?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...