Jump to content

Help with modding units


Recommended Posts

Okay, so I have been trying to mod in a new unit with a custom model, skeleton and animations into the game for a while. I have created the actor file in the mod directory and the subdirectories for the mesh and the skeleton but everytime I try to load the new unit in Atlas it outputs:


error: art/meshes/skeletal/argonian_militia.dae: Assertion not satisfied (line 393): failed requirement "recognized skeleton structure"

error: Could not load mesh 'art/meshes/skeletal/argonian_militia.dae'

error: CObjectEntry: :BuildVariation(): Model art/meshes/skeletal/argonian_militia.dae failed to load


I'm kinda clueless on what may be causing this. Can you help me out?


  • Like 1
Link to comment
Share on other sites

3 hours ago, azayrahmad said:

Is this an Elder Scrolls mod?

The model itself is from an Elder Scrolls total conversion but I have no plan of actually releasing anything. I am just using that to practice modeling and animations in 0 A.D.

If and when I become good enough at modding I may actually try to release a fully fledged mod but I am still very, very far away from that point :P

Link to comment
Share on other sites

6 hours ago, Trinketos said:

Sounds like some bones are not define in the skeleton file or they are not written well.

I recommend to use this python script for generating the skeleton file:

It worked, thank you very much, Atlas imports the rigged mesh properly now.

I have also tried to bake and export the dae animations from Blender as suggested in the AnimationExportTutorial and while the animation loads, it looks completely deformed. Is it a problem with the scale of the mesh or is the baking process that's messed up?

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...