Jump to content

Recommended Posts

Hi@all,

ich spiele 0ad auf einer mobilen Workstation von HP

Machine:   Type: Laptop System: HP product: HP ZBook Studio G5 v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: HP model: 8427 v: KBC Version 16.48.00 serial: <filter> UEFI: HP 
           v: Q71 Ver. 01.12.00 date: 07/29/2020

CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake 
           rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52799 
           Speed: 3999 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 3999 2: 3934 3: 3996 
           4: 3982 5: 3943 6: 3999 7: 3995 8: 4001 9: 4000 10: 3981 11: 3999 12: 3995

Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Hewlett-Packard driver: nvidia 
           v: 450.80.02 bus ID: 01:00.0 chip ID: 10de:1cbb 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
           unloaded: fbdev,nouveau,vesa resolution: 3840x2160~60Hz 
           OpenGL: renderer: Quadro P1000/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 direct render: Yes

When I start 0AD the game uses 100% of the CPU. Therefore the fan runs all the time and the notebook gets warm accordingly.

i have tried to limit the process (0ad) with the help of cpulimit but it does not work

me@lt001:/usr/games$ cpulimit --pid 4342 -c 1 -l 1
Process 4342 detected

is there a way to limit the CPU load when starting 0AD?

 

with best

pixel24

Link to post
Share on other sites

Hello,
in game options you can try to limit fps, settings -> graphics, it should help with cpu load.
Aside from this, game is more-less single thread bound so all simulation computations occupies your 1 thread.
If you start game first time, load can be higher, but later it should not be so much.
Does it run always at 100 % ?
Also to my knowledge modern cpus are fine with running at 100%, but maybe you could check the graphic settings if fans are too loud, 

Link to post
Share on other sites
18 hours ago, pixel24 said:

ok, I set all graphics options to the lowest value. CPU load is now at 50%. The fan is still running continuously :-(

Did you try remove the fan from your computer? It helps in 100% cases

Link to post
Share on other sites

btw some computers can setup  modes, e.g I can have 3 settings, in highest one graphics tries to render max quality and cpu works really hard so fans will run like crazy. 

But I never use that one :D

 

if you do not have that option in your pc, there are always some settings in windows (additional power settings), which can influence how hot your laptop gets. Basicly you can limit there maximum speed/work for your cpu and other things. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...