Jump to content

Another error building the game for the first time


Recommended Posts

Hello,

  Attached is the list of commands I have tried thus far. I'm in over my head here. There may be an issue with the Fedora Silverblue container toolbox. I've only been playing with Fedora Silverblue for a few weeks. The game works fine as a flatpak on this machine. I am interested in hacking around with the AI, and was hoping to get debugging of some kind working. Perhaps there is a better way than what I have tried thus far.

  To anyone unaware, Silverblue, has immutable binaries. So software updates are done during a restart and most software is sandboxed by default. It is also setup with "toolboxes" for a containerized CLI workspace. Once a toolbox is created it works like a regular Fedora Workstation. The only other tricky thing that might be an issue is that the file tree structure is slightly different than a typical unix-like system. Basically the home directory is under /var/ instead of root, as root is immutable. If you want a GNU/Linux OS that just works, is secure, and runs secure boot on an UEFI stub instead of ancient legacy bios, F-SB is it. The default software center has the current 0AD release available as a flatpak. Mods work on it too just add them to the local ~/.var/ version of the game files.

Anyways, I'm not getting anywhere with the pyrogenesis or pyrogenesis_gdb version. I don't know GDB well enough to get anywhere useful with it. I tried and added some of the output to the end of the attached file. Any help or advice is appreciated.

$ lshw -short
/0/1                   processor      Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
/0/100/2               display        HD Graphics 5500

$ uname -a
Linux toolbox 5.7.10-201.fc32.x86_64 #1 SMP Thu Jul 23 00:58:39 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

$ dnf --version
4.2.23
  Installed: dnf-0:4.2.23-1.fc32.noarch at Thu Jun 25 19:05:38 2020
  Built    : Fedora Project at Tue Jun  2 19:50:03 2020
 
  Installed: rpm-0:4.15.1-3.fc32.1.x86_64 at Thu Jun 25 19:05:17 2020
  Built    : Fedora Project at Mon May  4 07:32:48 2020

aka current Fedora 32 Silverblue.

I cloned the github mirror yesterday

...Really...I just wanted to see if "gameState.getResources()" refers to the map or the player ID...

install-history.txt

crashlog.txt

Edited by Jake L
Link to post
Share on other sites

You seem to have an issue with your sound driver and or your graphics driver. For the former you can disable sound either by running the game with the --nosound flag or by compiling without sound. See /build/premake/premake5.lua for some options.

Link to post
Share on other sites

Is there a way to determine the setup used in the Fedora flatpak version of the game and use it as a baseline to find a solution? The sound and graphics work without any issues in it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...