Jump to content

Multiplayer joinin problem / Port forwarding


Recommended Posts



This is amazing project, I wish I could participate.


I'm been suffering problems with joining games in multiplayerlobby. Couple of times I have managed to join games after ridiculous amount of time. I got notifications about my ping, unfortunately at time I  did not understand concept. Later I concluded poor internet access was reason, but I'm not satisfacted with that, couple of times big game has worked well, and never before had had problems with speed. 


Problem seem to be joining other servers, and if I host game, no one seem to be able to join.  I clearly see lobby activity and I can chat with easy. Might geographical distances be a problem? 


I'm using Linux mint 18.3 and 0.ad ken wood. My router is ZTE MFD93D and in a speedtest i get ping:14 ms download 22 mbps and upload 10 mbps. Router says UPnP is enabled an port mapping (equals port forwarding?) Src. port 20595 (my IP) Dest. port 20595, protocol UDP+TCP.  


sudo iptables -L -v gives

Chain ufw-user-input (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 ACCEPT     tcp  --  any    any     anywhere             anywhere             tcp dpt:20595
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:20595
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:20595


and this gives:

$ sysctl net.ipv4.ip_forward
net.ipv4.ip_forward = 1

What I am missing? This might be really silly problem, but never before worked with connection related problems and got little clues from net. 







Link to comment
Share on other sites

  • 2 months later...





Related to new house, I got new internet connection and router. I would like to diagnose exact problem some other time, but I managed to join today every game and to my hosting was possible to join.


Seem to be, problem was old mobile router. Nevertheless, internet speed was not problem, because I usually did not get notifications for lagging. 


What I have done:

1) New Router Zyxel VMG3925-B10B

2) Make hole in the firewall:

X75A1 ~ $ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
20595/udp                  ALLOW       Anywhere                  
20595/udp (v6)             ALLOW       Anywhere (v6)             


3) Put static IP (dont ask, HC science for me :) )

4) Make port forwarding to router


I have done all previous with old router without success, I could have joined some games. When I have  spare time, I remove firewall hole, port forwarding and static IP and check, if they are necessary. 



Thank you all involved! 




Link to comment
Share on other sites

And for my confusion, when I check port 20595 on internet, for example, https://portchecker.co/check, i always get port is closed, also opening port by:

X75A1 ~ $ sudo nc -u -l 20595

do not help, but now game work. 


For information, my old speed test and new. With downloading speed 1.9 Mbs i have been played without problem. 





  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...