Jump to content

Errors while building alpha 0.0.23 under debian GNU/Linux


Recommended Posts


I've get some Errors and many messages while I tried to build the new release. I don't know further. After a bit contact with the deloppers in the chatroom, it couldn't get solved. So I ask again but now here in the forum.

The content of the found buildRunner2.txt is the follows:

Running cxxtest tests (2 tests).
In MyTestSuite2::testMultiplication:
MyTestSuite2.h:16: Error: Expected (2 * 2 == 5), found (4 != 5)
Failed 1 and Skipped 0 of 2 tests
Success rate: 50%

Oh stop, I only notice now, that it is in the sub-directory libraries/sources/cxxtest-4.4/examples.

So I need to look for other log files or there like. I found no other in the directory, in which the rest of the files is stored. The output of the console seems to be too big for the post, I will try it on an other way now: With a link to the fille in which I copied the console-output:link_to_the_console-output

I hope that finally it will work now, with the post.

Okay, but I forgot to write, that I used the official sources from the download-page of the official webpage.

Edited by Karnorth85
Link to comment
Share on other sites

Welcome to the forums!

Could we ask you to start at the beginning, tell us where you've got the source from, and take us through the exact steps you've used to get to this point, please? (List the exact commands, any arguments you're passing to them, etc.)

Relevant IRC Chat log excerpt: (http://irclogs.wildfiregames.com/2018-05/2018-05-22-QuakeNet-%230ad-dev.log)


09:00	Karnorth85_	has joined #0ad-dev
09:04	Karnorth85_	Hi, I've got a question about an error during the linking, I tink. The 1st line of the error message is: collect2: error: ld returned 1 exit status ; then a line like: pyrogenesis.make:83: recipe for target '../../../binaries/system/pyrogenesis' failed ; could I have forget to install any lib?
09:08	Stan		Hello there do you have any errors before that ?
09:11	Karnorth85_	Hello Stan, not that I could see them, but many messages about undefined references.
09:14	Stan		Stdlib by any chance ?
09:15	Karnorth85_	Ah and before I forget it: after the lines I told before there are 3 lines more on the error, but thank you, I will thake a look on the URL you told me.
09:20	Karnorth85_	Stdlib, for C or C++ or Python? - Synaptic shows python and golang, if I type in stdlib, only.
09:21	Stan		C++ we have had some issues with with recent versions of gcc
09:22	Stan		After trying people realised they couldn't event compile a hello world
09:25	Karnorth85_	I thook a look, but libstdc++6 is installed bevore.
09:25	Imarok		Karnorth85_ wanna upload your buildlog e.g. on pastebin?
09:28	Karnorth85_	By the way, I need to say that I use debian GNU/Linux, pasetebin? - Need I there an account? - I ask because by an file bugtracking website on which name I don't know jet, I had problems with login in a long time ago.
09:33	Imarok		No, pastebin.com needs no account
09:36	Karnorth85_	Okay, then that should be no problem if I find the directory with the buildlog.
09:39	Imarok		There is one?
09:39	Imarok		Just copy the console output
09:41	Karnorth85_	Okay, that's much but possible. And now I found the file buildRunner2.log. I thik I attach both, is that Okay?
09:44	Imarok		Sure
09:46	Karnorth85_	Okay, the whole console output is copied into a file, now I look for pastebin.
09:51	Karnorth85_	I found pastebin, but I'm not shure what is where to entry. So I need to look for a manual for guest users. That could need for looking for it and reading the manual.
09:52	Imarok		Just paste text there?
09:53	Imarok		https://pastebin.com
09:55	Imarok		You know, with Ctrl + C and Ctrl + V
09:56	Karnorth85_	Ah yes but need it some indentations or formattings?
10:00	Imarok		Don't care
10:00	Karnorth85_	Ah okay.
10:08	Imarok		Just upload it
10:08	Karnorth85_	By creating a new paste, I recive rather an error message: You have exceeded the maximum paste size of 512 kilobytes per paste. PRO users don't have this limit! ; I think that comes from the pagewise messages from undefined references and so on.
10:09	Karnorth85_	Schould I try to short it?
10:16	Imarok		Then just upload the First Part?
10:17	Karnorth85_	Shortened it worked, the URL is: https://pastebin.com/4wxTfzU5
10:18	Imarok		Could you just upload the first part of the console output?
10:20	Karnorth85_	I can try it, but because the fact that it are many screenpages, I can't say theter that's possible. I try it simlpy.
10:21	elexis		Expected (2 * 2 == 5)?
10:21	Imarok		Try Paste.ee, that has 1mb limitation
10:22	elexis		it looks like someone copy&pasted an example code that is meant to be modified
10:23	elexis		void testMultiplication in source/cxxtest-4.4/doc/examples/MyTestSuite2.h
10:23	Imarok		Yeah xD
10:24	Karnorth85_	Pastebin dont work with the rest of the consoleoutput. paste.ee? - I thake a look whether I find it per google.
10:24	elexis		4x4=12 > 2+2=5
10:27	Imarok		Karnorth85_: What? come on, why do you google an URL? ><
10:28	Karnorth85_	Bad news, paste.ee says that the console-output is 6mb sized bur only 1mb are allowed.
10:28	Karnorth85_	bur? , sorry I menaned but.
10:29	Imarok		then just upload the first sixtht?
10:29	Imarok		are you using svn
10:31	Imarok		?
10:32	Karnorth85_	Not the SVN the sources of the release, I've uploaded the first 6 lines of the console-output: https://paste.ee/p/67nXw
10:33	Imarok		how did you get the code?
10:34	Imarok		with sixtht I meant 1/6 of the whole output
10:34	Imarok		but that six lines look like no, or wrong spidermonkey
10:34	Imarok		maybe want just create a forum topic with your issue?
10:34	Imarok		@forum
10:34	WildfireBot	http://wildfiregames.com/forum/
10:35	Karnorth85_	I donloaded it from the website of the project.
10:36	Karnorth85_	Ooops, no or wrong spidermonkey? but I tried it like in the buildinstructions described.
10:37	Imarok		as said, just start a forum topic, where you post the whole build output
10:38	Karnorth85_	Okay, than in the forum. It seems that there's no other way. See you.
10:39	Karnorth85_	has left #0ad-dev []
  • Like 1
Link to comment
Share on other sites

Well I donloaded the source from this official site: https://play0ad.com/download/source/

Then I followed the build-instructions from this site, under considering the Dependencies further above: https://trac.wildfiregames.com/wiki/BuildInstructions#DebianUbuntu

Then I entered  into the console as further down described, but with other CPU-Core count: ./update-workspaces.sh -j5

When that had gone through I entered in the subdirectory gcc: make -j5

As so far, I don't see what I did do wrong. Whatever I did wrong, I seems to did a fail.

Link to comment
Share on other sites

Funny wise, I came to the Idea, to delete the uncompressed directory and uncompress again. The result of going in the directory "0ad-0.0.23-alpha/build/workspaces" calling the script with "./update-workspaces.sh --with-system-nvtt -j5" going into the subdirectory gcc and calling "make -j5" did throw a lesser number of error messages. Only these messages kept remained, after many status messages :unsure::

==== Building pyrogenesis (release) ====
Linking pyrogenesis
../../../binaries/system/libengine.a(ModIo.o): In function `ModIo::ModIo()':
/home/arne/0ad_Ken_Wood/0ad-0.0.23-alpha/build/workspaces/gcc/../../../source/ps/ModIo.cpp:120: undefined reference to `sodium_base642bin'
../../../binaries/system/libengine.a(ModIo.o): In function `ModIo::ParseSignature(std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&, SigStruct&, PKStruct const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&)':
/home/arne/0ad_Ken_Wood/0ad-0.0.23-alpha/build/workspaces/gcc/../../../source/ps/ModIo.cpp:777: undefined reference to `sodium_base642bin'
/home/arne/0ad_Ken_Wood/0ad-0.0.23-alpha/build/workspaces/gcc/../../../source/ps/ModIo.cpp:793: undefined reference to `sodium_base642bin'
collect2: error: ld returned 1 exit status
pyrogenesis.make:83: recipe for target '../../../binaries/system/pyrogenesis' failed
make[1]: *** [../../../binaries/system/pyrogenesis] Error 1
Makefile:68: recipe for target 'pyrogenesis' failed
make: *** [pyrogenesis] Error 2"


Okay it are not so much as before, but I must agree that I'm confused now. Especially what I entered wrong things before.

Link to comment
Share on other sites


when I read the post from stanislas69 my answer limit was reached, but I checked it out: In the repositories only an older version than needed was available. So after I uninstalled this one, I downloaded and installed a newer one that I think is 1.0.16. Then it worked, I could only announce it today. Because I couldn't answer again on yesterday. Now the Alpha 23 works. That I've got checked. By the way, I can say thank you all for the help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...