Jump to content

[SOLVED] Cannot build Alpha 19 on Chakra, SpiderMonkey build fails


Recommended Posts

Input:

cd build/workspacesunset CPPFLAGS # for le spidermonkey./update-workspaces.sh \  --disable-atlas \  --with-system-miniupnpc \  --with-system-nvtt \  --bindir=/usr/bin \  --libdir=/usr/lib/0ad \  --datadir=/usr/share/${pkgname}/data

Output:

Updating bundled third-party dependencies...Building SpiderMonkey...SpiderMonkey build options: --enable-shared-js --enable-gcgenerational --disable-tests --without-intl-api      --host=x86_64-unknown-linux-gnu   --enable-shared-js --enable-gcgenerational --disable-tests --without-intl-api --host=x86_64-unknown-linux-gnupatching file js/src/jit/BaselineCompiler.cppHunk #1 succeeded at 338 (offset 1 line).patching file js/src/vm/TraceLogging.cpppatching file js/src/vm/TraceLogging.hpatching file js/src/jit/MCallOptimize.cppHunk #1 succeeded at 1734 (offset -55 lines).patching file js/src/builtin/TypedObject.cppHunk #6 succeeded at 2461 (offset 17 lines).patching file js/src/frontend/BytecodeCompiler.cpppatching file js/public/Utility.hHunk #1 succeeded at 89 (offset 6 lines).patching file js/src/jsgcinlines.hpatching file js/src/vm/Debugger.cppcreating cache ./config.cachechecking host system type... x86_64-unknown-linux-gnuchecking target system type... x86_64-unknown-linux-gnuchecking build system type... x86_64-unknown-linux-gnuchecking for gawk... gawkchecking for perl5... nochecking for perl... /usr/bin/perlchecking for gcc... gccchecking whether the C compiler (gcc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wl,-O1,--sort-common,--as-needed,-z,relro) works... yeschecking whether the C compiler (gcc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wl,-O1,--sort-common,--as-needed,-z,relro) is a cross-compiler... nochecking whether we are using GNU C... yeschecking whether gcc accepts -g... yeschecking for c++... c++checking whether the C++ compiler (c++ -DTRACE_LOG_DIR="\"/tmp/traces/\"" -Wl,-O1,--sort-common,--as-needed,-z,relro) works... yeschecking whether the C++ compiler (c++ -DTRACE_LOG_DIR="\"/tmp/traces/\"" -Wl,-O1,--sort-common,--as-needed,-z,relro) is a cross-compiler... nochecking whether we are using GNU C++... yeschecking whether c++ accepts -g... yeschecking for ranlib... ranlibchecking for as... /usr/bin/aschecking for ar... archecking for ld... ldchecking for strip... stripchecking for windres... nochecking how to run the C preprocessor... gcc -Echecking how to run the C++ preprocessor... c++ -Echecking for sb-conf... nochecking for ve... nochecking for a BSD compatible install... /usr/bin/install -cchecking whether ln -s works... yeschecking for tar archiver... checking for gnutar... nochecking for gtar... nochecking for tar... tartarchecking for minimum required perl version >= 5.006... 5.018000checking for full perl installation... yeschecking for python2.7... /usr/bin/python2.7Creating Python environmentNew python executable in /chakra/desktop/0ad/src/0ad-0.0.19-alpha/libraries/source/spidermonkey/mozjs31/js/src/build-debug/_virtualenv/bin/python2.7Also creating executable in /chakra/desktop/0ad/src/0ad-0.0.19-alpha/libraries/source/spidermonkey/mozjs31/js/src/build-debug/_virtualenv/bin/pythonInstalling setuptools, pip...done.running build_extcopying build/lib.linux-x86_64-2.7/_psutil_linux.so -> copying build/lib.linux-x86_64-2.7/_psutil_posix.so -> checking Python environment is Mozilla virtualenv... Traceback (most recent call last):  File "<string>", line 1, in <module>  File "/chakra/desktop/0ad/src/0ad-0.0.19-alpha/libraries/source/spidermonkey/mozjs31/python/mozbuild/mozbuild/base.py", line 17, in <module>    from mach.mixin.process import ProcessExecutionMixin  File "/chakra/desktop/0ad/src/0ad-0.0.19-alpha/libraries/source/spidermonkey/mozjs31/python/mach/mach/mixin/process.py", line 29, in <module>    raise Exception('Could not detect environment shell!')Exception: Could not detect environment shell!configure: error: Python environment does not appear to be sane.------ config.log ------configure:3164:1: warning: incompatible implicit declaration of built-in function 'exit'configure:3164:1: note: include '<stdlib.h>' or provide a declaration of 'exit'configure:3187: checking for ranlibconfigure:3219: checking for asconfigure:3273: checking for arconfigure:3308: checking for ldconfigure:3343: checking for stripconfigure:3378: checking for windresconfigure:3917: checking how to run the C preprocessorconfigure:3938: gcc -E  conftest.c >/dev/null 2>conftest.outconfigure:3997: checking how to run the C++ preprocessorconfigure:4015: c++ -E  conftest.C >/dev/null 2>conftest.outconfigure:4075: checking for sb-confconfigure:4075: checking for veconfigure:4137: checking for a BSD compatible installconfigure:4190: checking whether ln -s worksconfigure:4212: checking for tar archiverconfigure:4218: checking for gnutarconfigure:4218: checking for gtarconfigure:4218: checking for tarconfigure:4256: checking for minimum required perl version >= 5.006configure:4267: checking for full perl installationconfigure:4285: checking for python2.7configure:4395: checking Python environment is Mozilla virtualenvconfigure: error: Python environment does not appear to be sane.ERROR: SpiderMonkey build failed
Link to post
Share on other sites

You're also passing useless config options that were deprecated and a no-op in A18 already. There are possibly more issues, but since both the links on our website in the download section for Chakra are broken, as is the search function for packages on the Chakra website (to which you only get via the CCR search page and even then you have to fix the URL only to be presented with an error) I can't point those out and just tell you to look at the likely less broken Arch PKGBUILD.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...