Jump to content
Sign in to follow this  
tgodtaylor

0AD Constant Lag under 30 FPS

Recommended Posts

Hello,

since I installed 0ad I experience heavy FPS drops & constant 10 FPS in all games.

Other players have no such problems! How is that possible?
Hardware changes makes no difference. When I change from an i5-4460 to an Ryzen 7 2700 it makes no difference.

Graphics card from GTX 960 or GTX 1060 or Radeon 5700 gives the same exact FPS numbers!..

Watch the profile.txt's of some multiplayer games that I fast saved.

 

Thanks in advance,

your TGODTaylor

profile_with_20_fps.txt profile_with_50_fps.txt

Share this post


Link to post
Share on other sites

Do you happen to play on a laptop? What OS are you on? From what I see it's the rendering that's killing your performance. It could be that the laptop is using the wrong GPU.

What pop cap do you use? How many AIs

Share this post


Link to post
Share on other sites

Yes and no

It makes a little difference with deactivated shadows or at low. 8 - 10 fps increase. But this doesn't makes differences in late end games

When I put all graphcis down I get 20 fps more. Im at 40 now.
I can set everything on max but shader model on 1.0 expect 10.0 as I had before. I get constant 10 fps now in late games.

But still others with an Gefore 850M on Ultra get 60 FPS..

Edited by tgodtaylor

Share this post


Link to post
Share on other sites

Might be a driver bug. Do you have stuff running in the background?

2 minutes ago, Stan` said:

Might be a driver bug. Do you have stuff running in the background?

Can you attach the game's log https://trac.wildfiregames.com/wiki/GameDataPaths

4 minutes ago, tgodtaylor said:

But still others with an Gefore 850M on Ultra get 60 FPS..

Windows 10 as well?

 

Do you think you could compile the game? :)

Share this post


Link to post
Share on other sites

Driver bug. Yes. I got a defect graphics card or Mainboard. But i changed my whole system hardware! So its not an hardware issue.. Somehow.

Driver is installed but not the official software delivered with it. Just the .ini for 4k resolution.

 

I can try again to compile it myself. But I think it maked no difference. SVN too..

Windows is reinstalled in the 0ad test times about 5 times. Different versions tryd

I used an 1vs1 agains KI and at minet 5 it droppped to 30 fps. Heavy lag spikes. Here the logs:

profile.txt

Edited by tgodtaylor

Share this post


Link to post
Share on other sites

It lag speaks when I move the camera. So basically yes.

 

#I can't install visual studio 2015 or 2017. I need to pay for it says microsoft.

Visual Studio Community but can't find the mentioned compiler -.-

Edited by tgodtaylor

Share this post


Link to post
Share on other sites
33 minutes ago, tgodtaylor said:

It lag speaks when I move the camera. So basically yes.

What's the FPS when the camera is close to ground and looking directly to the ground (more vertical rather than horizontal, controlled by Ctrl + W/S)?

Share this post


Link to post
Share on other sites
13 minutes ago, vladislavbelov said:

What's the FPS when the camera is close to ground and looking directly to the ground (more vertical rather than horizontal, controlled by Ctrl + W/S)?

When I go to the ground with Crtl + W I lose 15 fps drop (from 50 to 35)

With Crtl + S nothing changes

#Edit: Zooming in and out drops the lag from 50 to 20

Edited by tgodtaylor

Share this post


Link to post
Share on other sites
1 hour ago, Stan` said:

Might be a driver bug. Do you have stuff running in the background?

I don't think there is a driver bug. The game isn't that well threaded yet. So, you won't get an advantage from 8 against 4 cores. The single core performance of both CPUs is nearly the same, so the fps should be also the same.

Also, you won’t benefit from a faster gpu as you are currently limited by cpu. If you have an look on your task manger, you will see that your gpu isn't fully used. Maybe only 50 percent.

Share this post


Link to post
Share on other sites

Things that noticeably affect fps count:

  • screen resolution
  • map size
  • camera zoom and angle
  • number of AI players
  • game speed
  • game graphics settings (options)

Share this post


Link to post
Share on other sites
5 hours ago, tgodtaylor said:

When I go to the ground with Crtl + W I lose 15 fps drop (from 50 to 35)

With Crtl + S nothing changes

#Edit: Zooming in and out drops the lag from 50 to 20

Then I got it. Less you see - less object the game should draw.

@nani and @OptimusShepard are mostly right, we're CPU bound in most cases. I'm working on the bottleneck.

I could recommend to use closer views to prevent drawing of most objects on a scene.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

RenderSubmission seems to take ~50% of the the total render time (measure from the internal profiler). Maybe that part can be threaded as it consist of a bunch of loops (but seems the data from each iterated object is dependent of its parent object as it's seems to traverse to the root object till it finds all has been correctly updated).

Edited by nani
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, nani said:

RenderSubmission seems to take ~50% of the the total render time (measure from the internal profiler). Maybe that part can be threaded as it consist of a bunch of loops (but seems the data from each iterated object is dependent of its parent object as it's seems to traverse to the root object till it finds all has been correctly updated).

The problem isn't the only dependency but also a thread-safety, you can't just run simulation during rendering process, because it might invalidate some rendering data. Another reason is obsolete techniques, we don't use indirect or instancing drawing for example.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...