Jump to content
Sign in to follow this  
Ceniros

New Animation Tool for creating animations for custom models.

Recommended Posts

Check that the vertex groups match the bone names. Avoid '.' in those and replace them by _

Share this post


Link to post
Share on other sites
3 hours ago, Ceniros said:

Should I worry about the names of the bones?

Yeah somewhat. Usually it's nice to prefix them with the armature name ex for bear_armature, prefix all bones with bear_ to avoid skeleton mismatch 

@Alexandermb likely has more tips.

Share this post


Link to post
Share on other sites

As for the bones themselves, can they sort of be separated but still connected like a black line connecting the two bones.

Share this post


Link to post
Share on other sites
7 hours ago, Ceniros said:

As for the bones themselves, can they sort of be separated but still connected like a black line connecting the two bones.

You mean parented but not connected ? Keeping offset. Yes they can, keep in mind what @Stan` mentioned about names. IE if my unit armature has Foot_R and your armature has Foot_R only one of them will work. However they can have a prefix such as Unit_Foot_R and Bear_Foot_R will work together. 

Also mesh needs to have every vertex weight or group event if it's influence it's 0, or the mesh wouldn't recognize in-game the armature bone.

 

Share this post


Link to post
Share on other sites
3 hours ago, Alexandermb said:

You mean parented but not connected ? Keeping offset. Yes they can, keep in mind what @Stan` mentioned about names. IE if my unit armature has Foot_R and your armature has Foot_R only one of them will work. However they can have a prefix such as Unit_Foot_R and Bear_Foot_R will work together. 

Also mesh needs to have every vertex weight or group event if it's influence it's 0, or the mesh wouldn't recognize in-game the armature bone.

 

How do I prevent that from happening. im using 2.81 which is the current version of blender.

Share this post


Link to post
Share on other sites
16 minutes ago, Ceniros said:

How do I prevent that from happening.

I'm sorry, prevent what from happening?

Share this post


Link to post
Share on other sites
3 hours ago, Alexandermb said:

Also mesh needs to have every vertex weight or group event if it's influence it's 0, or the mesh wouldn't recognize in-game the armature bone.

By doing this ^

Share this post


Link to post
Share on other sites
3 hours ago, Ceniros said:

Like the vertex groups need to overlap each other?

Not necessary, have an example of automatic weighthing:

This is a mesh and armature im doing recently so haven't been tested in Atlas:

 

  • Like 1

Share this post


Link to post
Share on other sites

Hey @Ceniros

This error means you have an issue in your template file in

binaries/data/mods/yourmod/simulation/templates/units

Can you show us the file?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...