Jump to content
Sign in to follow this  
Nescio

unable to launch updated development version

Recommended Posts

Happy New Year!

Today I updated my copy of 0 A.D.'s development version, as usual:

Spoiler

svn revert -R *
svn up
cd build/workspaces
./clean-workspaces.sh
./update-workspaces.sh -j7
cd gcc
make clean
make -j7
cd ../../..
binaries/system/test

 

But when I tried to run the game, it failed to launch and instead gave me this:

Spoiler

[b@p50 0ad]$ binaries/system/test 
Running cxxtest tests (329 tests).........................................................................................................................................................................................................................................................................................................................................OK!
[b@p50 0ad]$ binaries/system/pyrogenesis 
TIMER| InitVfs: 235.235 us
Writing the mainlog at /home/b/.config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 2.62775 ms
Sound: AlcInit success, using OpenAL Soft
TIMER| shutdown ConfigDB: 0.466 us
AL lib: (WW) ReleaseALSources: (0x12248c0) Deleted 64 Sources
TIMER| resource modules: 3.94195 ms
TIMER TOTALS (9 clients)
-----------------------------------------------------
  tc_pool_alloc: 0 c (0x)
  tc_png_decode: 0 c (0x)
  tc_dds_transform: 0 c (0x)
  tc_transform: 0 c (0x)
  tc_plain_transform: 0 c (0x)
  tc_ShaderGLSLLink: 0 c (0x)
  tc_ShaderGLSLCompile: 0 c (0x)
  tc_ShaderValidation: 0 c (0x)
  xml_validation: 0 c (0x)
-----------------------------------------------------
TIMER| shutdown misc: 202.266 us
TIMER| InitVfs: 738.682 us
Writing the mainlog at /home/b/.config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 2.43674 ms
Sound: AlcInit success, using OpenAL Soft
Unknown cache/TLB descriptor 0xc3
UserReport written to /home/b/.config/0ad/logs/userreport_hwdetect.txt
TIMER| RunHardwareDetection: 6.41956 ms
TIMER| write_sys_info: 23.4091 ms
TIMER| InitRenderer: 5.77691 ms
TIMER| ps_console: 2.36944 ms
TIMER| ps_lang_hotkeys: 865.383 us
TIMER| common/modern/setup.xml: 522.938 us
TIMER| common/modern/styles.xml: 120.481 us
TIMER| common/modern/sprites.xml: 1.47274 ms
TIMER| common/setup.xml: 598.116 us
TIMER| common/sprites.xml: 530.563 us
TIMER| common/styles.xml: 74.279 us
TIMER| pregame/backgrounds/: 552.178 us
TIMER| pregame/sprites.xml: 119.715 us
TIMER| pregame/styles.xml: 38.975 us
TIMER| pregame/mainmenu.xml: 56.6507 ms
TIMER| common/global.xml: 611.687 us
tex_dds.cpp(485): Function call failed: return value was -120102 (Invalid/unsupported texture format)
Function call failed: return value was -120102 (Invalid/unsupported texture format)
Location: tex_dds.cpp:485 (decode_pf)

Call stack:

(0x9dbc35) Projects/0ad/binaries/system/pyrogenesis() [0x9dbc35]
(0x97ad61) Projects/0ad/binaries/system/pyrogenesis() [0x97ad61]
(0x97c584) Projects/0ad/binaries/system/pyrogenesis() [0x97c584]
(0x97c8b3) Projects/0ad/binaries/system/pyrogenesis() [0x97c8b3]
(0x9fd74c) Projects/0ad/binaries/system/pyrogenesis() [0x9fd74c]
(0x9fa763) Projects/0ad/binaries/system/pyrogenesis() [0x9fa763]
(0x9cdf30) Projects/0ad/binaries/system/pyrogenesis() [0x9cdf30]
(0x9d0947) Projects/0ad/binaries/system/pyrogenesis() [0x9d0947]
(0x7cb9f5) Projects/0ad/binaries/system/pyrogenesis() [0x7cb9f5]
(0x7d6076) Projects/0ad/binaries/system/pyrogenesis() [0x7d6076]
(0x7ca560) Projects/0ad/binaries/system/pyrogenesis() [0x7ca560]
(0x7a9d91) Projects/0ad/binaries/system/pyrogenesis() [0x7a9d91]
(0x7c6f92) Projects/0ad/binaries/system/pyrogenesis() [0x7c6f92]
(0x96f038) Projects/0ad/binaries/system/pyrogenesis() [0x96f038]
(0x965402) Projects/0ad/binaries/system/pyrogenesis() [0x965402]
(0x91a20a) Projects/0ad/binaries/system/pyrogenesis() [0x91a20a]

errno = 0 (No error reported here)
OS error = ?



 

The last time I updated the game was before Christmas, and everything worked then, so I suspect something faulty was introduced in one of the recent commits. @Angen, @Itms, @Stan`

Share this post


Link to post
Share on other sites

Nvtt updates only occur once every ten years maybe more in specific section about common problems and fixes! (But then again not common at all)

Share this post


Link to post
Share on other sites
2 hours ago, Stan` said:

Nvtt updates only occur once every ten years maybe more in specific section about common problems and fixes! (But then again not common at all)

What's the point update that thing? More optimization?

Share this post


Link to post
Share on other sites
9 minutes ago, Lion.Kanzen said:

What's the point update that thing? More optimization?

Could be for textures, but the point is that we are no longer forced to apply a bunch of fixes of our own on top of it for it to work, because they finally releases a new version;

Share this post


Link to post
Share on other sites

Nvtt comes directly from Nvidia so it most likely was not working for their current gpu's so they had to update it even if the standard was defined when Microsoft first introduced DirectX with Win95

Enjoy the Choice :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...