Jump to content
Sign in to follow this  
Udi

Can't start the game on latest Ubuntu

Recommended Posts

Hi all,

I really want to try this game out. I've installed with Ubuntu Software but the game doesn't start. When starting from Terminal this is what I get:

TIMER| InitVfs: 855.84 us
Writing the mainlog at /home/udi/snap/0ad/129/.config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 884.436 us
Sound: AlcInit success, using OpenAL Soft
TIMER| shutdown ConfigDB: 0.311 us
TIMER| resource modules: 2.35962 ms
TIMER TOTALS (9 clients)
-----------------------------------------------------
  tc_pool_alloc: 0 c (0x)
  tc_png_decode: 0 c (0x)
  tc_dds_transform: 0 c (0x)
  tc_transform: 0 c (0x)
  tc_plain_transform: 0 c (0x)
  tc_ShaderGLSLLink: 0 c (0x)
  tc_ShaderGLSLCompile: 0 c (0x)
  tc_ShaderValidation: 0 c (0x)
  xml_validation: 0 c (0x)
-----------------------------------------------------
TIMER| shutdown misc: 168.128 us
TIMER| InitVfs: 78.9122 ms
Writing the mainlog at /home/udi/snap/0ad/129/.config/0ad/logs/mainlog.html
TIMER| CONFIG_Init: 881.7 us
Sound: AlcInit success, using OpenAL Soft
cache.cpp(43): Assertion failed: "cache.Validate()"
Assertion failed: "cache.Validate()"
Location: cache.cpp:43 (AddCache)

Call stack:

(0x55a909ca840e) /snap/0ad/129/binaries/system/pyrogenesis(+0x60440e) [0x55a909ca840e]
(0x55a909c54dd1) /snap/0ad/129/binaries/system/pyrogenesis(+0x5b0dd1) [0x55a909c54dd1]
(0x55a909c571fe) /snap/0ad/129/binaries/system/pyrogenesis(+0x5b31fe) [0x55a909c571fe]
(0x55a909ca0299) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fc299) [0x55a909ca0299]
(0x55a909ca04e7) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fc4e7) [0x55a909ca04e7]
(0x55a909ca1365) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fd365) [0x55a909ca1365]
(0x55a909cd9153) /snap/0ad/129/binaries/system/pyrogenesis(+0x635153) [0x55a909cd9153]
(0x55a909ca140e) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fd40e) [0x55a909ca140e]
(0x55a909ca21f2) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fe1f2) [0x55a909ca21f2]
(0x55a909cd9153) /snap/0ad/129/binaries/system/pyrogenesis(+0x635153) [0x55a909cd9153]
(0x55a909ca1e6a) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fde6a) [0x55a909ca1e6a]
(0x55a909927d15) /snap/0ad/129/binaries/system/pyrogenesis(+0x283d15) [0x55a909927d15]
(0x55a9099182a9) /snap/0ad/129/binaries/system/pyrogenesis(+0x2742a9) [0x55a9099182a9]
(0x55a909703dd8) /snap/0ad/129/binaries/system/pyrogenesis(+0x5fdd8) [0x55a909703dd8]
(0x55a9096f3777) /snap/0ad/129/binaries/system/pyrogenesis(+0x4f777) [0x55a9096f3777]
(0x7f4b4e815b97) /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) [0x7f4b4e815b97]

errno = 0 (Try again later)
OS error = ?

 

Any ides what I should do to resolve this?

 

Thanks a lot!

Share this post


Link to post
Share on other sites

Not enough info inferring from the path shown you used the SNAP version to install which is probably a good thing as the version in the Ubuntu repo's will not connect to our multi-player lobby it's to old now could you post the last lines of the mainlog file that should give us more info on where exactly it is bailing out as is it appears to be a cache related and since this an initialisation run is weird in other words the cache is being created so it should be ok as it's never been touched.

Enjoy the Choice :) 

Share this post


Link to post
Share on other sites
 <p>Loaded config string "view.near" = "2.0"</p>
 <p>Loaded config string "view.far" = "4096.0"</p>
 <p>Loaded config string "view.fov" = "45.0"</p>
 <p>Loaded config string "view.height.smoothness" = "0.5"</p>
 <p>Loaded config string "view.height.min" = "16"</p>
 <p>Cannot find config file "config/local.cfg" - ignoring</p>
 <p>Loading config file "config/user.cfg"</p>
 <p>Loaded config string "userreport.enabledversion" = "0"</p>
 <p>Loaded config string "userreport.id"</p>

 

The version I have is 0.0.23, which is the latest one, isn't it? Should I install the game differently then?

Thanks for your assistance!

Edited by Udi

Share this post


Link to post
Share on other sites

We currently have an issue with Ryzen CPUs. You can fix it by recompiling the game. Would you like me to guide you through that?

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, Stan` said:

We currently have an issue with Ryzen CPUs. You can fix it by recompiling the game. Would you like me to guide you through that?

Yea sure, or link to a guide if there is one.

Thanks a lot!

Share this post


Link to post
Share on other sites

See BuildInstructions.

$ svn checkout -r 21945 https://svn.wildfiregames.com/public/ps/trunk/ 0ad

This will clone the A23B release on your machine. Then you'll need the dependencies in the link above.

$ sudo apt-get install build-essential cmake libboost-dev libboost-filesystem-dev   \
    libcurl4-gnutls-dev libenet-dev libgloox-dev libicu-dev    \
    libminiupnpc-dev libnvtt-dev libogg-dev libopenal-dev   \
    libpng-dev libsdl2-dev libvorbis-dev libwxgtk3.0-dev libxcursor-dev  \
    libxml2-dev python subversion zlib1g-dev

If svn isn't installed you need to run

$ sudo apt install subversion

Then you need to apply the patch: D2353. On the top right select "download raw diff". After that you can patch your svn

$ patch -p0 -i ~/D2353.diff

Alternatively you can just edit the file directly.

Finally you need to run

$ ./build/workspaces/update-workspaces.sh -j(ncore +1)

Then cd into build/workspaces/gcc and run

$ make -j(ncores+1)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...