Jump to content
Sign in to follow this  
wowgetoffyourcellphone

[Fixed] AI building tons of Stables

Recommended Posts

52 minutes ago, Stan` said:

I remember @Nescio unifying somrthing related to it.

The AI checks for the `Stable` class, then builds the `{civ}_stable.xml` structure. The problem in Delenda Est is that the generic template had a `Stables` (with s) class, which means the AI can't find any Stable and will continue to build more. I made a pull request to solve it for you: https://github.com/JustusAvramenko/delenda_est/pull/20

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Nescio said:

The AI checks for the `Stable` class, then builds the `{civ}_stable.xml` structure. The problem in Delenda Est is that the generic template had a `Stables` (with s) class, which means the AI can't find any Stable and will continue to build more. I made a pull request to solve it for you: https://github.com/JustusAvramenko/delenda_est/pull/20

If i remember corectly this is still issue in Millennium AD.

  • Like 1

Share this post


Link to post
Share on other sites
30 minutes ago, asterix said:

If i remember corectly this is still issue in Millennium AD.

Related but different: the problem with Delenda Est is that it duplicates hundreds of files from the public repository, which makes it hard to maintain. Millennium AD doesn't have its own version of `template_structure_military_stable.xml`; the issue here is that byza, caro, umay were updated, but `anglo_stables.xml` was forgotten.

  • Like 1

Share this post


Link to post
Share on other sites

Well, the stables were working fine until there was a change to core game. :) But it's fixed now, thanks. 

I am also quite sure that many of the files DE has were innovations at the time of their creation, but only later were made obsolete by core game upgrades and changes (I am quite sure some of DE's actor files have been used, but that's okay, open source of course and the point of it all). 

Edited by wowgetoffyourcellphone

Share this post


Link to post
Share on other sites
On 8/25/2019 at 4:28 AM, Nescio said:

The AI checks for the `Stable` class, then builds the `{civ}_stable.xml` structure. The problem in Delenda Est is that the generic template had a `Stables` (with s) class, which means the AI can't find any Stable and will continue to build more. I made a pull request to solve it for you: https://github.com/JustusAvramenko/delenda_est/pull/20

 

On 8/25/2019 at 5:20 AM, wowgetoffyourcellphone said:

Thanks. Merged.

Quote

ERROR: RelaxNGValidator: Validation error: structures/mace_elephant_stables:1: Expecting an element GenericName, got nothing

ERROR: RelaxNGValidator: Validation error: structures/mace_elephant_stables:1: Invalid sequence in interleave

ERROR: RelaxNGValidator: Validation error: structures/mace_elephant_stables:1: Element Identity failed to validate content

ERROR: RelaxNGValidator: Validation failed for '(null)'

ERROR: Failed to validate entity template 'structures/mace_elephant_stables'

ERROR: JavaScript error: gui/session/session.js line 227 Error: deepfreeze requires exactly one object as an argument. GetTemplateData@gui/session/session.js:227:1 g_SelectionPanels.Construction.setupButton@gui/session/selection_panels.js:222:18 setupUnitPanel@gui/session/unit_commands.js:95:8 updateUnitCommands@gui/session/unit_commands.js:147:4 updateSelectionDetails@gui/session/selection_details.js:471:2 updateGUIObjects@gui/session/session.js:945:2 onTick@gui/session/session.js:815:3 __eventhandler101 (tick)@session tick:0:1

This one is perplexing me, since the Indentity and GenericName elements look just fine in the templates. Not sure what it's barking about.

Share this post


Link to post
Share on other sites

That bug was fixed? I was really sick of seeing that mess and how it created lag that ai behavior.

Edited by Lion.Kanzen

Share this post


Link to post
Share on other sites

Even when he takes the time for complete sentences he still has a tendency to use Spanish grammarB) which can be confusing for English and non English speakers.

  Enjoy the Choice :)

Edited by Loki1950
spelling error

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...