Jump to content
Sign in to follow this  
hades11

Crash Win10, Ken Wood

Recommended Posts

Hi,

thank you for your great work so far!

I used to play 0 A.D. with an old PC (I7 950, 6GB DDR3 GTX970 Win7) very well, except for some slowdowns in very big games.

Since i changed to my new PC i cant finish a game because it crashs.

New PC:

I7 9700k

16GB DDR4

RTX 2080

Crucial MX500 1TB

Win10

Resolution: 1440x2560, 144FPS, GSync Compatible ON

Grafiktreiber: 419.35

See the "0AD.txt" for the complete text of the error window.

Because it says "not enough Memory"  i made a Screenshot of the Memory used at the time the crash occured. As you can see there is plenty of Memory left. The Games are not that big, i hardly get over 300 Supply (i hope supply is the right word for "Bevölkerungslimit", i only know the german version of the game) in a game with only me and 3 KI on a Giant map. The old PC used to be fine - besides of some performace isues - with me, 7 KI even with 1800 used Supply (from my units alone). All together i´m pretty sure that it is not caused by too big games.

If i hit the "continue" button in the error window i can continue to play for a few minutes before the game finally crashes, this time without any error windows.  If i save the game after the first error and load it new (restarting 0 A.D.) it runs just like i started a new game (this means 10 - 30 Minutes time before the error window shows up). To me it seems as if the Savegame was healthy, but i decided to upload it anyway, maybe you can see more then i.

i also found some graphical issues, but those were easy to fix, i just need to torn off Fog in the graphics menu. Once it was turned of, i can turn it on and everything is fine. I can also fix that by turning OpenGL2.0 shaders of. While this helped me perfectly with the graphical issue it had no effect on the crashes.

I know some errors are not fixed over night and you have also other stuff on your todo-list, so take your time. Just tell me if, and wich aditional information you need.

0AD.PNG

0AD.txt savegame-0003.0adsave

  • Like 1

Share this post


Link to post
Share on other sites

Hello @hades11and welcome to the forum!

I know your error; it has been speculated it could be memory leaking. Unfortunately I don't really have the feeling that there's a solution coming, so I basically sit it out and just hope the next alpha at least will have autosave. :/

 

Klugschiss:

Spoiler

Bevölkerungslimit = pop(ulation) cap

KI = AI

;)

 

Share this post


Link to post
Share on other sites

Here i have the complete logfolder, including the crashlogs.

Thank you for your help with the vocabulary, i really should have known that.

Is this error only occuring on Win10?

If yes i could work around using a dualboot Linux.

For now i test all graphic settings to lowest/off, if it is a memory leak thats caused by a graphical effect this might help. 

EDIT: Since i used an older 0 A.D. version on my old PC i cant tell if this problem is older or just new with Ken Wood. Do you see any chance that switching back to an older 0 A.D. version could help?

I also try some diffrent races, maybe the Memleak is limited to some graphics effect that onnly (or mostly) occures on certain races.

 

0AD_logs.zip

Edited by hades11

Share this post


Link to post
Share on other sites

I just had a first success, turning all graphical options except Opengl 2.0 shaders of helped. I just had a game  over 1 hour without a crash. Maybe it´s a faction related problem, all games that crashed i choose Carthaginians, for the working one i had Ptolemies.

Next step for me is to try and figure out if i can play with high graphics and ptolemies without crashes. When i know this i try the older versions to see wich one is the first with crashes.

Of course, i havent done hundreds of games for testing this, so all testing results may be affected by coincidence.

Share this post


Link to post
Share on other sites
6 hours ago, hades11 said:

Is this error only occuring on Win10?

Nah, I have it on Win 8.1.

Most common advice around here is to turn off GLSL and post processing in the graphics options; chances are you'll be fine just trying that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...