Jump to content
Sign in to follow this  
mimo

0ad bug with firefox 55?

Recommended Posts

mimo    298

Since my update to firefox 55,  I'm facing a strange bug: each time i start a 0ad game, all my firefox tabs become empty, even when reloading. Reopening a new tab works though.

It could be a bug with firefox55, but no other application apart 0ad give me that problem.

Anybody facing the same problem? I've 2 pc with kubuntu 17.04 and both have it.

 

Share this post


Link to post
Share on other sites
feneur    1,430

IIRC SpiderMonkey can either be system-wide or specific to 0 A.D. could it be that you are using the former and that somehow affects things? I would assume not as that would have been more logical if you always had the issue, than if it just has begun. SpiderMonkey is all that 0 A.D. and FireFox has got in common though, right? :unsure:

  • Like 1

Share this post


Link to post
Share on other sites
mimo    298
20 minutes ago, fatherbushido said:

Have you some firefox extensions?

I had disabled them, with still the same problem.

Share this post


Link to post
Share on other sites
mimo    298
20 minutes ago, feneur said:

IIRC SpiderMonkey can either be system-wide or specific to 0 A.D. could it be that you are using the former and that somehow affects things? I would assume not as that would have been more logical if you always had the issue, than if it just has begun. SpiderMonkey is all that 0 A.D. and FireFox has got in common though, right? :unsure:

As i was not sure how it is set when i compile it, i've installed the 0ad A22 package from ppa:wfg/0ad and have the same problem.

Share this post


Link to post
Share on other sites
mimo    298

After some investigation, the problem is linked to the new tab multithreading of firefox, actived by default on my kubuntu with firefox 55. I switched "browser.tabs.remote.autostart.2" to false in about:config and that cured the problem (although loosing the multi-threading).

But still i don't understand why this only happened when starting Oad. I'd be interested if others are also running firefox 55: what are your values of

browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 in about:config? and do you see the same problem when multithread is activated?

 

 

  • Like 1

Share this post


Link to post
Share on other sites
fatherbushido    289

I am running it too. I will check the value.

edit:

browser.tabs.remote.autostart -> false (default)

browser.tabs.remote.autostart2 -> true (modified, that's perhaps a debian patch)

Share this post


Link to post
Share on other sites
mimo    298

I had the same values, and you have no problems when starting 0ad while firefox was open with some tabs? should then be something in my system

Share this post


Link to post
Share on other sites
Guest Dunedan   
Guest Dunedan

Got the same problem as well with Firefox 55 under Debian. Happens with Alpha 21 directly from the Debian archive as well as with a manually compiled Alpha 22, which should use mozjs shipped with 0ad. So I'm quite puzzled where the relation is coming from.

Share this post


Link to post
Share on other sites
mimo    298

Thanks Dunedan, at least i'm not alone with that bug :)

PS  An additionnal info,  the problem does not happen with non-visual replays

Share this post


Link to post
Share on other sites
Dunedan    0

Just wanted to point out that this problem went away for me without touching 0ad. So I believe some updated Debian package fixed it.

Share this post


Link to post
Share on other sites
Dunedan    0

Ok, that was to early. The problem appeared back again, but this time I noticed that it's not related to 0ad at all. Apparently that problem appears whenever compositing for my DE gets enabled or disabled. As running 0ad disables it, it looked like it is related to 0ad, while it is not.

For somebody running with KDE it should be fairly simply to check: Start Firefox and open some page, switch compositing with CTRL + Shift + F12 and you should see blank pages in Firefox.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×