Jump to content

Recommended Posts

Hey there everyone! 0.4 is being re-released, due to a change in the UI for 0AD's re-release of 0.23 that completely broke and prevented multiplayer matches: https://www.moddb.com/mods/hyrule-conquest/downloads/hyrule-conquest-04-re-release

Unfortunately, the nature of their change requires everyone to take an extra step to get the mod to run properly, namely you have to manually delete a configuration folder in C:\Users\User\AppData\Roaming\0ad folder. Exodarion has a handy tutorial below on how to pull that off, as well as general installation instructions for those that have never installed the game before. Deleting the configuration file is timestamped at 7:45

I apologize for this extra step needed, it should be unecessary for future versions of Hyrule Conquest. 

Share this post


Link to post
Share on other sites
5 hours ago, The Undying Nephalim said:

I apologize for this extra step needed, 

I wonder what change could have broken your setup... 

(That really sounds like you've done some quite hacky things ;))

Share this post


Link to post
Share on other sites
20 minutes ago, Imarok said:

I wonder what change could have broken your setup... 

(That really sounds like you've done some quite hacky things ;))

We had messed with the gamesetup.js and gamesetup.xml file before the re-release. We fixed both files after the re-release came out, but for some reason user.cfg would not recognize the changes and made anything beyond the main menu inaccessible. Disabling the mod, starting a single player match in 0AD, and the  re-enabling the mod fixed the problem, or just outright deleting user.cfg and letting it regenerate.

@Exodarion probably has a more accurate description of what exactly the problem was.

Edited by The Undying Nephalim

Share this post


Link to post
Share on other sites

I dont really believe this was anyones '"fault" nor does it really matter tbh. We basically used edited versions of the gamesetup and mainmenu files from the previous 0AD version, which caused multiple errors and conflicts. After updating them both the mod was fixed although it is true that the user settings had to be nuked for it to work again.
 

Edited by Exodarion

Share this post


Link to post
Share on other sites
3 hours ago, Ozerol Notna said:

Does unit experience still work by the way? How do we know the heroes' abilities function the way they are described as?

Unit experience is disabled at the moment. Hero abilities are also disabled until a functional system is working in the engine. At the moment only aura based abilities and some hacky stuff is possible.

Share this post


Link to post
Share on other sites
11 hours ago, The Undying Nephalim said:

Unit experience is disabled at the moment. Hero abilities are also disabled until a functional system is working in the engine. At the moment only aura based abilities and some hacky stuff is possible.

What about dodging and stuff?

Can there be a system like Total War Warhammer with melee attack and melee defence?

Share this post


Link to post
Share on other sites
5 hours ago, Ozerol Notna said:

What about dodging and stuff?

Can there be a system like Total War Warhammer with melee attack and melee defence?

I think, dodging was in 0.4 changelog. So should be in game, yes. :P

Edited by MCreeper

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×