fritzmyname

Game crashing when loading map

15 posts in this topic

Hi @all,

I'm new to this forum and the game, so please go easy on me. I love the game from what I have seen, but sadly I can't play it.

First: I did google my problem, tried everything that was suggested, redownloaded, uninstalled, tried different locations for installement. I even found a similar thread from a few years ago, but it turned out that my problem is not sound-related (trying without sound didn't work for me, but did for the other guy)

Now the actual problem:

When I try to start a single player game, the game crashes while loading the map. Everything up to this point works great! After crashing, I get this message:

 

 

Much to our regret we must report the program has encountered an error.

Please let us know at http://trac.wildfiregames.com/ and attach the crashlog.txt and crashlog.dmp files.

Details: unhandled exception (Access violation reading 0x00000000)

Location: unknown:0 (?)

Call stack:

(error while dumping stack: No stack frames found)
errno = 0 (No error reported here)
OS error = 0 (no error code was set)

 

(This message varies; 

Details: unhandled exception (Access violation reading 0x65762065)

This number is different from time to time...)

 

I would gladly supply the crashlog.txt and crashlog.dmp, but I don't know where to find them. In the error message is nothing else.

I thank you wholeheartedly for your support in advance :)

Kind regards

Edit: I have an Acer Travelmate 7750G Laptop which supports games like ARMA without problems, so that's that. Win7, 4GB RAM

 

Edited by fritzmyname

Share this post


Link to post
Share on other sites

To find those missing crash files the start menu item for 0 AD has an item to open proper folder they are in.

Enjoy the Choice :)

1 person likes this

Share this post


Link to post
Share on other sites

Yes,the same error: 

WARNING: Unable to verify timestamp for ntdll.dll
*** ERROR: Module load completed but symbols could not be loaded for ntdll.dll

Share this post


Link to post
Share on other sites

Update: I installed it on my brother's laptop (even older Travelmate, but Win10) and it worked :o

 

Now whats the problem with mine??

Share this post


Link to post
Share on other sites

Try disabling all graphics settings, especially GLSL.

Do other 3D apps work flawlessly?

If I had to guess, I'd assume it's the graphics driver. What graphics card is installed?

1 person likes this

Share this post


Link to post
Share on other sites

Both laptops are stock and both are capable of running graphic-heavy programs. My brother's laptop is even older (it's the previous version of mine). I am by no means an expert and don't know a lot about PC hardware :o

the graphics card is a AMD Radeon HD 6650 1GB VRAM

I run games like ARMA 3 without problems and also design/engineering programs like Revit, ACAD etc. I don't think it's the graphics card fault, especially considering that my brother's is even worse and it work on his.

What does the crashlog say? Is there some information? Again, I'm an engineering student, no computer scientist...;)

is there some kind of script or something I could change?

 

2 hours ago, elexis said:

Try disabling all graphics settings, especially GLSL.

You mean ingame in the options? I tried and it still fails. What's GLSL?

 

Again, thank you for your support and excuse me for my lack of knowledge

Share this post


Link to post
Share on other sites

GLSL https://en.wikipedia.org/wiki/OpenGL_Shading_Language basically what the fancy shaders for the game are written in and no they are not supported by Microsoft's DX11 the game uses Open Graphics like blender for it's graphical interface as it is cross platform ie: it works on Macs and Linux so we do not have to code three different ways to support these platforms it was developed by Silicon graphics a long time ago then Open sourced from the crash log you posted your driver supports version 4.1.10527 which should be alright though I notice that you also have a INTEL GPU as well which is enabled that may be the issue as Intel's OpenGL support sucks big time.

Enjoy the Choice :)

Share this post


Link to post
Share on other sites

Hm, that graphics card should be fine enough.

Perhaps it is also an installation problem, sometimes the game crashes when it can't read data from the disk or some directory. This has happened before when people changed the username, did some upgrade, renamed directories or similar things. Could try to reinstall, perhaps to a different directory.

1 person likes this

Share this post


Link to post
Share on other sites

I already did all this. I changed the username, disabled all graphics (shadows etc), put the sound to zero. I tried I installing to different directories - to the default setting, to C and so on. I even redownloaded the Torrent and did it all again.

 

is there anything useful in the crashfiles?

Share this post


Link to post
Share on other sites

Someone with windows and visual studio 2013 might open that binary crash dump and figure out what was the last call in 0ad before it crashed and from that postulate what must have happened. The textual file doesn't contain anything besides your system info which looks fine. Perhaps upload a mainlog.html too after a crash.

Must be something specific to your system, probably OS installation. Especially following of the user change, I'd go with checking directory permissions, in particular for the config, cache, logs, replay and root directory of 0ad http://trac.wildfiregames.com/wiki/GameDataPaths.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now