Jump to content
Sign in to follow this  
No1indahoodg

Alpha 18 on OSX Snow Leopard?

Recommended Posts

Is there any other reason besides "most people aren't using it anyway"? (like certain API Support etc)

Yes, because we are using now c++11 in the engine development, and "Apple has decided to only officially support libc++ on 10.7 or higher"

Share this post


Link to post
Share on other sites

Seriously, Apple is so frustrating sometimes. I know snow leopard is 6 years old, but from what I understand it still has a fairly large user base. I don't want to upgrade because of certain software and because I've heard different reports about problems upgrading with bootcamp. Oh well, I can still play this wonderful game on my windows partition. Thanks for the replies.

  • Like 2

Share this post


Link to post
Share on other sites

It wasn't an easy decision to drop older OS X support, but there wasn't much choice, once we decided to use C++11, that restricted us to libc++ on OS X (libstdc++ didn't have adequate C++11 support), which in turn limits us to 10.7+.

I will discuss it again with leper, r16226 might have broken the libstdc++ build, but I was never sure why that was necessary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...