Jump to content
Sign in to follow this  
creaker

[RESOLVED] Alpha 16 - No Sound on Gentoo

Recommended Posts

Hi there!

I've installed 0ad at my Gentoo box, all works fine but without sounds.

I searched on web and found some outdated info relevant to Alpha 10/11.

How do I get sound in current Alpha 16?

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello, can you check in the main menu, in Tools & Options > Options, that the sound values are not set to 0?

If they are ok, the problem must come from your sound system, I know I have often issues when I try to setup sound on LInux ;)

Share this post


Link to post
Share on other sites

Sound settings are set for these values:

Master Gain - 0.9

Music Gane - 0.2

Ambient Gain - 0.6

Action Gain - 0.7

UI Gain - 0.7

Seemes OK.

I found some strangeness: /usr/share/games/0ad/mods/public/ directory hasn't subdirs, only one archive file "public.zip" that contains some data including sounds. I do not know should be this archive extracted or not. I extracted archive content and tried to start game, but it doesn't help.

Any way to get some additional info on this issue? Is it possible to run in debug mode? If so, how do I do it?

Share this post


Link to post
Share on other sites

The zip thing is normal. The problem must come from outside the game, however we should find a way to correct this for the players (and first for you!).

Is anybody familiar with sound on Linux?

Share this post


Link to post
Share on other sites

The public.zip doesn't need to be ex.

tracted.

A system_info.text always helps. Now where was that located on Gentoo?

It will be @ /home/username/.config/0ad/logs as in all Linux systems.

Enjoy the Choice :)

Share this post


Link to post
Share on other sites

Hi Creaker!

You have to check your USE-Flags for games-strategy/0ad in Gentoo and bring the sound-USE-flag in your /etc/portage/package.use. If you want to edit or make some new maps, you should activate the editor-USE-Flag.

games-strategy/0ad
Available versions: (~)0.0.16_alpha-r2^t
IUSE (all versions): editor +lobby pch sound test
Installed versions: Version: 0.0.16_alpha-r2^t
Date: 09:59:28 2014-09-05
USE: editor lobby sound -pch -test
Christian
Edited by emerge -uDNva

Share this post


Link to post
Share on other sites

Yes, it's a sound USE flag issue. I rebuilt game with 'sound" flag, now sound is OK.

Though it is strange enough that "sound' disabled by default, hmm...

But the music is just amazing!

Thanks for helping!

Share this post


Link to post
Share on other sites

It's a Portage flag that Gentoo uses to build the app so it would be the maintainer's responsibility there may also be a distro policy about it as well as lots of Gentoo users like lean builds ;)

Enjoy the Choice :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...