Jump to content
Sign in to follow this  
LordGood

Ponies Ascendant Alpha 1.0

Recommended Posts

ah I might get rid of the auras then, I havent had a problem with them slowing the game (maybe because they're static entities) but then again I haven't built too many. Just being able pushing territory borders seems to be a big gameplay change in itself.

Share this post


Link to post
Share on other sites

Just watched the youtube video. Most impressive - you have put a lot of time into this. I love the medieval building set. I think I was most impressed by your icons which look beautiful. Though I don't understand the pony stuff, well done - bravo :clap:

  • Like 4

Share this post


Link to post
Share on other sites
3 hours ago, Rahman 540 said:

can i use this in a19?

I'm afraid not, I haven't been able to keep this up to date. The logical choice for me would be to truncate it to an A18 standalone to future-proof it, but as it stands now its pre-capturing, so everything is broken atm.

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, Rahman 540 said:

can i use this in a19?

You have access to all code, so if you're interested in modding, you can try updating it yourself.

If you do that, and keep the mod updated with 0 A.D., the mod will be ready for A20.

If you have any questions on how to solve a certain problem, you can join us on IRC chat: https://kiwiirc.com/client/irc.quakenet.org/0ad-dev

  • Like 2

Share this post


Link to post
Share on other sites
7 hours ago, s0600204 said:

Ponies Ascendant has been updated on GitHub so that it works with the recent A20 release of 0AD. Download and enjoy!

You're a godsend mate

Thanks! :D

  • Like 2

Share this post


Link to post
Share on other sites

Nice update, there are also some new menu background images I didn’t remember before!

There are a lot of errors and warnings however:

Spoiler

WARNING: [ParamNode] Could not remove token 'Infantry' from node 'RestrictedClasses' in 'units/spart_support_female_citizen'; not present in list nor inherited (possible typo?)
WARNING: [ParamNode] Could not remove token 'Cavalry' from node 'RestrictedClasses' in 'units/spart_support_female_citizen'; not present in list nor inherited (possible typo?)
WARNING: [ParamNode] Could not remove token 'Champion' from node 'RestrictedClasses' in 'units/spart_support_female_citizen'; not present in list nor inherited (possible typo?)
WARNING: [ParamNode] Could not remove token 'CitizenSoldier' from node 'RestrictedClasses' in 'units/spart_support_female_citizen'; not present in list nor inherited (possible typo?)

ERROR: RelaxNGValidator: Validation error: skirmish/units/default_support_female_citizen:1: Element Auras failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: Failed to validate entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: RelaxNGValidator: Validation error: units/uni_support_female_citizen:1: Element Auras failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: Failed to validate entity template 'units/uni_support_female_citizen'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_infantry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_infantry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_infantry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_infantry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: RelaxNGValidator: Validation error: (null):0: Extra element animations in interleave
ERROR: RelaxNGValidator: Validation error: art/actors/units/unicorns/infantry_spearman_b.xml:6: Element variant failed to validate content
ERROR: RelaxNGValidator: Validation error: art/actors/units/unicorns/infantry_spearman_b.xml:5: Element group has extra content: variant
ERROR: RelaxNGValidator: Validation error: (null):0: Extra element group in interleave
ERROR: RelaxNGValidator: Validation error: art/actors/units/unicorns/infantry_spearman_b.xml:4: Element actor failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: CXeromyces: failed to validate XML file art/actors/units/unicorns/infantry_spearman_b.xml
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_cavalry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_cavalry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_infantry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_infantry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_infantry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_infantry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'
ERROR: CCacheLoader failed to find archived or source file for: "simulation/templates/units/uni_cavalry_javelinist_b.xml"
ERROR: Failed to load entity template 'units/uni_cavalry_javelinist_b'
WARNING: SkirmishReplacer.js: no replacements found in 'uni.json'

Also you may want to update the download link on the first post, still pointing to an old revision.

Share this post


Link to post
Share on other sites

@fabio: I've fixed all issues except the one of the aura. Could you check if you're still on the A20 revision? (and did not accidentally update SVN in the mean time?). Since I don't have that error here...

  • Like 1

Share this post


Link to post
Share on other sites

@niektb : most issues are fixed now, thanks :). Here are the remaining errors:

Spoiler

ERROR: RelaxNGValidator: Validation error: skirmish/units/default_support_female_citizen:1: Element Auras failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: Failed to validate entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: Failed to load entity template 'skirmish/units/default_support_female_citizen'
ERROR: RelaxNGValidator: Validation error: units/earth_support_female_citizen:1: Element Auras failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: Failed to validate entity template 'units/earth_support_female_citizen'
TIMER| LoadDLL: 23.3299 ms
ERROR: RelaxNGValidator: Validation error: units/pega_support_female_citizen:1: Element Auras failed to validate content
ERROR: RelaxNGValidator: Validation failed for '(null)'
ERROR: Failed to validate entity template 'units/pega_support_female_citizen'
TIMER| common/modern/setup.xml: 477.588 us
...
TIMER| common/global.xml: 19.7869 ms
GAME STARTED, ALL INIT COMPLETE
ERROR: JavaScript error: simulation/helpers/Commands.js line 255
TypeError: template is undefined
  g_Commands.train@simulation/helpers/Commands.js:255:1
  ProcessCommand@simulation/helpers/Commands.js:45:3

I am on SVN indeed, but are there already some incompatible changes vs A20? EDIT: will try and report with A20.

Share this post


Link to post
Share on other sites

I really want to play this mod but I keep getting this error in the console/notification(?) spammed nonstop at the top left and I don't know what is causing it. I also cannot build the structure to the far left of the build panel with the mod.

(error I keep getting) JavaScript error: simulation/helpers/commands.js line 267 TypeError: template is undefined g_commands.trainSimulation/helpers/commands.js: 267: 1 Failed to call ProcessCommand( ) global script function

Also to get the mod to work I had to go into the mods.json file and turn the 20 in "dependencies" to 21. If that is what is causing the error I am sorry for wasting your time as this was an issue produced by me.

Can anybody please help me? I really want to play this mod and the creator (LordGood) told me to try this out for help.

  • Like 1

Share this post


Link to post
Share on other sites

@balduin, @AtomicGaming the mod apparently wasn't updated to A21 compatibility yet. You can install 0 A.D. A20 and play in the latest version of Ponies Ascendant on it for now. And hopefully someone will update the mod soon :) (I will try to look at it myself too, but I don't promise anything, since I don't have much free time)

Share this post


Link to post
Share on other sites

@AtomicGaming Thanks for trying that out. In this case somebody has to make Ponies Ascendant compatible with A21.

@fcxSanya Thanks for the explanation. But, I use the Arch Linux package for 0 A.D., which gets constant updates. The current version of the game is A21-3 which means the package maintainer(s) updated the package since the release of A21 several times. Therefor, I am not really willing to downgrade from A21 to A20.

Share this post


Link to post
Share on other sites

@balduin, @AtomicGaming, @stanislas69 I made a pull request with fixes for issues I was able to find: https://github.com/0ADMods/ponies_ascendant/pull/9 , please review / playtest :)

(there is a remaining "Extra element props in interleave" error with art/actors/structures/pegasi/house.xml , but I'm not sure whether it's a21-specific or was present before; going to examine it a bit more)

Share this post


Link to post
Share on other sites

For the remaining error I would try to remove/alter the minheight property at line 7:

<prop actor="props/structures/decals/city_tile_3x3.xml" attachpoint="root" minheight=""/>
      
  • Like 2

Share this post


Link to post
Share on other sites

@niektb by some reason I can't reproduce it now (without any changes). It should be enough to start a match as pegasi and try to build a house, right? (I think that's what I did when I got the issue for the first time).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...